Advertisement:

Author Topic: Whole forum is down due to a corrupt table  (Read 5441 times)

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 57,508
  • Gender: Male
    • Kindred-999 on GitHub
Re: Whole forum is down due to a corrupt table
« Reply #40 on: December 09, 2018, 03:24:27 PM »
Well, because making an official release is not simple...   and, as the page clearly states, beta versions should not be used in production, nor should they be used unless you understand technical and debugging processes.

2.0.15 is the current release in the main supported branch.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 69,910
    • StoryBB/StoryBB on GitHub
Re: Whole forum is down due to a corrupt table
« Reply #41 on: December 09, 2018, 03:29:43 PM »
Beta versions should be taken from GitHub where the development happens - beta 3 is over a year old, with 'beta 4' being developed since.

Curious why the newest version is not here on SMF, as it  may create confusion about what is the latest version available,

Because it changes literally nearly every day...
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline backend

  • Jr. Member
  • **
  • Posts: 191
Re: Whole forum is down due to a corrupt table
« Reply #42 on: December 09, 2018, 07:53:02 PM »
thanks guys, i ended up using the 2.0.15 Large Upgrade (https://download.simplemachines.org/index.php?thanks;filename=smf_2-0-15_upgrade.zip)

Now having another issue with the update:

"Server has not responded for 30 seconds. It may be worth waiting a little longer or otherwise please click here to try this step again"[/b}

And this has been for hours and it is still stuck on "Executing: "Updating and creating indexes..." (1 of 19 - of this script)"




Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,241
Re: Whole forum is down due to a corrupt table
« Reply #43 on: December 09, 2018, 08:04:22 PM »
there are no database changes since SMF 2.0 was released, you dont need to run the upgrade script. also it is recommend to use the package manager patches to upgrade if you are already on some sub version of SMF 2.0.

if you did use the large upgrade package that means you have uninstalled maybe even partially uninstalled your mods and may need to reinstall them when you are done.

Offline backend

  • Jr. Member
  • **
  • Posts: 191
Re: Whole forum is down due to a corrupt table
« Reply #44 on: December 09, 2018, 08:07:49 PM »
there are no database changes since SMF 2.0 was released, you dont need to run the upgrade script. also it is recommend to use the package manager patches to upgrade if you are already on some sub version of SMF 2.0.

if you did use the large upgrade package that means you have uninstalled maybe even partially uninstalled your mods and may need to reinstall them when you are done.

To make a long story short, assuming you didn't follow this thread from the beginning (Gosh, even I forgot some of the details lol) , we had to upgrade because we were having issues and I kept getting errors. One of which was the following : "Unknown column 'add_deny' in 'field list'"

After some research, I found out it had to do with running old files/DB and needed to upgrade to new version of PHP which I did.

« Last Edit: December 09, 2018, 08:18:08 PM by backend »

Offline backend

  • Jr. Member
  • **
  • Posts: 191
Re: Whole forum is down due to a corrupt table
« Reply #45 on: December 12, 2018, 01:17:44 AM »
there are no database changes since SMF 2.0 was released, you dont need to run the upgrade script. also it is recommend to use the package manager patches to upgrade if you are already on some sub version of SMF 2.0.

if you did use the large upgrade package that means you have uninstalled maybe even partially uninstalled your mods and may need to reinstall them when you are done.

To make a long story short, assuming you didn't follow this thread from the beginning (Gosh, even I forgot some of the details lol) , we had to upgrade because we were having issues and I kept getting errors. One of which was the following : "Unknown column 'add_deny' in 'field list'"

After some research, I found out it had to do with running old files/DB and needed to upgrade to new version of PHP which I did.



If I don't upgrade, I am getting '"Unknown column 'add_deny' in 'field list'"'

And I do try to upgrade, I am stuck at 14% and mot moving. Been trying it for days.

If I could get over '"Unknown column 'add_deny' in 'field list'" without having to upgrade, would be a lot better.



Any advise?


Offline SpacePhoenix

  • Semi-Newbie
  • *
  • Posts: 49
Re: Whole forum is down due to a corrupt table
« Reply #46 on: December 12, 2018, 02:04:57 AM »
And I do try to upgrade, I am stuck at 14% and mot moving. Been trying it for days.
When it gets stuck at 14% are there any errors in either the PHP or MySQL error logs?

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,447
  • Riding the endless highway in the sky.
Re: Whole forum is down due to a corrupt table
« Reply #47 on: December 13, 2018, 04:09:25 PM »
If I could get over '"Unknown column 'add_deny' in 'field list'" without having to upgrade, would be a lot better.

Well, you can't.  A 1.1 database will not work in 2.0.15 install.  Upgrade will sometimes fail if you're on a really crappy server.  I've had to upgrade several forums by importing db to test install on my host, upgrade, import upgraded db to original forum.

Offline backend

  • Jr. Member
  • **
  • Posts: 191
Re: Whole forum is down due to a corrupt table
« Reply #48 on: January 02, 2019, 11:18:02 PM »
Happy new year everyone. Been busy last couple of weeks with the holidays so haven't been able to work on this.

I am running the upgrade again and I am stuck at 14%, with the following error message:

"Executing upgrade script 1 of 2.
Executing: "Updating and creating indexes..." (1 of 19 - of this script)

!!Error!
Server has not responded for 30 seconds. It may be worth waiting a little longer or otherwise please click here to try this step again"


I have run this a million times and it keeps getting stuck at the same percentage, so there is clearly something wrong that is preventing this from progressing.


Please advise!


Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,734
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Whole forum is down due to a corrupt table
« Reply #49 on: January 03, 2019, 01:29:48 AM »
That error is a bit misleading, as it doesn't actually mean the script has stopped. Allow it some time, and it will try to continue automatically.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,447
  • Riding the endless highway in the sky.
Re: Whole forum is down due to a corrupt table
« Reply #50 on: January 03, 2019, 04:38:47 PM »
Just reread this topic, still on GoDaddy?  That's your biggest problem right now.  Are you trying to upgrade a 1.1 datrabase to 2.0?  Is the 1.1 database currently running in a 1.1 install?  Have you dropped the backup tables?