Advertisement:

Author Topic: Memcache Error: memcache_connect Connection refused  (Read 964 times)

Offline spiros

  • Language Moderator
  • SMF Hero
  • *
  • Posts: 1,662
  • Gender: Male
  • A different point of view
    • spiros.doikas on Facebook
    • doikas on LinkedIn
    • @greektranslator on Twitter
    • Greek Translation
Memcache Error: memcache_connect Connection refused
« on: May 11, 2018, 06:25:40 AM »
I see 1000s of these error in error log. Memcache not working OK?

Code: [Select]
memcache_connect(): Server 127.0.0.1 (tcp 11211, udp 0) failed with: Connection refused (111)Apply Filter: Only show the errors from this file File:
forum/Sources/Load.php
Line: 2883

Offline drewactual

  • Jr. Member
  • **
  • Posts: 305
    • College Football Fan Site CFB51
Re: Memcache Error: memcache_connect Connection refused
« Reply #1 on: June 15, 2018, 11:41:30 AM »
it likely isn't working..

you can either draft and implement a crom for the service to start, or, you have to manually start it each time you restart the server.  it drives me nuts too.

on my apache machine running centos7x i ssh and use:
Code: [Select]
memcached -d -m 512 -l 127.0.0.1 -p 11211 -u nobody
and it's good until next shutdown restart.
https://www.cfb51.com is a College Football Fan Site, Store, and Publisher, launched in July of 2017

Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,139
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: Memcache Error: memcache_connect Connection refused
« Reply #2 on: June 15, 2018, 01:03:00 PM »

You can also try using a different accelerator.
Install one of the other supported ones if need be.

Offline spiros

  • Language Moderator
  • SMF Hero
  • *
  • Posts: 1,662
  • Gender: Male
  • A different point of view
    • spiros.doikas on Facebook
    • doikas on LinkedIn
    • @greektranslator on Twitter
    • Greek Translation
Re: Memcache Error: memcache_connect Connection refused
« Reply #3 on: July 07, 2018, 06:11:13 AM »
For CentOS 7

To tell the service to start at reboot:
Code: [Select]
systemctl enable memcached