Advertisement:

Author Topic: Error with MediaWiki Integration  (Read 571 times)

Offline Torngate

  • Semi-Newbie
  • *
  • Posts: 28
  • Gender: Male
    • Torngate on GitHub
    • Shadow Fleet
Error with MediaWiki Integration
« on: May 16, 2018, 07:22:16 PM »
Hello all,

I recently tried to set up a MediaWiki alongside my forum, and ran into some issues. I found and started to utilize this script that is apparently used to link SMF's own forum and the same wiki software as I now am trying to set up.

However, on several admin-level tasks, I run into an error:

Warning: require_once(/Subs-Db-.php): failed to open stream: No such file or directory in /XXXX/XXXX/public_html/databank/extensions/Auth_SMF.php on line 991

Code: [Select]
Fatal error: require_once(): Failed opening required '/Subs-Db-.php' (include_path='/xxxx/xxxx/public_html/databank/vendor/pear/pear_exception:/xxxx/xxxx/public_html/databank/vendor/pear/console_getopt:/xxxx/xxxx/public_html/databank/vendor/pear/mail_mime-decode:/xxxx/xxxx/public_html/databank/vendor/pear/net_smtp:/xxxx/xxxx/public_html/databank/vendor/pear/pear-core-minimal/src:/xxxx/xxxx/public_html/databank/vendor/pear/mail:/xxxx/xxxx/public_html/databank/vendor/pear/mail_mime:/xxxx/xxxx/public_html/databank/vendor/pear/net_socket:.:/usr/php/56/usr/lib64:/usr/php/56/usr/share/pear') in /xxxx/xxxx/public_html/databank/extensions/Auth_SMF.php on line 991
I am ashamed to admit I don't know the first lick of PHP, but would really appreciate any help that could be rendered.

Forum's url scheme looks like: XXXX.org/forum
Wiki looks like: xxxx.org/databank

Any help would be much appreciated. I'll provide any additional information as may be needed as I am best able.

Cheers!
Site Administrator- Shadow Fleet Star Trek RPG

Offline Aleksi "Lex" Kilpinen

  • Support Specialist
  • SMF Super Hero
  • *
  • Posts: 16,879
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Error with MediaWiki Integration
« Reply #1 on: May 24, 2018, 11:38:31 AM »
Are you hosted with GoDaddy? Does the file referenced actually exist? If not, then should it?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,706
  • Gender: Male
  • Black cat rulz!
    • Antes on GitHub
    • merta on LinkedIn
    • @XinYenFon on Twitter
    • Lunarfall
Re: Error with MediaWiki Integration
« Reply #2 on: May 24, 2018, 01:47:46 PM »
It looks like $smf_settings['db_type'] returning empty...

Code: (Find) [Select]
require_once($smf_settings['sourcedir'] . '/Subs-Db-' . $smf_settings['db_type'] . '.php');
Code: (Replace) [Select]
require_once($smf_settings['sourcedir'] . '/Subs-Db-' . $db_type . '.php');
(Still not the best solution)
T..s sig..t..e is ce..or.d by S.F T... w..ho.t an ex..an...on.

Past Project(s): [ ezPortal ]