Advertisement:

Author Topic: Problem with 2.0.15 upgrade package?  (Read 335 times)

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,938
  • 'Tis the gift to be simple (duh)
Problem with 2.0.15 upgrade package?
« on: April 24, 2018, 01:10:46 AM »
Just finishing up an especially difficult upgrade, and hit a glitch on what should have been the easy part.  Went from 1.1.12 -> 1.1.21 -> 2.0.1 -> 2.0.15.  When I uploaded 2.0.15 upgrade package and ran it, got the outdated files error.  Uploaded 2.0.15 install package, ran upgrade.php, upgrade successful.  Everything else was the same for both packages.  Have done a lot of upgrades, don't think I ever saw this before.

Offline Aleksi "Lex" Kilpinen

  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,070
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Problem with 2.0.15 upgrade package?
« Reply #1 on: May 01, 2018, 12:32:37 AM »
Could be the language files and the info it's checking for don't match, not a big issue though.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,938
  • 'Tis the gift to be simple (duh)
Re: Problem with 2.0.15 upgrade package?
« Reply #2 on: May 01, 2018, 12:35:45 AM »
Don't know what caused it, was able to replicate the problem on test install.  Did another clean install, d/l'd the current 2.0.15 upgrade package, worked fine.

Offline Aleksi "Lex" Kilpinen

  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,070
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Problem with 2.0.15 upgrade package?
« Reply #3 on: May 17, 2018, 01:14:29 AM »
The upgrade package should include up to date english language, but I know that message can come up with any other language used - including english-utf8, if you do not also update the language files or switch to english. Don't know what else might trigger it though, apart from the original upload of the upgrade files faiiling partially for some reason perhaps.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas