Advertisement:

Author Topic: 403 error  (Read 359 times)

Offline pepa

  • Jr. Member
  • **
  • Posts: 192
403 error
« on: May 16, 2018, 10:43:00 PM »
Trying to modify a post as Admin but getting a 403 error, error lost reveals:

8: Undefined index: customsmiiconApply Filter: Only show the errors from this file File: /home2/reformaps/public_html/forum/Sources/Load.php
Line: 1362

Anyone know what that's about?

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,152
  • 'Tis the gift to be simple (duh)
Re: 403 error
« Reply #1 on: May 16, 2018, 11:14:40 PM »
That's not core code, it's from a mod.

Online vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 20,398
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: 403 error
« Reply #2 on: May 16, 2018, 11:37:30 PM »
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,139
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: 403 error
« Reply #3 on: May 16, 2018, 11:37:44 PM »
The SMF error log clip you reported seems related to this mod:
https://custom.simplemachines.org/mods/index.php?mod=3304

The author has not been active here since December 2016.
That mod has not been updated in quite some time & will not cleanly install on SMF 2.0.15.
Did you manually parse edits or adjust the xml install file to work with SMF 2.0.15?

.. 403 error is usually due to file/folder permissions and may not be related to your error in the SMF log.

Offline pepa

  • Jr. Member
  • **
  • Posts: 192
Re: 403 error
« Reply #4 on: May 17, 2018, 01:02:42 AM »
The SMF error log clip you reported seems related to this mod:
https://custom.simplemachines.org/mods/index.php?mod=3304

The author has not been active here since December 2016.
That mod has not been updated in quite some time & will not cleanly install on SMF 2.0.15.
Did you manually parse edits or adjust the xml install file to work with SMF 2.0.15?

.. 403 error is usually due to file/folder permissions and may not be related to your error in the SMF log.

Yes I installed that mod and made the modifications listed here -> https://www.simplemachines.org/community/index.php?topic=467074.msg3954993#msg3954993

I first installed it on a different host (which I use as a test forum) with no https, checked and all OK ... also I'm not getting the 403 error on that host, it's all good there.

Then installed on my working forum which has https (I have checked the server error logs, via cpanel, and they're empty?)  On my working forum I only seem to be encountering this error when I try to modify some existing posts but not others.  I have two folders at the root level, above the forum.  I have pdf files in those folders that can be downloaded from within the forum, one folder is password protected, the other isn't, but that doesn't seem to be the problem.  I can modify some posts that contain links to files in these folders, but can't modify others (403) error.  This 'seems' to be almost random ... I always get 403 errors trying to modify posts that contain links to files in the password protected folder and in a number ... but not all of the posts containing links to files in the non-protected folder.

Any further ideas on this?


Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,152
  • 'Tis the gift to be simple (duh)
Re: 403 error
« Reply #5 on: May 17, 2018, 01:08:27 AM »
Undefined index should not cause 403 error.  Did you check mod_security?

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,282
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: 403 error
« Reply #6 on: May 17, 2018, 01:10:22 AM »
403 error maybe mod_security related check out https://wiki.simplemachines.org/smf/Mod_security_-_Having_problems_with_mod_security

This would be my suggestion as well, did you look at this? Did it help?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline pepa

  • Jr. Member
  • **
  • Posts: 192
Re: 403 error
« Reply #7 on: May 17, 2018, 01:13:44 AM »
No I didn't check mod security ... will do so now.

Offline pepa

  • Jr. Member
  • **
  • Posts: 192
Re: 403 error
« Reply #8 on: May 17, 2018, 02:01:01 AM »
I'm on a Mac, having all sorts of problems trying to download the .htaccess file and my ftp software won't allow me to edit it, so I've just sent a request to the host.  If they won't disable mod_security I'll try the patch mentioned in that article.

Offline pepa

  • Jr. Member
  • **
  • Posts: 192
Re: 403 error
« Reply #9 on: May 17, 2018, 03:49:28 AM »
OK ... .htaccess file altered to turn mod_security filtering off ... PROBLEM SOLVED : )

Thanks so much everyone for your help!