Advertisement:

Author Topic: Trouble Installing Forum  (Read 1814 times)

Offline novic3

  • Semi-Newbie
  • *
  • Posts: 38
Re: Trouble Installing Forum
« Reply #20 on: May 18, 2018, 11:01:24 AM »
I think I did however I get a 502 error. Am I missing a file? if so which one?

thx

UPDATE: now I get

"Critical Error!
Cannot connect to the database server with the supplied data.

If you are not sure about what to type in, please contact your host."

Offline novic3

  • Semi-Newbie
  • *
  • Posts: 38
Re: Trouble Installing Forum
« Reply #21 on: May 18, 2018, 12:03:40 PM »
I apologize for bumping but here is the diagnostic in the attachment below.

Online vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 20,551
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: Trouble Installing Forum
« Reply #22 on: May 18, 2018, 12:32:12 PM »
You have to create a database user and database using your control panel/cpanel
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline novic3

  • Semi-Newbie
  • *
  • Posts: 38
Re: Trouble Installing Forum
« Reply #23 on: May 18, 2018, 12:36:25 PM »
I added that info of the database and user password but I still get errors. What am I doing wrong?

Thank you for your help and time :)

Offline Illori

  • Project Manager
  • SMF Master
  • *
  • Posts: 49,950
Re: Trouble Installing Forum
« Reply #24 on: May 18, 2018, 12:37:41 PM »
you would need to reach out to your host so they can assist you further.

Offline novic3

  • Semi-Newbie
  • *
  • Posts: 38
Re: Trouble Installing Forum
« Reply #25 on: May 18, 2018, 12:43:13 PM »
so its not me at this point but a file permissions issue with the host?

thx

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 57,213
  • Gender: Male
    • Kindred-999 on GitHub
Re: Trouble Installing Forum
« Reply #26 on: May 18, 2018, 12:53:03 PM »
well, there might be a file permission issue... but the database issue seems to indicate that the values which you put into SMF do not match what your server settings are for the database, database username, database password or database host location...  one or more of those settings would seem to be different from what you are thinking it would be.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline novic3

  • Semi-Newbie
  • *
  • Posts: 38
Re: Trouble Installing Forum
« Reply #27 on: May 18, 2018, 12:58:33 PM »
sorry I am a noob I did not type it correctly. I got it to work but now it tells me to type my url

I typed "http://freeadzworld.com/forum" however, I want users to simply type in google or click freeadzworld.com and be able to reach my site which is a default forum.

How do I achieve this?

thx

-d3vcho; Link removed due to security risk
« Last Edit: May 18, 2018, 01:39:06 PM by novic3 »

Offline novic3

  • Semi-Newbie
  • *
  • Posts: 38
Re: Trouble Installing Forum
« Reply #28 on: May 18, 2018, 02:18:39 PM »
sorry to bump again but where do I find my database password? is that my databse user password?

thx

Online vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 20,551
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: Trouble Installing Forum
« Reply #29 on: May 18, 2018, 02:24:17 PM »
yes
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline novic3

  • Semi-Newbie
  • *
  • Posts: 38
Re: Trouble Installing Forum
« Reply #30 on: May 18, 2018, 02:39:47 PM »
sorry now I got it installed HOWEVER it is white. How do I fix it?

(see attachment)

Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,148
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: Trouble Installing Forum
« Reply #31 on: May 18, 2018, 03:18:05 PM »

You need to use the repair_settings tool to fix your paths.

ref.
https://wiki.simplemachines.org/smf/Repair_settings.php

Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,148
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: Trouble Installing Forum
« Reply #32 on: May 18, 2018, 03:36:45 PM »

Specifically your default theme settings.
You can set them within SMF admin if you want:
Admin -> Current Theme
.. and adjust the url's + path in the "Theme URL's and Configuration Settings" at the top.



There may be more that need adjustment which is why I suggested the repair settings method in my previous post.

Offline novic3

  • Semi-Newbie
  • *
  • Posts: 38
Re: Trouble Installing Forum
« Reply #33 on: May 18, 2018, 03:48:33 PM »

Specifically your default theme settings.
You can set them within SMF admin if you want:
Admin -> Current Theme
.. and adjust the url's + path in the "Theme URL's and Configuration Settings" at the top.



There may be more that need adjustment which is why I suggested the repair settings method in my previous post.

So what do I change the links to? (see attachment)

Thanks for your time


Offline Illori

  • Project Manager
  • SMF Master
  • *
  • Posts: 49,950
Re: Trouble Installing Forum
« Reply #34 on: May 18, 2018, 03:59:12 PM »
at the bottom of the page should be a reset button, click it. it will do the hard work for you.

Offline novic3

  • Semi-Newbie
  • *
  • Posts: 38
Re: Trouble Installing Forum
« Reply #35 on: May 18, 2018, 04:01:21 PM »
at the bottom of the page should be a reset button, click it. it will do the hard work for you.

sorry but I am having trouble finding the "reset" button? you mean hit the "save" button?

thx :)

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 57,213
  • Gender: Male
    • Kindred-999 on GitHub
Re: Trouble Installing Forum
« Reply #36 on: May 18, 2018, 04:02:26 PM »
you have to RESET all of the URLs to use the correct setting, THEN press save
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline a10

  • Charter Member
  • Sr. Member
  • *
  • Posts: 818
Re: Trouble Installing Forum
« Reply #37 on: May 18, 2018, 04:13:01 PM »
Example (see attachment).

Quote
however, I want users to simply type in google or click freeadzworld.com and be able to reach my site which is a default forum.
That can be fixed later (.htaccess redirect), but first I'd think it's best to get the basics to work properly.
2.0.15, ssl, php 7.1.19, MySQL 10.1.30-MariaDB-1~xenial
Mods: Contact Page, Like Posts, Responsive Curve, Search Focus Dropdown.

Offline Chen Zhen

  • Sophist Member
  • *****
  • Posts: 1,148
  • Gender: Male
  • If you're going through hell, keep going!
    • Underdog-01 on GitHub
    • WebDev.ca
Re: Trouble Installing Forum
« Reply #38 on: May 18, 2018, 04:17:41 PM »


Admin -> Themes and Layout -> Theme Settings -> Attempt to reset all themes

Online Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 57,213
  • Gender: Male
    • Kindred-999 on GitHub
Re: Trouble Installing Forum
« Reply #39 on: May 18, 2018, 06:24:26 PM »
that only works if the base URL for the forum is already correct - that's why we use repair_settings.php which can fix ALL of the URLs at once
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.