Advertisement:

Author Topic: smf 2.0.15 no me reconoce los usuarios con tílde  (Read 375 times)

Offline zesna

  • Semi-Newbie
  • *
  • Posts: 40
smf 2.0.15 no me reconoce los usuarios con tílde
« on: July 11, 2018, 04:05:55 AM »
Buenos días, he instalado smf 2.0.15 y he importado la vieja base de datos, con lo que me salen carácteres raros, he probado una codificación y siguen saliendo pero no importa, lo que ocurre es que los usuarios con tílde no se pueden identificar y tampoco por mucho que cambie su contraseña en la base de datos me dice que no existe ese usuario..

Sábeis porque?

Gracias

Offline d3vcho(void)

  • Sempiterno
  • Lead Localizer
  • SMF Hero
  • *
  • Posts: 2,970
  • Gender: Male
    • frandominguez03 on GitHub
    • @_d3vcho on Twitter
Re: smf 2.0.15 no me reconoce los usuarios con tílde
« Reply #1 on: July 11, 2018, 04:35:29 AM »
¿Podrías dejar un enlace a tu foro? ¿Estás usando el paquete de idioma con codificación utf-8?
"Demons are like obedient dogs; they come when they're called"

d3vcho(void)

Offline zesna

  • Semi-Newbie
  • *
  • Posts: 40
Re: smf 2.0.15 no me reconoce los usuarios con tílde
« Reply #2 on: July 11, 2018, 07:27:58 AM »
Hola! muchas gracias por responder, el foro es de tipo privado... podrías adjuntarme por favor el paquete de idiomas de esa codificación? si voy a mantenimiento me sale conventir html-a utf8 y ya lo ejecuté pero en la base de datos pone algo así como swalish_general_ci o parecido, creo que tendría que instalar el paquete de idiomas pero no lo encuentro :S


Offline d3vcho(void)

  • Sempiterno
  • Lead Localizer
  • SMF Hero
  • *
  • Posts: 2,970
  • Gender: Male
    • frandominguez03 on GitHub
    • @_d3vcho on Twitter
Re: smf 2.0.15 no me reconoce los usuarios con tílde
« Reply #3 on: July 11, 2018, 07:33:16 AM »
No en la base de datos no deberías de cambiar nada, lo que tienes que hacer en administración es buscar el menú que ponga "Idiomas" y revisar si los que tienes instalados son con codificación utf-8, en caso negativo, deberías cambiarlos.

Los paquetes se pueden encontrar aquí, para Spanish_es y para Spanish_latin
https://download.simplemachines.org/index.php?languages;id=43
https://download.simplemachines.org/index.php?languages;id=44

Aunque se pueden instalar desde el mismo menú de idiomas que mencioné anteriormente.
"Demons are like obedient dogs; they come when they're called"

d3vcho(void)

Offline zesna

  • Semi-Newbie
  • *
  • Posts: 40
Re: smf 2.0.15 no me reconoce los usuarios con tílde
« Reply #4 on: July 11, 2018, 07:40:16 AM »
Me dicen que no son válidos :S más tarde probaré de nuevo pero qué raro.. gracias de todos modos :)

Offline d3vcho(void)

  • Sempiterno
  • Lead Localizer
  • SMF Hero
  • *
  • Posts: 2,970
  • Gender: Male
    • frandominguez03 on GitHub
    • @_d3vcho on Twitter
Re: smf 2.0.15 no me reconoce los usuarios con tílde
« Reply #5 on: July 11, 2018, 07:41:24 AM »
Si pudieses proporcionarme por privado una cuenta de administrador a tu foro, seguramente podría echarle un vistazo más de cerca al problema.
"Demons are like obedient dogs; they come when they're called"

d3vcho(void)

Offline Rock Lee

  • Local Moderator
  • SMF Hero
  • *
  • Posts: 1,995
  • Gender: Male
  • I also speak english :D
    • BomberCode.Oficial on Facebook
    • RockLee-BC on GitHub
    • @Bomber_Code on Twitter
    • Bomber Code ~ La nueva era del conocimiento
Re: smf 2.0.15 no me reconoce los usuarios con tílde
« Reply #6 on: July 11, 2018, 01:01:31 PM »
Anteriormente ¿que tipo de codificación estabas utlizando? por que si desde el vamos la base de datos quedo en esa manera seria complicado recuperarla, me ah pasado algunas veces...


Saludos!
¡Regresando como cual Fenix! ~ Bomber Code © 2018
Ayudas - Aportes - Tutoriales - Y mucho mas!!!


Ayudame via PayPal

Offline zesna

  • Semi-Newbie
  • *
  • Posts: 40
Re: smf 2.0.15 no me reconoce los usuarios con tílde
« Reply #7 on: July 12, 2018, 02:42:27 AM »
Hola,

Más o menos lo tengo solucionado, como solamente eran unos 3 o 4 con tílde, lo que he hecho ha sido, he cambiado su login por el mismo nombre sin tílde y luego la visibilidad en el foro con tílde y ya está arreglado así ;)

Gracias!

Ahora lo que me da miedo es instalar el mod karma, porque la última vez se me cayó el foro, sabéis que versión sería la buena para 2.0.15?

Gracias de nuevo :)

Offline Rock Lee

  • Local Moderator
  • SMF Hero
  • *
  • Posts: 1,995
  • Gender: Male
  • I also speak english :D
    • BomberCode.Oficial on Facebook
    • RockLee-BC on GitHub
    • @Bomber_Code on Twitter
    • Bomber Code ~ La nueva era del conocimiento
Re: smf 2.0.15 no me reconoce los usuarios con tílde
« Reply #8 on: July 12, 2018, 12:17:57 PM »
Bueno eso puede ser una diferencia en las codificaciones utilizadas haciendo al momento de guardarlo en la base de datos al no saber interpretarlo se cambia, al menos como a mi me paso en algunas pruebas hice en su momento.
¿Que quieres decir con "cayo"? generalmente cuando te marca error 500 o parecido es debido algún error en el php...


Saludos!
¡Regresando como cual Fenix! ~ Bomber Code © 2018
Ayudas - Aportes - Tutoriales - Y mucho mas!!!


Ayudame via PayPal