Advertisement:

Author Topic: 1.1.23 to 2.0.15 Upgrade Issue  (Read 1663 times)

Offline melanieh75

  • Semi-Newbie
  • *
  • Posts: 55
1.1.23 to 2.0.15 Upgrade Issue
« on: August 02, 2018, 05:07:25 PM »
I backed up all files and db's
uploaded the smf 2.0.15 package to forum root
Pointed browser to www.yourdomain.com/forum/upgrade.php

and get this error:

[an error occurred while processing this directive]

In searching this board, it seems might be related to something with my host, but not sure what. I see in cpanel it's set to use PHP 5.6
Not sure where to start looking

Thank you in advance,

Melanie

Offline melanieh75

  • Semi-Newbie
  • *
  • Posts: 55
Re: 1.1.23 to 2.0.15 Upgrade Issue
« Reply #1 on: August 02, 2018, 05:30:11 PM »
More Info: in cpanel, looked at Errors. These two are posted each time I visit the upgrade.php from a browser:

 [cgi:error] [pid 840487] [client #myip#] AH01228: exec used but not allowed in
 home/mydomain/public_html/500.shtml

 [:error] [pid 840487] [client #myip# SoftException in Application.cpp:261: File "/home/mydomain/public_html/forum/upgrade.php" is writeable by group

any ideas?

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,372
    • StoryBB/StoryBB on GitHub
Re: 1.1.23 to 2.0.15 Upgrade Issue
« Reply #2 on: August 02, 2018, 05:32:44 PM »
What file permissions does upgrade.php have? It seems like it should have 644 permissions looking at that error.

(Depending on your FTP client, this might be shown as rw-r--r-- or similar.)
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline melanieh75

  • Semi-Newbie
  • *
  • Posts: 55
Re: 1.1.23 to 2.0.15 Upgrade Issue
« Reply #3 on: August 02, 2018, 05:38:15 PM »
It had 664 so set to 666 and same error. I also tried 667.
Currently, it's back to 664

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,372
    • StoryBB/StoryBB on GitHub
Re: 1.1.23 to 2.0.15 Upgrade Issue
« Reply #4 on: August 02, 2018, 05:42:20 PM »
Yeah, that second 6 is the problem. Make it 644.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,231
Re: 1.1.23 to 2.0.15 Upgrade Issue
« Reply #5 on: August 02, 2018, 05:43:46 PM »
Did you try 644?  Server seems to be objecting to 'writeable by group', which is anything x6x.

Offline melanieh75

  • Semi-Newbie
  • *
  • Posts: 55
Re: 1.1.23 to 2.0.15 Upgrade Issue
« Reply #6 on: August 02, 2018, 05:44:52 PM »
That worked! I am now at the upgrade screen. whew. thanks to you both!