Advertisement:

Author Topic: upgrade stuck at beginning 1.1.21 to 2.0.15  (Read 10270 times)

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,429
  • Gender: Male
    • Kindred-999 on GitHub
Re: upgrade stuck at beginning 1.1.21 to 2.0.15
« Reply #20 on: August 23, 2018, 09:58:52 PM »
Hmmm... then edit Settings.php directly to add the dbtype
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline kb5won

  • Semi-Newbie
  • *
  • Posts: 17
  • Brian Gallimore
    • kb5won on GitHub
Re: upgrade stuck at beginning 1.1.21 to 2.0.15
« Reply #21 on: August 24, 2018, 12:04:03 AM »
I went through a series of things that seemed to make things worse.  So I restored my database from a backup, deleted all the files in my HTML folder and restored them as well. 

I manually edited the Settings.php file, added
$db_type = 'MySQL';
$queryless_urls = 0;
so I get no errors now when running repair_settings.php

then I run the 2.0.15 upgrader.  I get error about a theme (I think?).  see attachment.

I restored again, then logged in to SFM as admin, removed all the theme options, set all users to core theme and tried upgrade again.  I got the same result.

Offline kb5won

  • Semi-Newbie
  • *
  • Posts: 17
  • Brian Gallimore
    • kb5won on GitHub
Re: upgrade stuck at beginning 1.1.21 to 2.0.15
« Reply #22 on: August 24, 2018, 12:43:52 AM »
I fixed the problem with the theme error by deleting 6 records in the smf_themes table that were pointing to a directory that doesn't exist.  I think this was from years ago when my webhost moved my files to a different directory. 

Now I'm back to the original problem --- stuck at the beginning of the upgrade process.   (see screenshot) 

possible related errors in server logs:
/public_html/northtexasvegetablegardeners/forum/index.php
[Thu Aug 23 22:38:19 2018] [error] [client 157.55.39.145] File does not exist:

/public_html/northtexasvegetablegardeners/forum/Sources/error_log:
[31-May-2017 02:35:24 America/Denver] PHP Warning:  PHP Startup: pdo_sqlite: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20100525
These options need to match
 in Unknown on line 0
[31-May-2017 02:35:24 America/Denver] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/pdo_pgsql.so' - /usr/php/56/usr/lib64/php/modules/pdo_pgsql.so: undefined symbol: pdo_handle_error in Unknown on line 0
[19-Jun-2017 02:52:26 America/Denver] PHP Warning:  PHP Startup: imagick: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20100525
These options need to match
 in Unknown on line 0
...

/public_html/northtexasvegetablegardeners/forum/error_log:
[13-Apr-2018 08:25:00 America/Denver] PHP Warning:  PHP Startup: pdo_sqlite: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20100525
These options need to match
 in Unknown on line 0
[13-Apr-2018 08:25:00 America/Denver] PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/php/56/usr/lib64/php/modules/pdo_pgsql.so' - /usr/php/56/usr/lib64/php/modules/pdo_pgsql.so: undefined symbol: pdo_handle_error in Unknown on line 0
[13-Apr-2018 08:28:31 America/Denver] PHP Warning:  PHP Startup: imagick: Unable to initialize module
Module compiled with module API=20131226
PHP    compiled with module API=20100525
These options need to match
 in Unknown on line 0
...

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,242
Re: upgrade stuck at beginning 1.1.21 to 2.0.15
« Reply #23 on: August 24, 2018, 01:50:46 AM »
Not on my computer, but if you can go here, register with same username, I'll set up a board for you tomorrow and you can attach your phpmyadmin db backup  I'll see if it will upgrade on my server.  Had to do this for a couple of GoDaddy forums, upgrade just wouldn't run on GD.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,133
Re: upgrade stuck at beginning 1.1.21 to 2.0.15
« Reply #24 on: August 24, 2018, 05:10:15 AM »
i would suggest that you reach out to your host. you should not have those errors. your host should fix them, which may or may not correct the issue you are having.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,429
  • Gender: Male
    • Kindred-999 on GitHub
Re: upgrade stuck at beginning 1.1.21 to 2.0.15
« Reply #25 on: August 24, 2018, 07:20:42 AM »
yup....   the first issue was due to the fact that the dbtype was not defined, so it hung.

the second issue seems to have been because you had the leftover themes (sounds like you deleted the directories without ever deleting the theme in the smf admin, maybe)

the third and latest errors shows a missing index.php
Quote
/public_html/northtexasvegetablegardeners/forum/index.php
[Thu Aug 23 22:38:19 2018] [error] [client 157.55.39.145] File does not exist:

You can/should delete all those  error.log files now, though....   they are all old, except for the first one.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline kb5won

  • Semi-Newbie
  • *
  • Posts: 17
  • Brian Gallimore
    • kb5won on GitHub
Re: upgrade stuck at beginning 1.1.21 to 2.0.15
« Reply #26 on: August 24, 2018, 08:07:36 AM »
but if you can go here [nofollow], register with same username, I'll set up a board for you tomorrow and you can attach your phpmyadmin db backup  I'll see if it will upgrade on my server.
done.

I'm using bluehost, in case that sets off any flags to you

Offline kb5won

  • Semi-Newbie
  • *
  • Posts: 17
  • Brian Gallimore
    • kb5won on GitHub
Re: upgrade stuck at beginning 1.1.21 to 2.0.15
« Reply #27 on: August 24, 2018, 08:08:56 AM »
i would suggest that you reach out to your host. you should not have those errors. your host should fix them, which may or may not correct the issue you are having.
I just tried.  They don't want to fix them.  Say they will not cause any issue.

Offline kb5won

  • Semi-Newbie
  • *
  • Posts: 17
  • Brian Gallimore
    • kb5won on GitHub
Re: upgrade stuck at beginning 1.1.21 to 2.0.15
« Reply #28 on: August 24, 2018, 08:12:24 AM »
yup....   the first issue was due to the fact that the dbtype was not defined, so it hung.

the second issue seems to have been because you had the leftover themes (sounds like you deleted the directories without ever deleting the theme in the smf admin, maybe)

the third and latest errors shows a missing index.php
Quote
/public_html/northtexasvegetablegardeners/forum/index.php
[Thu Aug 23 22:38:19 2018] [error] [client 157.55.39.145] File does not exist:

You can/should delete all those  error.log files now, though....   they are all old, except for the first one.
Maybe something changed the time I had that error, but now that I check the index.php file is there. 

Offline kb5won

  • Semi-Newbie
  • *
  • Posts: 17
  • Brian Gallimore
    • kb5won on GitHub
Re: upgrade stuck at beginning 1.1.21 to 2.0.15
« Reply #29 on: August 29, 2018, 09:41:26 AM »
update:  Krash was able to manually convert my database to solve the problem.