Advertisement:

Author Topic: Trying SMF 1.1.15 but install.php says unable to detect MySQL support  (Read 2537 times)

Offline JasperHartline

  • Semi-Newbie
  • *
  • Posts: 32
Trying SMF 1.1.15 but install.php says unable to detect MySQL support in PHP.
Please see the screenshot attached to see the error:

Using PHP 7.0 and MySQL 5.5 and SMF 1.1.15

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,435
  • Gender: Male
    • Kindred-999 on GitHub
Re: Trying SMF 1.1.15 but install.php says unable to detect MySQL support
« Reply #1 on: September 04, 2018, 07:27:12 PM »
First. 1.1.x does not support php7

Second, why are you trying to install 1.1.15? Not only is the 1.1.x branch at Enid of life and mostly unsupported, but that’s not even the most recent version of 1.1.x
Install 2.0.15
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline landyvlad

  • Sr. Member
  • ****
  • Posts: 862
  • Gender: Male
    • Michael Reed on Facebook
    • GSX1400 Owners ORG
Re: Trying SMF 1.1.15 but install.php says unable to detect MySQL support
« Reply #2 on: September 04, 2018, 07:27:44 PM »
Yep, beat me to it. SNAP !
That is correct.
Please do not PM, IM or Email me with questions on astrophysics or theology.  You will get better and faster responses by asking homeless people in the street. Thank you.

To paraphrase Kindred: "There are no technical solutions to social problems."

No hack nor blackhats, just persistent asshats.

Offline JasperHartline

  • Semi-Newbie
  • *
  • Posts: 32
Re: Trying SMF 1.1.15 but install.php says unable to detect MySQL support
« Reply #3 on: September 04, 2018, 07:29:43 PM »
I installed 2.0.15 but I get a message on the screen shown here in this thread:
https://www.simplemachines.org/community/index.php?topic=562039.0

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,435
  • Gender: Male
    • Kindred-999 on GitHub
Re: Trying SMF 1.1.15 but install.php says unable to detect MySQL support
« Reply #4 on: September 04, 2018, 07:40:50 PM »
Well, you can’t import a 1.1.x database into a 2.0.x installation...

And 1.1.x will not run on php7 at all.

So...  install 1.1.21 code, use php 5.6, run the 1.1.21 upgrade
THEN put the 2.0.15 code in and run the 2.0.15 upgrader
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Gary

  • Sorceress's Knight
  • Customizer
  • SMF Super Hero
  • *
  • Posts: 18,107
  • Gender: Male
  • So this is the luck of the draw...
    • Gazmanafc on Facebook
    • garygadsdon on LinkedIn
    • @Gazmanafc on Twitter
    • The Bongo Comics Fan Forum
Re: Trying SMF 1.1.15 but install.php says unable to detect MySQL support
« Reply #5 on: September 05, 2018, 01:59:36 AM »
run the 1.1.21 upgrade
This is an unnecessary step. Any version of SMF can be upgraded straight to 2.0.15, there's no need to upgrade to the newest 1.1 version first. In fact, the SMF upgrader is actually capable of upgrading from YaBB SE 1.5.5 even for 2.0.
Gary M. Gadsdon
Do NOT PM me unless I say so

War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,243
Re: Trying SMF 1.1.15 but install.php says unable to detect MySQL support
« Reply #6 on: September 05, 2018, 02:09:45 AM »
Sorry, no.  I've run into this several times.  Upgrading from early 1.1 must sometimes be done in steps with some php version juggling.

Offline Gary

  • Sorceress's Knight
  • Customizer
  • SMF Super Hero
  • *
  • Posts: 18,107
  • Gender: Male
  • So this is the luck of the draw...
    • Gazmanafc on Facebook
    • garygadsdon on LinkedIn
    • @Gazmanafc on Twitter
    • The Bongo Comics Fan Forum
Re: Trying SMF 1.1.15 but install.php says unable to detect MySQL support
« Reply #7 on: September 05, 2018, 03:25:54 AM »
Sometimes, yes, depending on mods and server environment but that can happen on an upgrade to any version from any previous version.
 
However, more often than not, and I did a test upgrade from 1.1(.0) to verify, that the upgrader to 2.0.15 does in general work from any previous SMF version plus YaBB SE 1.5.5 without the need to upgrade to 1.1.21 first.
Gary M. Gadsdon
Do NOT PM me unless I say so

War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,435
  • Gender: Male
    • Kindred-999 on GitHub
Re: Trying SMF 1.1.15 but install.php says unable to detect MySQL support
« Reply #8 on: September 05, 2018, 09:25:11 AM »
Gary,

As noted, while it SHOULD be possible to go from 1.0.x to 2.0.x or 1.1x  to 2.0.x, there are times when updating doesn't work right but going to the uppermost release in the branch and then jumping to the new branch often solves the issue
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,243
Re: Trying SMF 1.1.15 but install.php says unable to detect MySQL support
« Reply #9 on: September 05, 2018, 11:49:51 AM »
If everything worked like it should, we'd be living in a perfect world.  Doesn't look quite like that from here. :P

I've worked two or three forums that couldn't be upgraded on host server, had to export database to test install on my server, upgrade, then move it back.  Just did one a few days ago.  Some servers are so poorly configured, it's surprising anything will run on them.