News:

Join the Facebook Fan Page.

Main Menu

SunRise

Started by SychO, September 22, 2018, 10:12:35 PM

Previous topic - Next topic

spiros

I was testing after the 2.0.17 update and there seems no way to get the browser to remember the day/night selection. It seems to last only for the specific browser session; when browser is restarted one has to change it again. Is there any way to make it stick to the visitor/user selection (until the user changes it), I guess by cookie duration?

SychO

The cookie duration is 30 days by default, so even if you restart your browser the cookie should still be there before the 30 days, if you want to change the duration look for "setCookie" and edit "30" in index.template.php

also since the way the cookie is set by the theme has nothing to do with how the software sets its cookies, than 2.0.17 has no way of messing with it, of course something might be amiss with your installation but it works fine for me even with 2.0.17

Checkout My Themes:
-

Potato  •  Ackerman  •  SunRise  •  NightBreeze

spiros

#282
I did some more testing with 2 machines and 1 phone. Visiting 2 sites with the theme, closing the browser, opening it again. The results are a mixed bag. Some browsers fail in both sites I tested (your demo http://dzignmz.22web.org/forum/index.php?theme=8&i=1 and mine https://www.translatum.gr/forum/index.php), some work for both, some work in one, not in the other.

Menu issue
It seems that what causes much of the menu issues is the fact that in mobile dropdown menu the first item is not clickable but unfolds the subitems. So, if the main item has both a link and children elements (as for example "Customize" in this site), the link of the main item will not work in mobile mode. Not sure how this can be addressed as the first item can also be an important site link. Maybe have it added somehow as an extra subitem in mobile mode?

Stats on top

Checking your demo I can see a top row with stats. Is this an option? I could not find it.

11
MEMBERS
67
POSTS
32
TOPICS
NEWMEMBER
LATEST MEMBE

SychO

Quote from: spiros on January 02, 2020, 12:31:18 PM
I did some more testing with 2 machines and 1 phone. Visiting 2 sites with the theme, closing the browser, opening it again. The results are a mixed bag. Some browsers fail in both sites I tested (your demo http://dzignmz.22web.org/forum/index.php?theme=8&i=1 and mine https://www.translatum.gr/forum/index.php), some work for both, some work in one, not in the other.

That is weird, the javascript code used for this might need updating then.

Quote from: spiros on January 02, 2020, 12:31:18 PM
Menu issue
It seems that what causes much of the menu issues is the fact that in mobile dropdown menu the first item is not clickable but unfolds the subitems. So, if the main item has both a link and children elements (as for example "Customize" in this site), the link of the main item will not work in mobile mode. Not sure how this can be addressed as the first item can also be an important site link. Maybe have it added somehow as an extra subitem in mobile mode?

I guess if you do add the main item as a subitem that would solve the problem, the code is in index.template.php, I think the function responsible for the menu is called template_menu() you just need to re-write the <li> item inside the <ul> item which is inside of it.

Quote from: spiros on January 02, 2020, 12:31:18 PM
Stats on top

Checking your demo I can see a top row with stats. Is this an option? I could not find it.

11
MEMBERS
67
POSTS
32
TOPICS
NEWMEMBER
LATEST MEMBE

Disable "Show statistics on board index:" in the theme settings
Checkout My Themes:
-

Potato  •  Ackerman  •  SunRise  •  NightBreeze

spiros

Thanks for the reply.

Menu
I was not sure how exactly to implement that edit; I edited the menu in Subs.php instead by adding the main item as first subitem too.

Stats on Top
Yes, that worked fine. Is it possible to add total page views as a Stat there? I tried
$context['common_stats']['num_hits'] (https://www.simplemachines.org/community/index.php?topic=571157.msg4042492#msg4042492) but did not work.

-Rock Lee-

#285
I was just looking to use your theme and I realized you added new things for which I leave the translations with some improvements in the files ;)


Regards!
¡Regresando como cual Fenix! ~ Bomber Code
Ayudas - Aportes - Tutoriales - Y mucho mas!!!

SychO

Quote from: spiros on January 04, 2020, 07:04:14 AM
Stats on Top
Yes, that worked fine. Is it possible to add total page views as a Stat there? I tried
$context['common_stats']['num_hits'] (https://www.simplemachines.org/community/index.php?topic=571157.msg4042492#msg4042492) but did not work.

I cannot tell if that is possible or not at the moment.

Quote from: Rock Lee on January 05, 2020, 11:01:37 AM
I was just looking to use your theme and I realized you added new things for which I leave the translations with some improvements in the files ;)


Regards!


Thank you Rock Lee :) I'll include these whenever I get the chance
Checkout My Themes:
-

Potato  •  Ackerman  •  SunRise  •  NightBreeze

Tr0n

Hi SychO,

Quick question, Is it possible to include a custom background for whole forum, if so how?

Thanks

Gandrel

Has anyone upgraded to 2.0.17 yet and if so, have you had any issues with the SunRise theme? I'm reluctant to upgrade until I see 2.0.17 listed as officially compatible. Currently it's only showing 2.0.15.

Gandrel

I'd also like to propose that the following be changed in the index.template.php file in the next version of this theme:

Change:
<li><a class="firstlevel" href="', $scripturl, '?action=unread">' . fontawesome('fas fa-user-plus') . ' <span>', $txt['sr_unread_since_visit'], '</span></a></li>

To:
<li><a class="firstlevel" href="', $scripturl, '?action=unread">' . fontawesome('fas fa-inbox') . ' <span>', $txt['sr_unread_since_visit'], '</span></a></li>

Currently, it doesn't make sense to me that the icon for "UNREAD POSTS" is the same icon used for "REGISTER".

big red

 SychO - Thank You for the Theme

Two things:

1 - Giving Karma is important to my forum and while that option is there in desktop viewing, i cannot see that option in chrome mobile view. How can i make that option show.
2 - The default avatar mod (i want the same avatar to show across all themes) is not affecting your theme. I even overwrote your default avatar image and still no effect. What am i missing here?

   Thanks!

Koulouridhs

Hello.

Is there any documentation for how to change moon/sunlight to image?

Thanks in advance.

Byaku06

@SychO

Hi,

How can I remove the mountains and put another image?

hxxp:prnt.sc/rm3wzy [nonactive]

ByDenhiz


addlife

Quote from: SychO on May 03, 2020, 06:22:58 PM
Quote from: addlife on May 03, 2020, 06:05:37 PM
Correct me if I'm understanding wrong. The themes that you're referring to will work with the like posts mod without manual edits even if it's installed after the like posts mod?

I saw somewhere in the code of Sunrise that it mentions vbgamers mod in a comment. Is that the part of code that you did whatever you posted above?

Yes & Yes, that's the purpose of adding mod support.
I just tried installing the theme after I installed the mod but it didn't seem to work.

011972.xyz

Did I do something wrong?

SychO

Oh it doesn't indeed, the theme needs updating (it has for a while)

*shrugs*
Checkout My Themes:
-

Potato  •  Ackerman  •  SunRise  •  NightBreeze

spiros

#296
Looks like the board icons showing new posts do not change accordingly in child boards.

Icons showing the board index and message index with child boards in both Sunrise and Default theme. Notice that in default theme, the board with new messages has a different colour icon.

I think the problem is with the class responsible for new posts <td class="icon new_posts"> not being shown on child boards with new posts. The image changes name (to an image which in fact is the same), but the image is not the one responsible for the change.

SychO

It's not an issue, It's working as intended, I deliberately didn't incorporate icon changes based on new posts, call it personal preference, I never found it that useful, only bothersome at times.

If I remember correctly if you want to get it working like that, you just need to edit on2.png or something like that.
Checkout My Themes:
-

Potato  •  Ackerman  •  SunRise  •  NightBreeze

spiros

Well, actually icon changes on new posts do work on your default theme, (only for forum index though, not for message index) you have applied the class mentioned above on a td (icon new_posts)  :)

Also, I notice that no Font Awesome icon is used, although the image for "on" and "off" is the same as a Font Awesome icon. I sort of found a way to change this by replacing it in BoardIndex.template.php

Find

<img src="', $settings['images_url'], '/', $context['theme_variant_url'], 'on', $board['new'] ? '' : '2', '.png" alt="', $txt['new_posts'], '" class="tooltip" title="', $txt['new_posts'], '" />';

Replace:

<i class="fas fa-pencil-alt fa-3x" style="color:white !important" alt="', $txt['new_posts'], '" title="', $txt['new_posts'], '"';

I wanted to incorporate this:

<i class="fas fa-pencil-alt fa-3x" style="color:white !important" title="New posts"></i>

Although the html output of my php version is a bit problematic, I guess I am missing something. Also, getting it to be responsive the same way as the image is something I could not manage, even with something like

i.fas.fa-pencil-alt.fa-3x {
    font-size: 4.4vw;
}

dgs20

thank you good template

Advertisement: