Advertisement:

Author Topic: Recent Forum Topics on Boardindex  (Read 52764 times)

Offline GigaWatt

  • The Smiley Guy
  • Support Specialist
  • SMF Hero
  • *
  • Posts: 1,631
  • Gender: Male
    • Macedonian electronics forum
Re: Recent Forum Topics on Boardindex
« Reply #160 on: October 25, 2018, 09:03:56 AM »
Yeah, no problem on my forum... though I don't own a smartphone, so I can't confirm.

I recall viewing my forum from my wife's smartphone a few days ago, it seemed fine.

Also, a request directed at Pipke. Could you add a setting to limit the number of pages or recent topics shown (either will do) in the next version? Thanks :).
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

Offline Pipke

  • Full Member
  • ***
  • Posts: 456
    • [NRNS]
Re: Recent Forum Topics on Boardindex
« Reply #161 on: October 25, 2018, 03:01:09 PM »
mobile screenshot in attachment, btw russian is abracadabra to me lol


Offline FishingManMatt

  • Semi-Newbie
  • *
  • Posts: 51
  • Gender: Male
Re: Recent Forum Topics on Boardindex
« Reply #162 on: October 25, 2018, 03:04:44 PM »
Did this start happening over night or was it always like this?
It's hard to say. I have two web browsers on my phone (Chrome and Opera Beta) and for as long as I can remember the site looks fine.
Two days ago one of my moderators posted a screenshot from his phone. Then I used the built-in Chrome DevTools and saw the same bahaviour. The site still looks good on my phone.

I've just used the Chrome DevTools to check GigaWatt's forum and there is no such problem.


Is there anything I can do to fit the table to the main content section?

Can you provide a link to your forum, so we can see this behavior in action. At GigaWatt's site this looks all fine.
Sure. Here it is -> http://splawikigrunt.pl/forum/

Offline Pipke

  • Full Member
  • ***
  • Posts: 456
    • [NRNS]
Re: Recent Forum Topics on Boardindex
« Reply #163 on: October 25, 2018, 03:12:15 PM »
@FishingManMatt your site looks ok with chrome, can you ask the particular moderator wich browser and phone he made the screenshot.

Offline Pipke

  • Full Member
  • ***
  • Posts: 456
    • [NRNS]
Re: Recent Forum Topics on Boardindex
« Reply #164 on: October 25, 2018, 03:22:02 PM »
Also, a request directed at Pipke. Could you add a setting to limit the number of pages or recent topics shown (either will do) in the next version? Thanks :).

in RecentForumsTopics.php change this as desired
Code: [Select]
if (isset($_REQUEST['start']) && $_REQUEST['start'] > 95)
$_REQUEST['start'] = 95;

and find all '100' in file, to the desired number of topics, that should do the task.

Offline FishingManMatt

  • Semi-Newbie
  • *
  • Posts: 51
  • Gender: Male
Re: Recent Forum Topics on Boardindex
« Reply #165 on: October 25, 2018, 04:03:21 PM »
@FishingManMatt your site looks ok with chrome, can you ask the particular moderator wich browser and phone he made the screenshot.
Yeah, it looks OK with Chrome. But why doesn't it look OK in DevTools?
Take a look at this recording -> http://splawikigrunt.pl/pliki/misc/RFT.avi

I wrote to the moderator and will post the info as soon as he writes back.

Offline FishingManMatt

  • Semi-Newbie
  • *
  • Posts: 51
  • Gender: Male
Re: Recent Forum Topics on Boardindex
« Reply #166 on: October 25, 2018, 04:54:20 PM »
I got the answer. He used a native web browser in Samsung Galaxy S4 Mini.

And here is his screenshot:

Offline Pipke

  • Full Member
  • ***
  • Posts: 456
    • [NRNS]
Re: Recent Forum Topics on Boardindex
« Reply #167 on: October 25, 2018, 05:04:57 PM »
on my dev tools chrome all is fine, btw Viewport meta tag should exist to define device scaling

Viewport meta tag was not found in page header.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 57,642
  • Gender: Male
    • Kindred-999 on GitHub
Re: Recent Forum Topics on Boardindex
« Reply #168 on: October 25, 2018, 05:07:34 PM »
s4 is ancient....   probably not matching modern standards
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline GigaWatt

  • The Smiley Guy
  • Support Specialist
  • SMF Hero
  • *
  • Posts: 1,631
  • Gender: Male
    • Macedonian electronics forum
Re: Recent Forum Topics on Boardindex
« Reply #169 on: October 25, 2018, 09:55:36 PM »
mobile screenshot in attachment, btw russian is abracadabra to me lol

It's not Russian :D. It's a Cyrillic language, but it's not Russian :D.

Also, a request directed at Pipke. Could you add a setting to limit the number of pages or recent topics shown (either will do) in the next version? Thanks :).

in RecentForumsTopics.php change this as desired
Code: [Select]
if (isset($_REQUEST['start']) && $_REQUEST['start'] > 95)
$_REQUEST['start'] = 95;

and find all '100' in file, to the desired number of topics, that should do the task.

Thanks :).
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

Offline FishingManMatt

  • Semi-Newbie
  • *
  • Posts: 51
  • Gender: Male
Re: Recent Forum Topics on Boardindex
« Reply #170 on: October 30, 2018, 07:37:20 AM »
Sorry for the delayed response. I had to leave for a few days.

on my dev tools chrome all is fine
Indeed. I have no idea why it looks different in my DevTools. Really a mystery  :o

btw Viewport meta tag should exist to define device scaling

Viewport meta tag was not found in page header.
Ah, I see.
Is it recommended to add this meta tag (even to the default non-responsive theme)?

Offline Pipke

  • Full Member
  • ***
  • Posts: 456
    • [NRNS]
Re: Recent Forum Topics on Boardindex
« Reply #171 on: October 30, 2018, 10:41:28 AM »
@FishingManMatt you can always try it out, i guess it will do no harm
Code: [Select]
<meta name="viewport" content="width=device-width, initial-scale=1.0">

Offline FishingManMatt

  • Semi-Newbie
  • *
  • Posts: 51
  • Gender: Male
Re: Recent Forum Topics on Boardindex
« Reply #172 on: October 30, 2018, 03:16:50 PM »
Thanks Pipke!
After adding this meta I got the following preview in the DevTools which is, I suppose, even more strange.
I thought it could be related to the custom font DPI (125%) which I set in my Windows, but nothing changed after setting it to the default 100%.
Also, in my desktop Chrome shortcut I have the following target command:
"...\chrome.exe" /high-dpi-support=1 /force-device-scale-factor=1
I launched Chrome without this addition but it didn't change anything either.

The fact is that the GigaWatt's site always looks good in DevTools.

Never mind, let's say it is something mysterious :)
The most important thing is that the site (and the RFT table) looks OK on most mobile devices.