• Welcome to Simple Machines Community Forum. Please login or sign up.
September 19, 2021, 01:07:33 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


Update SMF 2.0.13 to 2.0.14 error

Started by M50Freak, December 10, 2018, 04:39:08 PM

Previous topic - Next topic

M50Freak

Hy

Hy

When i use the Update from SMF 2.0.13 to 2.0.14 i have problems with Integration. After Install the forum is down...

I see that the load.php will be the problem ....

After Update i have only a withe Side.

Some Error


Code: (Suchen) [Auswählen]

array($session_id, $data, time()),
array('session_id')
);

return $result;

Code: (Ersetzen) [Auswählen]

array($session_id, $data, time()),
array('session_id')
);

return true;




Code: (Suchen) [Auswählen]

// Just delete the row...
return $smcFunc['db_query']('', '
DELETE FROM {db_prefix}sessions
WHERE session_id = {string:session_id}',
array(
'session_id' => $session_id,
)
);

Code: (Ersetzen) [Auswählen]

// Just delete the row...
$smcFunc['db_query']('', '
DELETE FROM {db_prefix}sessions
WHERE session_id = {string:session_id}',
array(
'session_id' => $session_id,
)
);

return true;

Code: (Suchen) [Auswählen]

// Clean up ;).
return $smcFunc['db_query']('', '
DELETE FROM {db_prefix}sessions
WHERE last_update < {int:last_update}',
array(
'last_update' => time() - $max_lifetime,
)
);

Code: (Ersetzen) [Auswählen]

// Clean up ;).
$smcFunc['db_query']('', '
DELETE FROM {db_prefix}sessions
WHERE last_update < {int:last_update}',
array(
'last_update' => time() - $max_lifetime,
)
);

return $smcFunc['db_affected_rows']() != 0;



I will go up to 2.0.15. ...

Best greats Norbert


Kindred

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

M50Freak

December 10, 2018, 05:13:50 PM #2 Last Edit: December 10, 2018, 06:04:51 PM by M50Freak
Sorry

I have read the Error in mod install.

I know that i have a problem @ 3 big points.

The First is in Source/load.php on some points. - I knew. But i dont know to repair, becouse i don´t konw now the error ...

The secound is in     ./SSI.php


Code: (Suchen) [Auswählen]

global $smcFunc, $ssi_db_user, $scripturl, $ssi_db_passwd, $db_passwd, $cachedir;

// Remember the current configuration so it can be set back.

Code: (Ersetzen) [Auswählen]

global $smcFunc, $ssi_db_user, $scripturl, $ssi_db_passwd, $db_passwd, $cachedir;
global $image_proxy_enabled, $image_proxy_secret, $image_proxy_maxsize;

// Remember the current configuration so it can be set back.



and the last is in the themes.

./Themes/AsLine/index.template.php


After update to 2.014 and load the  oir source /load.php its also not works.

I will test to repair the load...

So up to 2.0.14 i have done....i don´t konw but it works xD ....jet.


Kindred

Well, if you installed it, by ignoring the error message, then its not surprising that it broke your system
That's why the error was there in the first place!  The system could not automatically  perform the code replacement function(s) because your code is somehow different from the default code.

That means that you should ***NOT*** have installed the patch until you fully identified what code needed to be edited and were ready to make those edits manually.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

M50Freak

Helllo

So i have done the Update up to 2.0.15. Forum ist aktiv and run.

But in the Protokol there are some Error´s.
I don´t now jet how i can fix them. I  see that the problem is in Source with preg_replace_callback(): Requires argument 2, '$smcFunc['entity_fix']('\2')', to be a valid callback , but i dont know what this is...(Sorry i use smf only for mei hobby use;)

Thanks

Greets Norbert

Kindred

1- did you fully apply all code changes... especially the ones that failed the autoinstall?
2- Are you running any mods?
3- What version is php are you running?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

M50Freak

Hy

1. i hope so....

Aktuelle SMF Version: SMF 2.0.15
GD Version: 2.2.5
Datenbankserver: MySQL
MySQL Version: 5.1.73
PHP: 5.6.38
Server Version: Apache

Mods

Kindred

please include the mods as text. For those of us on mobile devices, trying to puzzle out an image is not worth the effort.

regarding #1.
You hope so?
Did you manually apply the changes or not?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

M50Freak

1; Yes, but i am not a Profi ...It is still running stabil .... O:)


Mods:

1.   SMF 2.0.13 Update   1.0 
2.   ResizeImagesToFitScreen   0.1.6 
3.   SMF 2.0.14 Update   1.0 
4.   SMF 1.1.19 / 2.0.6 Update   1.0 
5.   SMF 1.1.20 / 2.0.9 Update   1.0 
6.   SMF 2.0.14 Update   1.0 
7.   SMF 2.0.11 Update   1.0 
8.   Activity Bar   1.1 
9.   Embed Facebook BBCode   3.4 
10.   SMF 2.0.15 Update   1.0 
11.   SMF 2.0.15 Update   1.0 
12.   SMF Gallery Lite   3.5 
13.   SMF 1.1.21 / 2.0.10 Update   1.0 
14.   SMF 2.0.15 Update   1.0 
15.   SMF 2.0.8 Update   1.0 
16.   SimplePortal   2.3.6 
17.   SMF 2.0.5 Update   1.0 
18.   KeyCAPTCHA for SMF   2.5 
19.   SMF 2.0.14 Update   1.0 
20.   YouTube BBCode   2.6 
21.   SMF 2.0.12 Update   1.0 

Advertisement: