Advertisement:

Author Topic: Update error  (Read 2383 times)

Offline Juan Carlos

  • Jr. Member
  • **
  • Posts: 245
  • Gender: Male
Update error
« on: December 17, 2018, 07:59:51 PM »
I just download the last gh today and the upgrade process stop alwalys in the same step.

I try several times but I cant advance.

I attach the image with the error
Juan Carlos

Offline Kindred

  • The Mean One
  • Lead Support Specialist
  • SMF Legend
  • *
  • Posts: 60,437
  • Gender: Male
    • Kindred-999 on GitHub
Re: Update error
« Reply #1 on: December 17, 2018, 08:15:41 PM »
You doi know that the upgrade script is not intended to be used between nightly builds?
« Last Edit: December 17, 2018, 08:33:12 PM by Kindred »
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline Juan Carlos

  • Jr. Member
  • **
  • Posts: 245
  • Gender: Male
Re: Update error
« Reply #2 on: December 17, 2018, 08:31:39 PM »
Sorry but I dont understand you
Juan Carlos

Offline Kindred

  • The Mean One
  • Lead Support Specialist
  • SMF Legend
  • *
  • Posts: 60,437
  • Gender: Male
    • Kindred-999 on GitHub
Re: Update error
« Reply #3 on: December 17, 2018, 08:33:44 PM »
The upgrader is not intended to be run when going from beta to beta of the github downloads
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline Juan Carlos

  • Jr. Member
  • **
  • Posts: 245
  • Gender: Male
Re: Update error
« Reply #4 on: December 17, 2018, 08:43:26 PM »
I made several upgrades from GitHub.
Which is the correct procesa then?
Juan Carlos

Offline Kindred

  • The Mean One
  • Lead Support Specialist
  • SMF Legend
  • *
  • Posts: 60,437
  • Gender: Male
    • Kindred-999 on GitHub
Re: Update error
« Reply #5 on: December 17, 2018, 09:02:04 PM »
You have to manually adjust the database .

This is one of the many reasons why we caution people not to use the beta unless they know what they are doing.


When we build an actual release, we make the updater work from previously released versions ... but there is no such thing taken into account for the day to day changes between daily github builds.
To upgrade a daily to a daily, you have to manually check the database changes and manually apply them.

The upgrader should work from 1.1.x, 2.0.x and probably 2.1 beta 3...
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline Juan Carlos

  • Jr. Member
  • **
  • Posts: 245
  • Gender: Male
Re: Update error
« Reply #6 on: December 17, 2018, 09:09:01 PM »
Ok thank you
How I know that changes in the databases to make manually
Juan Carlos

Offline Kindred

  • The Mean One
  • Lead Support Specialist
  • SMF Legend
  • *
  • Posts: 60,437
  • Gender: Male
    • Kindred-999 on GitHub
Re: Update error
« Reply #7 on: December 17, 2018, 09:25:10 PM »
You have to look through the upgrade script to find what the eventual target is and make sure your database matches ...     its part of the reason why I always blow away my test site and install clean copy instead of an update.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline Juan Carlos

  • Jr. Member
  • **
  • Posts: 245
  • Gender: Male
Re: Update error
« Reply #8 on: December 17, 2018, 09:35:44 PM »
Ok thank you vey much. now I will try and be more carafully with the upgrades
Juan Carlos

Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 9,166
  • Gender: Male
    • XinYenFon on GitHub
    • @XinYenFon on Twitter
Re: Update error
« Reply #9 on: December 18, 2018, 07:40:44 AM »
This is interesting, I'm using/testing SMF 2.1 since alpha1 and always used upgrade.php to bring my local to date and never had this issue. Are you running upgrade.php on a remote server or a local server?

Offline Juan Carlos

  • Jr. Member
  • **
  • Posts: 245
  • Gender: Male
Re: Update error
« Reply #10 on: December 18, 2018, 09:24:06 AM »
I always did like you Antes and I did not have problems with the upgrades either.
I'm running the upgrade.php on a remote server
Juan Carlos

Offline GigaWatt

  • The Smiley Guy
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 2,346
  • Gender: Male
    • MechDR on GitHub
    • Macedonian electronics forum
Re: Update error
« Reply #11 on: December 18, 2018, 09:59:42 AM »
Might be something server side. What permissions does the database user you're using for the beta have?
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 9,166
  • Gender: Male
    • XinYenFon on GitHub
    • @XinYenFon on Twitter
Re: Update error
« Reply #12 on: December 18, 2018, 10:04:27 AM »
I always did like you Antes and I did not have problems with the upgrades either.
I'm running the upgrade.php on a remote server

Clone your remote site to local and try to upgrade from there.

Offline Juan Carlos

  • Jr. Member
  • **
  • Posts: 245
  • Gender: Male
Re: Update error
« Reply #13 on: December 18, 2018, 12:28:53 PM »
I just run the "upgrade" in another domain as I always do and it ran perfectly without any errors.
The two domains are on the same host and the databases have the same characteristics.
The only difference I had between one forum and another is that the one that produced the error had installed the l to test.
I think the tiny portal made some change in the database that is causing the error.
Juan Carlos

Offline Kindred

  • The Mean One
  • Lead Support Specialist
  • SMF Legend
  • *
  • Posts: 60,437
  • Gender: Male
    • Kindred-999 on GitHub
Re: Update error
« Reply #14 on: December 18, 2018, 12:54:37 PM »
see, though, the thing is...  even running upgrade.php will not modify your database in the correct way(s) when going from nightly beta to nightly beta.  So, running upgrade.php will not have your database in the correct format and may result in odd issues

So I have been told by the lead developer.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline Juan Carlos

  • Jr. Member
  • **
  • Posts: 245
  • Gender: Male
Re: Update error
« Reply #15 on: December 18, 2018, 01:01:24 PM »
I download from the "Clone or Download" button in GH.

I dont know if this is the same that the nightly download.
Juan Carlos

Offline Illori

  • Support Specialist
  • SMF Legend
  • *
  • Posts: 52,947
Re: Update error
« Reply #16 on: December 18, 2018, 01:05:20 PM »
no it is not.

Offline Kindred

  • The Mean One
  • Lead Support Specialist
  • SMF Legend
  • *
  • Posts: 60,437
  • Gender: Male
    • Kindred-999 on GitHub
Re: Update error
« Reply #17 on: December 18, 2018, 01:36:39 PM »
yes, it is...  essentially.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 73,189
Re: Update error
« Reply #18 on: December 18, 2018, 01:41:23 PM »
yes, it is...  essentially.

Mostly, the key differences are that the installer is in a different folder, and that nightly can be out of sync with 'latest' by up to a day...
No good deed goes unpunished
All helpful urges should be circumvented

Offline tinoest

  • Development Contributor
  • Jr. Member
  • *
  • Posts: 268
Re: Update error
« Reply #19 on: December 18, 2018, 11:29:37 PM »
I just run the "upgrade" in another domain as I always do and it ran perfectly without any errors.
The two domains are on the same host and the databases have the same characteristics.
The only difference I had between one forum and another is that the one that produced the error had installed the l to test.
I think the tiny portal made some change in the database that is causing the error.

TinyPortal doesn’t make any changes to the dB or even core files for SMF2.1 so I can’t see how it would break it.