• Welcome to Simple Machines Community Forum. Please login or sign up.
September 17, 2021, 07:23:17 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Update error

Started by Juan Carlos, December 17, 2018, 07:59:51 PM

Previous topic - Next topic

shawnb61

Juan Carlos -

Did you ever get this sorted out?   Or is this still an issue?

If this is still an issue it may help to see the structure of your custom_fields table - that's what it was working on.

Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

lurkalot

Quote from: Antes on December 18, 2018, 07:40:44 AM
This is interesting, I'm using/testing SMF 2.1 since alpha1 and always used upgrade.php to bring my local to date and never had this issue. Are you running upgrade.php on a remote server or a local server?

Me too.  Upgraded using the nightly build of RC1 only two days ago. Also running TinyPortal since day one. http://cctestsite.info/testsite3/index.php

Juan Carlos

Quote from: shawnb61 on December 30, 2018, 04:36:53 PM
Juan Carlos -

Did you ever get this sorted out?   Or is this still an issue?

If this is still an issue it may help to see the structure of your custom_fields table - that's what it was working on.

Well, I've already got the problem gone but I do not know how. As I did not find the problem, I did the following:
1. I deleted the database and create a new one.
2. I made a new clean installation from gh.
3. I deleted the data from the tables and then imported all the data table by table from a previous backup.
4. Then I ran the upgrade again and it worked correctly.

I understand that this was not the best way to find the error
Juan Carlos

Advertisement: