Advertisement:

Author Topic: Graag ondersteuning bij terugzetten forum  (Read 4227 times)

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Graag ondersteuning bij terugzetten forum
« on: January 07, 2019, 06:35:15 AM »
Ik heb de database backup van een aantal jaar geleden, deze is geupload naar phpmyadmin > [juiste database], vervolgens lees ik op de homepage: Table 'online4q_smf517.smf3a_settings' doesn't exist.

Wat kan het probleem zijn? Is de database niet compleet?

Offline CoreISP

  • Server Admin
  • Server Team
  • SMF Super Hero
  • *
  • Posts: 18,004
  • Gender: Male
  • Liroy van Hoewijk
    • coreisp on GitHub
    • liroyvh on LinkedIn
    • @liroyvh on Twitter
Re: Graag ondersteuning bij terugzetten forum
« Reply #1 on: January 07, 2019, 07:03:41 AM »
Als je zeker weet dat je SMF correct ingesteld staat met database naam én prefix (zo niet, download repair_settings.php (Download -> Tools) en fix het.), dan lijkt het er inderdaad op dat of het herstel niet goed is gegaan of de backup van de database inderdaad incompleet is. Is de database erg groot of valt dat wel mee?
((U + C + I)x(10 − S)) / 20xAx1 / (1 − sin(F / 10))
President/CEO of Simple Machines - Server Manager
Please do not PM for support - anything else is usually OK.

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #2 on: January 07, 2019, 07:34:59 AM »
De database is 19.433 kb groot. Dus 19 mb ongeveer. Ik ga er zo snel mogelijk mee aan de slag en zal terugkoppeling geven. Tabblad blijft openstaan.

Offline @rjen

  • Full Member
  • ***
  • Posts: 509
  • Gender: Male
Re: Graag ondersteuning bij terugzetten forum
« Reply #3 on: January 07, 2019, 07:55:23 AM »
Ik zou even met phpmyadmin je database controleren: hoeveel tabellen heb je, en staat deze tabel 'smf3a_settings' er tussen?

Zo ja, zit er ook inhoud in?

Als dat twee keer ja is dan klopt er iets niet met je settings, anders is het je database...
Running SMF 2.0 with Tinyportal 1.6.4 at www.fjr-club.nl
Testing SMF 2.1 RC2 with Tinyportal at http://test2.fjr-club.nl/

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #4 on: January 07, 2019, 08:31:13 AM »
Ik heb mijn FTP files ook nog niet gecontroleerd

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #5 on: January 07, 2019, 12:46:34 PM »
Ik zou even met phpmyadmin je database controleren: hoeveel tabellen heb je, en staat deze tabel 'smf3a_settings' er tussen?

Zo ja, zit er ook inhoud in?

Als dat twee keer ja is dan klopt er iets niet met je settings, anders is het je database...

Nee, die tabel staat er niet tussen: https://youtu.be/cCMLcVyCi6Q [nofollow]. Kan het zijn dat Simple Machines in de tussentijd een nieuwe tabelstructuur heeft ontworpen waarbij de genoemde smf3a_settings is toegevoegd? Mijn database is namelijk een paar jaar oud.

Edit: ik heb namelijk niet een backup gemaakt destijds, waarbij ik alle tabellen heb opgeslagen, m.u.v. van deze smf3a_settings. Ik heb een volledige backup gemaakt via phpmyadmin, een export.

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #6 on: January 07, 2019, 01:12:32 PM »
De tabellenstructuur van SMF is in de tussentijd goed veranderd. Ik heb even een nieuwe installatie gedaan en dit is hoe het er tegenwoordig uitziet: https://youtu.be/f3Rl777IbPg [nofollow].

Voorheen zag het er zo uit: http://youtu.be/cCMLcVyCi6Q [nofollow].

Dat verklaart het probleem mijns inziens, want in de nieuwe structuur staat er wel een 'smf3a_settings' tabel tussen. Alleen is het de smf1a_settings.

Betekent ook dat vast meer mensen dit probleem hebben gehad, even zoeken....

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #7 on: January 07, 2019, 01:28:07 PM »
Hier iemand met dezelfde vraag, staat niets in: simplemachines.org/community/index.php?topic=563100.0

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #8 on: January 07, 2019, 01:38:52 PM »
Ik heb Google doorzocht op smf forum table doesn't exist en dan de afgelopen 3 jaar. Nergens specifiek mijn probleem kunnen vinden, noch een oplossing. Het zou helpen als ik nog een oude versie van SMF zou kunnen downloaden, die de oude tabellenstructuur nog hanteert en dan die vervolgens upgraden. Edit: ik heb nu geinstalleerd Version : 2.0.15. Zou dit mij kunnen helpen; archived releases: https://download.simplemachines.org/index.php?archive, hebben jullie enig idee welke versie nog een oude table structuur hanteert?

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #9 on: January 07, 2019, 01:44:58 PM »
Ik gebruikte destijds 2.0.2., zie ik in web archive.

Offline @rjen

  • Full Member
  • ***
  • Posts: 509
  • Gender: Male
Re: Graag ondersteuning bij terugzetten forum
« Reply #10 on: January 07, 2019, 01:51:09 PM »
Volgens mij is de tabel structuur in 2.0 niet gewijzigd! Denk dus dat je backup niet goed is / niet volledig teruggezet...
Running SMF 2.0 with Tinyportal 1.6.4 at www.fjr-club.nl
Testing SMF 2.1 RC2 with Tinyportal at http://test2.fjr-club.nl/

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #11 on: January 08, 2019, 11:00:03 AM »
Probleem opgelost. Wat heb ik gedaan dan?

Vervelend genoeg, weet ik niet meer precies wat de gouden oplossing is geweest. De volgende acties heb ik ondernomen:

- Andere database geprobeerd;
- Andere SMF versie geprobeerd, eentje uit het archief;
- Nog eens een paar keer de aanwezige files op de server en in phpmyadmin, de aanwezige tabellen nog eens goed bestudeerd;
- Teruggeschakeld naar een oude versie van PhP, via mijn webhostingaccount;
- Mogelijk nog enkele andere dingen;

Komt er op neer dat ik aan het nalopen en proberen ben geslagen en ergens heeft dat tot de oplossing geleid.

Mijn SMF forum wil niet connecten met de database, wat kan het probleem zijn?
Dit probleem had ik gisteren ook, kan te maken hebben met de php versie die je gebruikt. Ik heb de ingevoerde installatiegegevens talloze malen gecontroleerd, waarna uiteindelijk bleek dat enkel met het terugschakelen van de php versie, het probleem opgelost bleek te worden.

Wat betreft het terugzetten van het forum, zit ik nu nog met het probleem dat ik niet de juiste backup kan vinden, heb er alleen eentje uit 2011 werkend weten te krijgen, maar zoek er eentje uit 2015. Word nog even een speurtocht, gisteren al 6 uur mee bezig geweest, aanhouder wint.

Offline @rjen

  • Full Member
  • ***
  • Posts: 509
  • Gender: Male
Re: Graag ondersteuning bij terugzetten forum
« Reply #12 on: January 08, 2019, 12:22:11 PM »
Mooi dat het weer werkt, maar nu ben ik nieuwsgierig: staat er nu WEL een settings tabel in je database?
Running SMF 2.0 with Tinyportal 1.6.4 at www.fjr-club.nl
Testing SMF 2.1 RC2 with Tinyportal at http://test2.fjr-club.nl/

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #13 on: January 08, 2019, 01:37:34 PM »
Even gekeken; ja, die staat er nu wel in; backup_smf_settings. Vraag me niet hoe het kan, misschien heb ik een andere database geprobeerd en was de vorige incompleet, geen enkel idee wat daartoe de doorslag gaf.

Offline CoreISP

  • Server Admin
  • Server Team
  • SMF Super Hero
  • *
  • Posts: 18,004
  • Gender: Male
  • Liroy van Hoewijk
    • coreisp on GitHub
    • liroyvh on LinkedIn
    • @liroyvh on Twitter
Re: Graag ondersteuning bij terugzetten forum
« Reply #14 on: January 09, 2019, 08:49:46 AM »
Even gekeken; ja, die staat er nu wel in; backup_smf_settings. Vraag me niet hoe het kan, misschien heb ik een andere database geprobeerd en was de vorige incompleet, geen enkel idee wat daartoe de doorslag gaf.

Dat is een backup tabel, die wordt normaliter niet gebruikt.
Iets naar onder scrollen en dan zou je de normale smf_settings moeten zien. :)

Dit is overigens waarom ik in mijn eerste reactie op je post al voorstelde om eens te kijken of hij wel helemaal hersteld was of het wel compleet was. ;)
SMF werkt trouwens enkel niet goed met PHP 7.2. Wel met 5.6, 7.0 en 7.1.

Met betrekking tot je database herstel.
Je backup uit 2011 werkt, maar die uit 2015 niet als ik het goed begrijp.
Je kan eventueel de backups combineren door handmatig met het bestand te spelen. Stel je smf_settings ontbreekt uit die in 2015, dan kan je die tabel bijvoorbeeld toevoegen aan je database backup van die uit 2015.
Of dit altijd een succes is, is een tweede. Maar er is aardig wat speelruimte mee.
((U + C + I)x(10 − S)) / 20xAx1 / (1 − sin(F / 10))
President/CEO of Simple Machines - Server Manager
Please do not PM for support - anything else is usually OK.

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #15 on: January 09, 2019, 12:13:02 PM »
Quote
Je backup uit 2011 werkt, maar die uit 2015 niet als ik het goed begrijp
Dit is wat ik weet: de juiste backup van 2015, heb ik nog niet kunnen vinden. Backups heb ik gemaakt, net voor een site-verhuizing. Meerdere backups. Ze moeten van 2015 zijn, aangezien ik in web archive zie, dat het forum ten minste tot 2015 online is geweest. Probleem is dat ik de backups nog niet heb kunnen vinden. Vreemde is dat ik wel redelijk wat backups heb kunnen vinden, maar die zijn allemaal tot 2011.

Dus ben ik nog steeds op zoek naar de juiste. Waar ik wel sterk aan twijfel, is of de backups die ik heb gevonden, niet daadwerkelijk de juiste zijn, maar dat de server waarop ik zit, de meest recente data (topics) gewoon niet kan ophalen. Daar begin ik zeer sterk aan te twijfelen. Dus ben nu aan het kijken of ik kan overstappen naar mijn oude host om te zien of de backup (als hij nu onvolledig is), daar wel volledig is. Ze gebruiken daar een oudere PHP versie.

Ik ga er alles aan doen om het forum online te krijgen; de backups MOETEN er zijn. Destijds meerdere gemaakt. De aanhouder wint! :)

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #16 on: January 09, 2019, 06:07:12 PM »
Het lijkt er op dat ik de juiste backup heb gevonden; ik zie de berichten tot 2015 op het forum. Echter, ik juich niet te vroeg, maar het gaat de goede kant op.

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #17 on: January 14, 2019, 10:31:14 AM »
Ik was voor 99% klaar met het terugzetten van het forum (database, files, checks uitgevoerd, etc.), maar op het allerlaatste moment liep het mis. Bij het uploaden van alle backup files (dus folders als attachments, avatars en de andere 10, incll. alle losse files), liep ik tegen een database connection probleem aan. Hierop heb ik gezocht via Google en kwam op een topic uit met de tip de repair_settings te gebruiken.

Zo gezegd, zo gedaan, waarna vervolgens, enkel en alleen na het uitvoeren van de repair_settings, al mijn topics uit 2015 zijn verdwenen en het forum door repair settings is teruggezet naar een status / situatie uit 2011. Ik was er bijna.

Nu heb ik nogmaals de backup uit 2015 teruggezet, niets helpt. Cache verwijderd uit de proces, zonder resultaat. Alle folders nogmaals langsgegaan, niets.

Precies na https://wiki.simplemachines.org/smf/Repair_settings.php ging het fout, dus ik heb gecheckt wat repair_settings allemaal heeft gewijzigd, tot nu toe zonder resultaat. Het forum blijft op de backup van 2011 steken. Dus zelfs terwijl de 2015 backup niet in phpmyadmin staat, althans, dezelfde als die ik heb gebruikt om uit de backup van 2015 te komen.

Het ging mis op het allerlaatste moment bij repair settings.

Offline CoreISP

  • Server Admin
  • Server Team
  • SMF Super Hero
  • *
  • Posts: 18,004
  • Gender: Male
  • Liroy van Hoewijk
    • coreisp on GitHub
    • liroyvh on LinkedIn
    • @liroyvh on Twitter
Re: Graag ondersteuning bij terugzetten forum
« Reply #18 on: January 14, 2019, 10:16:47 PM »
Als het na repair_settings.php is gebeurd, dan is het heel simpel: dan verbind je met de verkeerde database. :P
Waarschijnlijk heb je meerdere backups teruggezet in verschillende databases. Vervolgens heb je in repair_settings.php de verkeerde database gegevens ingevuld.
Mogelijk heb je Settings.php overschreven toen je bestanden aan het terugzetten was.

Je zult dus even moeten kijken naar welke database je die backup uit 2015 hebt teruggezet, en daarvan de gegevens invullen in repair_settings.php.
Dan moeten die posts op magische wijze weer tevoorschijn komen.
((U + C + I)x(10 − S)) / 20xAx1 / (1 − sin(F / 10))
President/CEO of Simple Machines - Server Manager
Please do not PM for support - anything else is usually OK.

Offline James#

  • Semi-Newbie
  • *
  • Posts: 17
Re: Graag ondersteuning bij terugzetten forum
« Reply #19 on: January 15, 2019, 08:45:54 AM »
Als het na repair_settings.php is gebeurd, dan is het heel simpel: dan verbind je met de verkeerde database. :P
Waarschijnlijk heb je meerdere backups teruggezet in verschillende databases. Vervolgens heb je in repair_settings.php de verkeerde database gegevens ingevuld.
Mogelijk heb je Settings.php overschreven toen je bestanden aan het terugzetten was.

Je zult dus even moeten kijken naar welke database je die backup uit 2015 hebt teruggezet, en daarvan de gegevens invullen in repair_settings.php.
Dan moeten die posts op magische wijze weer tevoorschijn komen.

Hi CoreISP! Dank voor je reactie; wordt gewaardeerd. Maar zo simpel als jij denkt dat het is, dacht ik ook! Daarom heb ik direct na het ontstaan van het probleem met repair settings, mijn database gecontroleerd. Daar zat het probleem vreemdgenoeg niet! Nog een bizarre constatering, als ik exact, ik benadruk exact, dezelfde database upload naar Hostgator, werkt het daar wel top. Het enige verschil aan mijn werkzaamheden betreft dat ik bij de Nederlandse host, mijn gebackupte FTP files heb geupload en bij Hostgator, niet. Het kan dus inderdaad aan settings.php te wijten zijn. Echter, ik heb de settings.php grondig gecheckt en ook daar geen problemen geconstateerd. De juiste database instellingen stonden er in!

De volgende stap is dus nu een dubbelcheck, door nogmaals op de Nederlandse host, precies hetzelfde doen als bij Hostgator. Dus een nieuwe installatie van SMF, waarbij ik enkel op /install.php de gegevens van de oude database invul en verder geen gebackupte FTP files upload. Mocht dat werken, dan moet ik als laatste stap uitzoeken hoe ik mijn gebackupte FTP files kan uploaden, zonder dat het opnieuw fout gaat. Ik heb die FTP files namelijk nodig omdat daarin alle bijlagen o.a. in zijn opgeslagen (bijlagen die mijn leden destijds op het forum hebben geplaatst).

In dat geval zal ik de FTP files ditmaal echter 1 voor 1 uploaden of folder voor folder, zodat ik betere foutopsporing kan starten, mocht dat noodzakelijk zijn.