Advertisement:

Author Topic: Mods installed but not visible  (Read 414 times)

Offline tgojevic

  • Newbie
  • *
  • Posts: 6
Mods installed but not visible
« on: January 15, 2019, 08:00:09 AM »
Hi,

I am running SMF v2.0.15 and have installed 2 mods (screenshot attached):

Responsive Curve
Ad Management

but neither is my forum showing as responsive/mobile on mobile devices and I do not see Ad Management options as they suggest: Go into the Admin panel of SMF and under the Configuration heading click on Ad Management then click on Add Ads (screenshots added).

How is this possible even? What can I do, what do I need to check? Any help would be appreciated, thanks!

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,317
  • Gender: Male
    • Kindred-999 on GitHub
Re: Mods installed but not visible
« Reply #1 on: January 15, 2019, 08:06:31 AM »
Did the mods actually install?
What I mean is,  did the mod code actually get applied to the files and the files were actually changed?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline tgojevic

  • Newbie
  • *
  • Posts: 6
Re: Mods installed but not visible
« Reply #2 on: January 15, 2019, 08:13:48 AM »
Well the process went well, through the Package Manager, there were no errors. Is there any other way I can check?

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,317
  • Gender: Male
    • Kindred-999 on GitHub
Re: Mods installed but not visible
« Reply #3 on: January 15, 2019, 10:04:30 AM »
Yes...   as I said, you have to check that the ACTUAL code was changed, added or removed in the actual files.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline tgojevic

  • Newbie
  • *
  • Posts: 6
Re: Mods installed but not visible
« Reply #4 on: January 15, 2019, 10:07:50 AM »
I am not a technical person that I can go into code and understand there were changes made. Can you please give me more info what to look? How do I go into a file and can be sure that e.g. Responsive Curve has made the changes? Is there a line of code that says that or I need to look at source files of Responsive Curve and then of Curve theme and compare them so I see changes there? I never had this kind of issue before, uploading a mod and installing it before (I mean before upgrading to v2.0.15) was always working.

Offline tgojevic

  • Newbie
  • *
  • Posts: 6
Re: Mods installed but not visible
« Reply #5 on: January 15, 2019, 11:07:10 AM »
Ok, went through the files and no, the changes have not been made. What can I do to repair this? I mean, when I install through Package Manager, it says it was installed. Is there something I can do, run a file, so that next time I install a mod, it actually updates the files?

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,317
  • Gender: Male
    • Kindred-999 on GitHub
Re: Mods installed but not visible
« Reply #6 on: January 15, 2019, 11:44:31 AM »
So, that's pretty much the result I suspected.

The issue is with your server configuration and the ownership/permissions to the files.

Basically, your server is set so that the file report OK, but the server (silently) rejects the edits and refuses to allow the script to save the changes.

You will either have to 1) manually edit the files every time you want to install a mod, 2) find the correct chmod setting allowed by your server, or 3) talk to your host.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline tgojevic

  • Newbie
  • *
  • Posts: 6
Re: Mods installed but not visible
« Reply #7 on: January 16, 2019, 07:41:34 AM »
Thanks for the clarification! I will check with the hosting company.