Advertisement:

Author Topic: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5  (Read 2682 times)

Offline trth

  • Semi-Newbie
  • *
  • Posts: 38
Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« on: January 15, 2019, 09:21:51 AM »
Hi together,

since there doesnt seem to be any support in the german section (last 5 posts no answer at all for the last weeks) I will try to describe my problem and english and hope for some help...

I am the administrator of a small cool board community that has been running for the last 11 years. I guess half a year ago I updated to 1.1.21 and SQL 4, but now my provider (Domainfactory) ends support for this SQL Version so I have to change to SQL 5 (and therefore to SMF 2.0.15).

Well, I was able to create a SQL dump and update it to SQL 5 via BigDump. So far so good.

I am able to install a clean 2.0.15 - that is no problem. But now...

When I try to connect the clean new board to the filled SQL 5 database it doesn´t work (Errors in the last step of installation, something with "1" is not "0" or stuff like that).

When I install the board with a new blank SQL database und then try to import my "old" one I get error messages as well ("Unknown column 'add_deny' in 'field list'").

Where is my mistake? How can I handle this?

Thanks in advance for any help and sorry for my english...

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,191
    • StoryBB/StoryBB on GitHub
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #1 on: January 15, 2019, 09:26:46 AM »
You need to run the upgrader from 2.0 against your 1.1 database, which I don’t think you’ve done based on the error messages.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline trth

  • Semi-Newbie
  • *
  • Posts: 38
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #2 on: January 15, 2019, 09:31:51 AM »
that´s right - I looked online for a converter of any kind but couldnt find one - can you tell me the direct download link?

So it´s ok if I install a 2.0.15 and connect it to an already filled SQL 5 DB - but his one has to be converted before?

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,957

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,191
    • StoryBB/StoryBB on GitHub
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #4 on: January 15, 2019, 09:38:45 AM »
Take the MySQL 5 database, grab the 2.0 upgrade package from the downloads page and take your 1.1 Settings.php file, change the database details to point to the MySQL 5 database.

The upgrade is designed to be run in place.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline trth

  • Semi-Newbie
  • *
  • Posts: 38
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #5 on: January 15, 2019, 09:44:28 AM »
ok, thanks, this helps.

So to make it clear the way would be:

- Backup my old board
- create a SQL Dump and upgrade it to SQL 5
- change php on the webspace to a current version (7) as the current version is too old to run 2.0.15 oder SQL 5
- then use the "Large Upgrade" for Version 2.0.15
- upload the new SQL 5 DB an connect it to the board
- everything fine

?

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,191
    • StoryBB/StoryBB on GitHub
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #6 on: January 15, 2019, 09:47:25 AM »
No, that’s really not what I said but unfortunately I’m at work right now and can’t explain in great details,  Rhône that you need to dump the database into MySQL 5 then connect that to the 2.0 upgrade package so it can do the various changes it needs (like renaming the column from addDeny to add_deny)
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline trth

  • Semi-Newbie
  • *
  • Posts: 38
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #7 on: January 15, 2019, 09:49:42 AM »
ok, got it (I guess)

Thank you all so much so far for your help!  :)

Offline trth

  • Semi-Newbie
  • *
  • Posts: 38
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #8 on: January 15, 2019, 01:10:56 PM »
looks good til now... but now I have this error message:


!!
Error!
Table 'db212587_3.smf_log_errors' doesn't exist


That´s right - I killed it one year ago or so... what can I do?

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,317
  • Gender: Male
    • Kindred-999 on GitHub
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #9 on: January 15, 2019, 02:16:07 PM »
why would you ever delete a table in the database?? ?? ?? ??

NEVER EVER EVER DO THAT!



look at the install sql and then manually recreate the table.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline trth

  • Semi-Newbie
  • *
  • Posts: 38
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #10 on: January 15, 2019, 02:20:27 PM »
because I was stupid  :o

I copied smf113_log_errors to smf_log_errors... seems to work....

Offline trth

  • Semi-Newbie
  • *
  • Posts: 38
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #11 on: January 15, 2019, 02:35:59 PM »
well it worked  ;D

But one problem is left - I installed the german language, but "ä", "ü", "ö" and "ß" are not available - it only shows things like "rü". But only in the messages, not in the administration - there everything is right.

Does anybody know why?  :o

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,317
  • Gender: Male
    • Kindred-999 on GitHub
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #12 on: January 15, 2019, 02:52:45 PM »
convert to UTF-8
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline trth

  • Semi-Newbie
  • *
  • Posts: 38
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #13 on: January 15, 2019, 03:29:31 PM »
I did (with the possibility within the board) and now it looks like this:


Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,317
  • Gender: Male
    • Kindred-999 on GitHub
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #14 on: January 15, 2019, 03:38:55 PM »
confirm that all tables and columns in your database are utf-8
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline trth

  • Semi-Newbie
  • *
  • Posts: 38
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #15 on: January 15, 2019, 03:42:38 PM »
they are not - they are all "latin1_swedish_ci" in phpmyadmin and I don´t know how to change that...

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,317
  • Gender: Male
    • Kindred-999 on GitHub
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #16 on: January 15, 2019, 04:11:15 PM »
Changing it database wide:

ALTER DATABASE <database_name> CHARACTER SET utf8 COLLATE utf8_unicode_ci;

Changing it per table:

ALTER TABLE <table_name> CONVERT TO CHARACTER SET utf8 COLLATE utf8_unicode_ci;

Good practice is to change it at table level as it'll change it for columns as well. Changing for specific column is for any specific case.

Changing collation for a specific column:

ALTER TABLE <table_name> MODIFY <column_name> VARCHAR(255) CHARACTER SET utf8 COLLATE utf8_unicode_ci;
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline trth

  • Semi-Newbie
  • *
  • Posts: 38
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #17 on: January 15, 2019, 04:28:54 PM »
this is nothing I can do in phpmyadmin, right?

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,317
  • Gender: Male
    • Kindred-999 on GitHub
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #18 on: January 15, 2019, 05:00:38 PM »
those commands are run from the SQL tab in phpmyadmin
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline trth

  • Semi-Newbie
  • *
  • Posts: 38
Re: Switch from 1.1.21 to 2.0.15 with Upgrade from SQL 4 to SQL 5
« Reply #19 on: January 15, 2019, 05:33:52 PM »
Well it seems that I am fine - so far. Chars wont work but thats ok.

But I dont see any buttons / possibilities to change to administration tools to use another theme - looks strange?

BTW - if anyone wants to help me by just doing it - I dont mind spending 20 Bucks (Dollar? Pounds? Euros?) via paypal if it works afterwards. I don´t think that there is so much left that isn´t correct.

- latin1 to UFT doesnt work (its funny - I put back the old 1.1.14 with SQL 4 and told the installer to "use UFT" - and in 1.1.14 he does it. In 2.0.15 he doesnt with the same command - and it´s the same database, only migrated to SQL5).
- Theme doesnt work

For a newbie I think I did quite well  ;D Well, BIG THANKS to all you here - great support!
« Last Edit: January 15, 2019, 05:58:01 PM by trth »