Advertisement:
GCWebhosting

Author Topic: Topic Posting Issue  (Read 1288 times)

Online Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,463
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Topic Posting Issue
« Reply #20 on: February 06, 2019, 11:23:51 PM »
Caching. That is exactly what caching does, and is supposed to do.
« Last Edit: February 07, 2019, 01:43:30 AM by Aleksi "Lex" Kilpinen »
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.
  Fooling around with an i7 990X @ 3,47Ghz / 12Gb / Win 10 x64 / 3840x2160


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Captain Bigzy

  • Semi-Newbie
  • *
  • Posts: 18
Re: Topic Posting Issue
« Reply #21 on: February 08, 2019, 03:48:29 PM »
Caching. That is exactly what caching does, and is supposed to do.

Ok so is there something I can do or just leave it be with the delay? Thanks.

Online Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,463
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Topic Posting Issue
« Reply #22 on: February 08, 2019, 03:51:48 PM »
If your host is doing some sort of caching, you can at least try disabling the cache in SMF to see if it would make a difference.
If it doesn't seem to help, all you can do is ask your host to look in to it, as the reason is most likely Varnish.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.
  Fooling around with an i7 990X @ 3,47Ghz / 12Gb / Win 10 x64 / 3840x2160


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Captain Bigzy

  • Semi-Newbie
  • *
  • Posts: 18
Re: Topic Posting Issue
« Reply #23 on: February 08, 2019, 09:14:37 PM »
Alrighty I will ask them, I already disabled Varnish via the .htaccess file

Code: [Select]
Header add "Cache-Control" "no-cache"
Not sure if thats right though, just what someone suggested I try.

Offline drewactual

  • Full Member
  • ***
  • Posts: 654
    • College Football Fan Site CFB51
Re: Topic Posting Issue
« Reply #24 on: February 08, 2019, 09:35:28 PM »
since you can access htaccess, check for these, and if not there, add them:

Code: [Select]

## EXPIRES CACHING ##
<IfModule mod_expires.c>
  ExpiresActive On
  ExpiresByType image/jpg "access plus 6 months"
  ExpiresByType image/jpeg "access plus 6 months"
  ExpiresByType image/gif "access plus 6 months"
  ExpiresByType image/png "access plus 6 months"
  ExpiresByType text/css "access plus 6 months"
  ExpiresByType application/javascript "access plus 6 months"
  ExpiresByType text/javascript "access plus 6 months"
  ExpiresByType text/x-javascript "access plus 6 months"
  ExpiresByType application/x-shockwave-flash "access plus 6 months"
  ExpiresByType image/ico "access plus 1 year"
  ExpiresByType image/x-icon "access plus 1 year"
  ExpiresDefault "access plus 6 months"
  ExpiresByType application/x-httpd-php A0
  ExpiresByType application/x-python-code A0
  ExpiresByType text/html A0
</IfModule>
## EXPIRES CACHING ##

and the headers as well:
Code: [Select]
<ifModule mod_headers.c>
  <filesMatch "\\.(ico|pdf|flv|jpg|jpeg|png|gif)$">
   Header set Cache-Control "max-age=15778800, public"
  </filesMatch>
  <filesMatch "\\.(css)$">
   Header set Cache-Control "max-age=15778800, public"
  </filesMatch>
  <filesMatch "\\.(js)$">
   Header set Cache-Control "max-age=15778800, private"
  </filesMatch>
  <filesMatch "\\.(xml|txt)$">
   Header set Cache-Control "max-age=15778800, public, must-revalidate"
  </filesMatch>
  <filesMatch "\\.(html|htm|php)$">
   Header set Cache-Control "max-age=1, private, must-revalidate"
  </filesMatch>
</ifModule>

notice that in both directives the php/html/htm is set to expiring the cache either immediately or at access +one second... If you don't have the rest of the directives, give them a shot.  you'll like what it does for you most likely.  caveat: these aren't a good idea UNLESS you rarely change/alter your files...

that 'should' take care of your problem, which is the output of php (html) is being held on to for too long... even 60 seconds can be too much for a forum if people are waiting around for a response, and not seeing one within a minute (because the cache let it live that long).