Advertisement:

Author Topic: 2.1 RC1 New User Registration - Database Error!  (Read 641 times)

Offline arslun

  • Newbie
  • *
  • Posts: 8
2.1 RC1 New User Registration - Database Error!
« on: February 08, 2019, 02:17:35 PM »
Unable to register a new user. Tried multiple times, keep getting the following error:

Please try again. If you come back to this error screen, report the error to an administrator

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,471
Re: 2.1 RC1 New User Registration - Database Error!
« Reply #1 on: February 08, 2019, 02:29:34 PM »
anything in the error log?

Offline arslun

  • Newbie
  • *
  • Posts: 8
Re: 2.1 RC1 New User Registration - Database Error!
« Reply #2 on: February 08, 2019, 03:44:21 PM »
Here is the log:
******
Type of error: Database
Database Error: Field 'adk_pages_notifications' doesn't have a default value
 /index.php?action=signup2

/Sources/Subs-Members.php (Line 709)

Offline vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 21,628
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: 2.1 RC1 New User Registration - Database Error!
« Reply #3 on: February 08, 2019, 03:46:55 PM »
That's from an old mod you can either drop that column frrom the members table or make sure that it allows null.

I think it mostly is caused by this line which forces proper SQL in mysql
Code: [Select]
mysqli_query($connection, 'SET SESSION sql_mode = \'ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION\'');
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline arslun

  • Newbie
  • *
  • Posts: 8
Re: 2.1 RC1 New User Registration - Database Error!
« Reply #4 on: February 08, 2019, 04:51:44 PM »
Thanks for the quick response.
I will take a look at that table and try to fix.
Welcome to provide any solutions/comments.
Thank you

Offline vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 21,628
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: 2.1 RC1 New User Registration - Database Error!
« Reply #5 on: February 08, 2019, 04:55:43 PM »
Try that first if not remove that line in Subs-Db-mysql.php (102)
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline arslun

  • Newbie
  • *
  • Posts: 8
Re: 2.1 RC1 New User Registration - Database Error!
« Reply #6 on: February 09, 2019, 11:27:27 AM »
Hi vbgamer45,
Removed that line but still got the same error message.
I even didn't find such a field in the database. I searched from the logs and found that that field seems from a mod called adkportal which made the whole forum not-accessible by returning http 500 error. So I reinstalled the forum and pointed the newly installed forum to the old db.

How do we clean the old tables?

Thanks

Offline albertlast

  • Development Contributor
  • Full Member
  • *
  • Posts: 589
Re: 2.1 RC1 New User Registration - Database Error!
« Reply #7 on: February 09, 2019, 11:47:15 AM »
a pr from my side exists which could possible fix the issue: https://github.com/SimpleMachines/SMF2.1/pull/5401
but i don't know if it works and if this get merge.

When you got the chance you could test this.

Offline shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 1,522
    • sbulen on GitHub
Re: 2.1 RC1 New User Registration - Database Error!
« Reply #8 on: February 09, 2019, 11:50:16 AM »
First theory is that you somehow still have the hooks installed.   

If you installed the 2.1 code on top of your 2.0 code, and the hooks are still there, it may be trying to execute. 

To confirm, 2 questions:

1) Do you have a bunch of settings in your smf_settings table that start with "integrate_", e.g.:
   integrate_actions   Adk_portal_add_index_actions
   integrate_admin_areas   Adk_portal_add_admin_areas
   integrate_buffer   Adk_portal_change_buffer
   integrate_display_buttons   Adk_portal_display_buttons
   integrate_load_permissions   Adk_portal_Permissions
   integrate_load_theme   Adk_portal_load_from_theme
   integrate_menu_buttons   Adk_portal_add_menu_buttons
   integrate_pre_include   $sourcedir/AdkPortal/Subs-adkfunction.php
   integrate_pre_load   Adk_portal_pre_load
   integrate_redirect   Adk_portal_redirect
   integrate_whos_online   Adk_portal_who

2)  Do you still have an /adkportal folder on your forum?
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 1,522
    • sbulen on GitHub
Re: 2.1 RC1 New User Registration - Database Error!
« Reply #9 on: February 09, 2019, 02:56:28 PM »
I even didn't find such a field in the database. I searched from the logs and found that that field seems from a mod called adkportal which made the whole forum not-accessible by returning http 500 error. So I reinstalled the forum and pointed the newly installed forum to the old db.

arslun -

We're pretty sure that column exists in your database, or you wouldn't be getting this error.  It would be in your members table, & would look something like the attached (which is from phpmyadmin, for the members table, under "Structure" tab).   If you are not using adkportal, you should delete the column.  If you *are* still using adkportal, then you need to provide a default value for that column (null works). 

Attached is what this will look like in phpmyadmin. 

Take another peek!
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline arslun

  • Newbie
  • *
  • Posts: 8
Re: 2.1 RC1 New User Registration - Database Error!
« Reply #10 on: February 09, 2019, 04:37:27 PM »
It issue has be resoled after removing those 2 adk_* fields from the table.

Thanks for our help.