Advertisement:

Author Topic: Posts showing blank  (Read 472 times)

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Posts showing blank
« on: February 11, 2019, 12:16:18 AM »
I am having a problem posting to my forum.
Two of us, both admins, are posting in boards and the members see something has been posted but there is nothing in the post it is blank.
Tried it using the default theme, same.
May just be one board? not sure about that. Too hard to contact people at different times.
http://xs1100.com.au/forum [nofollow]
http://xs1100.com.au/forum/index.php?topic=3066.0 [nofollow]

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Posts showing blank
« Reply #1 on: February 11, 2019, 12:22:57 AM »
What's the content of that post?
Any errors in your logs, either SMF or server?

It would look like the post is not there at all, according to the html source.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Re: Posts showing blank
« Reply #2 on: February 11, 2019, 12:32:40 AM »
I've been told there's no errors in SMF log, and I have no mods. Also I see the text but others can't see it even when they press edit.

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Re: Posts showing blank
« Reply #3 on: February 11, 2019, 12:35:02 AM »
I posted as fred blogs a member and it was seen but the post I did as xtian (admin) is blank to members, I can see them as xtian but not fred blogs (both me)

Seems some posts can be seen and others can't???


« Last Edit: February 11, 2019, 12:58:33 AM by xtian »

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Posts showing blank
« Reply #4 on: February 11, 2019, 12:36:26 AM »
Could you quote a post that is missing, in it's entirety, and post it here. 
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Re: Posts showing blank
« Reply #5 on: February 11, 2019, 12:58:56 AM »
Once again I must apologise for my absence,
Eennie hoo, more work has been done on the motor, it’s back in 1 whole now,
I was about to start installing all the new stainless head bolts when I figured out it’d be easier to install pistons first
I do have to admit the gudgeon pin clips have stopped play for these days off, couldn’t for the life of me get them to go in, and I wasn’t about to scratch the crap out of the sides bumbling through, so a fresh set of eyes, hands and fingers next days off should see most of the build done,
I’ve made a couple of videos also whilst moving through different stages of the build, and they’ll be up shortly

I hope this post shows shows up, don’t know if I doing something wrong or not,

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Re: Posts showing blank
« Reply #6 on: February 11, 2019, 01:02:11 AM »
BUT this post can be seen, both posted by me as xtian (admin)

Find us at the Alexandria Industrial Estate, Unit D1, 46-62 Maddox Street Alexandria Customer parking available - enter via Huntley St or Maddox St EAST entrance (see the green arrows below for entry). Street parking is also available.


Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Posts showing blank
« Reply #7 on: February 11, 2019, 01:02:24 AM »
Okay, thanks - I was hoping for something that would jump out at me, but there's really nothing special there.

Was it posted through the quick reply form, or the full reply?
Did you copy/paste anything in the post?
Are you using WYSIWYG?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Re: Posts showing blank
« Reply #8 on: February 11, 2019, 01:03:48 AM »

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Re: Posts showing blank
« Reply #9 on: February 11, 2019, 01:25:44 AM »
I just contacted one of the other admins and when he gets home he will try a post and see what happens

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Posts showing blank
« Reply #10 on: February 11, 2019, 01:27:20 AM »

Did you copy/paste anything in the post?
Are you using WYSIWYG?
If you are using WYSIWYG, would turning it off make a difference?

If not, can you or another admin check the DB to see how the post appears there?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Re: Posts showing blank
« Reply #11 on: February 11, 2019, 01:30:30 AM »
Not using WYSIWYG as far as I know
Just checked and the disable box was not ticked so now it is
Yes 2 of the posts were pasted in from other documents and a post

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Re: Posts showing blank
« Reply #12 on: February 11, 2019, 01:36:47 AM »
Disabling WYSIWYG made no difference

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Posts showing blank
« Reply #13 on: February 11, 2019, 01:38:49 AM »
Okay, that seems like one more possible culprit eliminated - I was thinking WYSIWYG and copy/paste could do interesting stuff.
The WYSIWYG editor is sadly broken beyond repair in 2.0
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Re: Posts showing blank
« Reply #14 on: February 11, 2019, 01:42:43 AM »
When I pasted this message on the end of a post that shows, the whole post went blank.
When I went in and deleted it the original post reappeared

Once again I must apologise for my absence,
Eennie hoo, more work has been done on the motor, it’s back in 1 whole now,
I was about to start installing all the new stainless head bolts when I figured out it’d be easier to install pistons first
I do have to admit the gudgeon pin clips have stopped play for these days off, couldn’t for the life of me get them to go in, and I wasn’t about to scratch the crap out of the sides bumbling through, so a fresh set of eyes, hands and fingers next days off should see most of the build done,
I’ve made a couple of videos also whilst moving through different stages of the build, and they’ll be up shortly

I hope this post shows shows up, don’t know if I doing something wrong or not,

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Posts showing blank
« Reply #15 on: February 11, 2019, 01:43:44 AM »
Alright - Next step: Server error log. Pretty sure there has to be something there.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Re: Posts showing blank
« Reply #16 on: February 11, 2019, 01:50:17 AM »
I just did some message in a text document and cut and pasted it into a message that can be seen and it was ok so the pasting doesn't seem to be the problem

Find us at the Alexandria Industrial Estate, Unit D1, 46-62 Maddox Street Alexandria Customer parking available - enter via Huntley St or Maddox St EAST entrance (see the green arrows below for entry). Street parking is also available.

pasted message
Testing One Two Three
abcdefghijklmnop

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Posts showing blank
« Reply #17 on: February 11, 2019, 02:19:46 AM »
No, the actual action of copying and pasting is not the issue, but certain contents when copied over to the Wysiwyg -editor will cause oddities. That's known.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Re: Posts showing blank
« Reply #18 on: February 11, 2019, 03:10:48 AM »
Checked server error log and it is empty also I don't have buddies or ignore lists in the forum
I tried the paste with and without WYSIWIG and had the same result.

I am waiting for one of the other admins to get home to his place and he will give it a try

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 70,157
    • StoryBB/StoryBB on GitHub
Re: Posts showing blank
« Reply #19 on: February 11, 2019, 03:39:16 AM »
I’m wondering if a full files+database backup followed by UTF-8 conversion would do the trick here.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Posts showing blank
« Reply #20 on: February 11, 2019, 05:00:13 AM »
I’m wondering if a full files+database backup followed by UTF-8 conversion would do the trick here.
That just might be.

When I pasted this message on the end of a post that shows, the whole post went blank.
When I went in and deleted it the original post reappeared

Could you try this:

Once again I must apologise for my absence,
Eennie hoo, more work has been done on the motor, it's back in 1 whole now,
I was about to start installing all the new stainless head bolts when I figured out it'd be easier to install pistons first
I do have to admit the gudgeon pin clips have stopped play for these days off, couldn't for the life of me get them to go in, and I wasn't about to scratch the crap out of the sides bumbling through, so a fresh set of eyes, hands and fingers next days off should see most of the build done,
I've made a couple of videos also whilst moving through different stages of the build, and they'll be up shortly

I hope this post shows shows up, don't know if I doing something wrong or not,

( The difference is simple, I replaced every instance of ’ with ' )
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline xtian

  • Semi-Newbie
  • *
  • Posts: 17
Re: Posts showing blank
« Reply #21 on: February 11, 2019, 05:37:15 AM »
How sneaky seems that he is now using an Apple computer/phone so I will have to call him and let him know
I've also now converted to UTF8

Thanks for all the help sorry it was such a silly mistake
cheers from Australia

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Posts showing blank
« Reply #22 on: February 11, 2019, 05:54:55 AM »
I've also now converted to UTF8
This should prevent the issue in the future :)
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas