Advertisement:

Author Topic: Fresh installed SMF Forum 2.0.15 - no theme  (Read 295 times)

Offline ///M3Power

  • Semi-Newbie
  • *
  • Posts: 21
Fresh installed SMF Forum 2.0.15 - no theme
« on: February 12, 2019, 08:37:22 AM »
Hello,

I've recently downloaded and installed SMF 2.0.15
https://imgur.com/a/SGIcHVr [nofollow]
Created database and all, but I have no idea why it doesn't have the proper page layout/theme as you could see on the above images.
Note: Already tried to upload and install again, but it remains the same.

Any help would be appreciated.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Fresh installed SMF Forum 2.0.15 - no theme
« Reply #1 on: February 12, 2019, 08:39:59 AM »
This can happen sometimes, on certain server configs, but is luckily easy to fix.
Check out repair_settings and go through the urls for your themes. :)

What is repair_settings.php?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline ///M3Power

  • Semi-Newbie
  • *
  • Posts: 21
Re: Fresh installed SMF Forum 2.0.15 - no theme
« Reply #2 on: February 12, 2019, 08:45:39 AM »
Hello Aleksi and thank you for your quick response.
I've clicked on the link you provided, but got the following error:
https://imgur.com/a/XcJOMFp [nofollow]

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Fresh installed SMF Forum 2.0.15 - no theme
« Reply #3 on: February 12, 2019, 08:50:59 AM »
That's interesting - Seems like our Wiki might have misbehaved. Do try again, or if it doesn't work - go and download the tool from https://download.simplemachines.org/index.php?tools

Next, upload it to your forum's root, and access it through your browser.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline ///M3Power

  • Semi-Newbie
  • *
  • Posts: 21
Re: Fresh installed SMF Forum 2.0.15 - no theme
« Reply #4 on: February 12, 2019, 09:28:25 AM »
I've uploaded and ran it through my browser.
Not sure what to do next, hmm?
https://imgur.com/a/EMhoBl1 [nofollow]

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,311
Re: Fresh installed SMF Forum 2.0.15 - no theme
« Reply #5 on: February 12, 2019, 09:29:51 AM »
at the bottom of the file click on where it says reset all settings and save the file, once complete check if this fixed issue then delete the file off your server.

Offline ///M3Power

  • Semi-Newbie
  • *
  • Posts: 21
Re: Fresh installed SMF Forum 2.0.15 - no theme
« Reply #6 on: February 12, 2019, 09:45:37 AM »
Did it as you've said, but it seems to be all the same:
https://imgur.com/a/A4LAB2T [nofollow]

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Fresh installed SMF Forum 2.0.15 - no theme
« Reply #7 on: February 12, 2019, 09:55:40 AM »
I am unable to reach your domain at all, are you using local addresses to run the tool? If you are, there's a risk you are just repeating the mistake the installer did.
EDIT: no, sorry - My bad. Wait a second.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,923
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Fresh installed SMF Forum 2.0.15 - no theme
« Reply #8 on: February 12, 2019, 09:59:57 AM »
I am unable to reach your domain at all, are you using local addresses to run the tool? If you are, there's a risk you are just repeating the mistake the installer did.
EDIT: no, sorry - My bad. Wait a second.
Alright, seems your urls are still wrong - they should be full urls, so most commonly the suggested values under the boxes in repair_settings.
What I see now is "href="/css/index.css?fin20""
What I should see is "href="https://elite-duckerz.eu/forum/Themes/default/css/index.css?fin20"
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline ///M3Power

  • Semi-Newbie
  • *
  • Posts: 21
Re: Fresh installed SMF Forum 2.0.15 - no theme
« Reply #9 on: February 12, 2019, 10:13:29 AM »
So, any suggestions for the further improvements?
Here are the URLs in repair_settings.php:
https://imgur.com/a/1h5x8Jo [nofollow]

Offline Bob Perry of Web Presence Consulting

  • Sr. Member
  • ****
  • Posts: 989
  • Gender: Male
  • (T)ogether (E)veryone (A)chieves (M)ore
    • Bobert921 on Facebook
    • https://www.linkedin.com/in/bperry921/ on LinkedIn
    • @bperry921 on Twitter
    • Web Presence Consulting
Re: Fresh installed SMF Forum 2.0.15 - no theme
« Reply #10 on: February 12, 2019, 10:51:42 AM »
So, any suggestions for the further improvements?
Here are the URLs in repair_settings.php:
https://imgur.com/a/1h5x8Jo

Coming in late to conversation, when you went through the list of path settings and checked that all the paths were set correctly, did you click the blue recommendation for each of the theme paths? if they are even listed, cause the pic doesn't go all the way to bottom of screen so we can't see them?
Best Regards,
Bob Perry



"The world is moving so fast these days that the man who says it can't be done is generally interrupted by someone doing it." Elbert Hubbard

Offline ///M3Power

  • Semi-Newbie
  • *
  • Posts: 21
Re: Fresh installed SMF Forum 2.0.15 - no theme
« Reply #11 on: February 14, 2019, 08:07:22 AM »
Not sure what's wrong with it neither I know how to fix it, that's the reason for my post over here.
I did use SMF in the past without any problems and I have only good words to say for SMF.
What's the reason for my kind of problem? Is it perhaps the webhost?
Any working solutions posted in here would very much please me as I love SMF and I wouldn't really like to use any other Forum platform for my community other than SMF.

Cheers & have a nice day!  :)

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 70,157
    • StoryBB/StoryBB on GitHub
Re: Fresh installed SMF Forum 2.0.15 - no theme
« Reply #12 on: February 14, 2019, 09:05:35 AM »
Well, I went to the link in question and see a phpBB installation in progress, but the issue is a bug in the installer which can be fixed by way of using repair_settings.php correctly.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.