Advertisement:

Author Topic: Correct letter isn't shown in boardindex  (Read 399 times)

Offline jsx

  • Jr. Member
  • **
  • Posts: 339
  • Gender: Male
Correct letter isn't shown in boardindex
« on: February 14, 2019, 04:37:29 PM »
Hi,

My acquaintance has a forum SMF 2.0.15 and there is an error that causes that the Polish letter "w" can not be displayed here:



I uploaded the language files again, but unfortunately the English letter "in" still appears here. I have no idea what causes this error. Please help me how to fix it.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,063
  • Gender: Male
    • Kindred-999 on GitHub
Re: Correct letter isn't shown in boardindex
« Reply #1 on: February 14, 2019, 05:47:39 PM »
convert to utf-8
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 70,956
    • StoryBB/StoryBB on GitHub
Re: Correct letter isn't shown in boardindex
« Reply #2 on: February 14, 2019, 06:14:46 PM »
Eh? The issue is more likely that the theme doesn't respect the language pack...
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline jsx

  • Jr. Member
  • **
  • Posts: 339
  • Gender: Male
Re: Correct letter isn't shown in boardindex
« Reply #3 on: February 15, 2019, 04:21:13 AM »
convert to utf-8

From the beginning, the forum uses UTF-8 encoding. Database and language files.

Eh? The issue is more likely that the theme doesn't respect the language pack...

This mistake occurs also on the default theme:



This letter "in" is not generated from the index.english.php file. I changed this letter to another one for checking and the letter "in" still remains.

372 line index.english.php

Code: [Select]
$txt['in'] = 'in';

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,162
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Correct letter isn't shown in boardindex
« Reply #4 on: February 15, 2019, 04:28:32 AM »
What language packs are installed?
What theme is the forum using?
And, could we see an URL? Sorry - Seems this is already included.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline jsx

  • Jr. Member
  • **
  • Posts: 339
  • Gender: Male
Re: Correct letter isn't shown in boardindex
« Reply #5 on: February 15, 2019, 04:33:55 AM »
Quote
What language packs are installed?

English and Polish-UTF8 (main).

Quote
What theme is the forum using?

Express. But on every theme, the letter "in" is displayed instead of the Polish "w" in this place.


Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 18,162
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • There's No Place Like 127.0.0.1
Re: Correct letter isn't shown in boardindex
« Reply #6 on: February 15, 2019, 04:36:39 AM »
Okay, check index.polish-utf8.php instead of index.english.php
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline jsx

  • Jr. Member
  • **
  • Posts: 339
  • Gender: Male
Re: Correct letter isn't shown in boardindex
« Reply #7 on: February 15, 2019, 04:42:42 AM »
I checked the file index.polish-utf8.php and in 373 line the letter "w" is correctly entered.

373 line index.polish-utf8.php

Code: [Select]
$txt['in'] = 'w';
I uploaded all the language polish packet again and the letter "in" is still displayed.


Offline jsx

  • Jr. Member
  • **
  • Posts: 339
  • Gender: Male
Re: Correct letter isn't shown in boardindex
« Reply #8 on: February 15, 2019, 05:17:09 AM »
Maybe I should uninstall all modifications and copy the database and then install clean SMF?

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 70,956
    • StoryBB/StoryBB on GitHub
Re: Correct letter isn't shown in boardindex
« Reply #9 on: February 15, 2019, 05:26:56 AM »
I think you have a modification to the board index then, that doesn’t respect the language pack...
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline jsx

  • Jr. Member
  • **
  • Posts: 339
  • Gender: Male
Re: Correct letter isn't shown in boardindex
« Reply #10 on: February 15, 2019, 05:45:17 AM »
I think you have a modification to the board index then, that doesn’t respect the language pack...

You're right. In the translation of the modification there was no Polish letter "in". Thanks for the help.
« Last Edit: February 15, 2019, 06:38:03 AM by jsx »