Advertisement:

Author Topic: Changing hosts and moving from root to /public_html  (Read 797 times)

Offline Koda

  • Semi-Newbie
  • *
  • Posts: 25
Changing hosts and moving from root to /public_html
« on: February 20, 2019, 03:29:45 PM »
Hello, I recently changed hosts, and it appears I performed the transfer successfully, especially after running the repair_settings tool, however if I click any links from the main page I am given a not found error.  I believe this is because during the transfer, I had to bump the files up from the www.example.com folder to the www.example.com/public_html folder.  So there appears to be some issue with the links and possibly database.  I kept the url and database information the same, and only changed what was recommended in the repair settings tool.  I am sure this is an easy fix, but I must be overlooking something.

Thank you.

Offline Shambles

  • SMF Hero
  • ******
  • Posts: 5,145
  • Gender: Male
    • i30 Owners Club
Re: Changing hosts and moving from root to /public_html
« Reply #1 on: February 20, 2019, 03:31:36 PM »
Are you sure you're running a version of SMF 1.1.* ?

Offline Koda

  • Semi-Newbie
  • *
  • Posts: 25
Re: Changing hosts and moving from root to /public_html
« Reply #2 on: February 20, 2019, 03:45:45 PM »
How can I check the version?  I recall I am using some sort of hybrid of the two, I believe I might be using a newer version that was adapted to fit  1.x template.

What is odd is that the front page works perfectly, but not a single link will open.  I had thought it might be prettyurls, but even the search, admin, login, etc all bring up errors

I am using a 2.0 version, let me remake this topic in the correct section, my apologies