Advertisement:

Author Topic: forum mail settings obviously jacked up  (Read 447 times)

Offline Dan_

  • Semi-Newbie
  • *
  • Posts: 79
  • Gender: Male
    • Eagler's Nest
forum mail settings obviously jacked up
« on: March 13, 2019, 12:35:22 AM »
I have read everything I can find on this problem.  I think this problem may have started when I changed my hosting level to
Cpanel.   Godaddy just gave me a new username and now I can log in with either.  I am using SMF 2.0.15.

I have gone in circles and actually got the testmail.php script to actually deliver a couple of emails these past few days.  But never an activation email or a forgot my password email...
When you call Godad support they get around helping you with the problem as fast as possible, and start trying to upsell you on some additional hosting products.
The attached screenshot shows a residue of my trying to get smtp to work.  I change the type drop down  back to (php default) and back everything out of all the other inputs...  When I hit save the  page scrolls up to the top.  When I scroll it back down I see the PW has jumped back in.  :o
Could this be fixed with a manual edit to the database..?
Cheers, and Thanks in advance for your time.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,140
  • Gender: Male
    • Kindred-999 on GitHub
Re: forum mail settings obviously jacked up
« Reply #1 on: March 13, 2019, 09:19:32 AM »
that password fill in is due to your browser settings....
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Dan_

  • Semi-Newbie
  • *
  • Posts: 79
  • Gender: Male
    • Eagler's Nest
Re: forum mail settings obviously jacked up
« Reply #2 on: March 13, 2019, 06:49:13 PM »
Thanks...  That made sense. So I logged out of the forum on FF and tried I.E. with autocomplete turned off and everything I could find to disable a pw being dispensed, every history, cookie, password etc... 

It still seems like something is amiss.  I.E. keeps putting in the same long pw.  Even after I tried to put in a 3 letter one.

Last night I found a row in a search of the entire database on "smtp_password".  It came back with one row, and it had a pw there in the value field and I made it blank.
I just checked that field again and it is still blank.  Should a text type field say null instead?

Is there a no frills stripped down browser that I can try that does not come with any autocomplete as default to try to change that pw?  Or do I have the wrong DB row..?

At this point I can't tell if it's the browser, database, or me   --flummoxed .
Thanks again.

Offline Tonyvic

  • Jr. Member
  • **
  • Posts: 173
  • Gender: Male
Re: forum mail settings obviously jacked up
« Reply #3 on: March 13, 2019, 07:06:06 PM »
I had the same password situation a few years ago, the 12 letter password is not real. See explanation: https://www.simplemachines.org/community/index.php?topic=538719.msg3828361#msg3828361

Offline Dan_

  • Semi-Newbie
  • *
  • Posts: 79
  • Gender: Male
    • Eagler's Nest
Re: forum mail settings obviously jacked up
« Reply #4 on: March 13, 2019, 09:08:19 PM »
I had the same password situation a few years ago, the 12 letter password is not real. See explanation: https://www.simplemachines.org/community/index.php?topic=538719.msg3828361#msg3828361

Thank you sir.  The fog is lifting some.  I can see the pw has changed this time.  I will mark this solved when I verify a new member receives activation email.

2 things...
  • I suppose a 3 character pw won't go into the database.
  • I suppose the information above would be very helpful in the wiki article about getting your forum to send email.
I appreciate the patient help (i get so often) here very much.
Cheers! 

Offline Dan_

  • Semi-Newbie
  • *
  • Posts: 79
  • Gender: Male
    • Eagler's Nest
Re: forum mail settings obviously jacked up
« Reply #5 on: March 16, 2019, 01:19:37 AM »
I am going to mark this one solved...  I am under the impression that when I went with Cpanel the MX record should have been changed.  I have monkeyed with the settings for days now and apparently arrived at the correct tics in the right boxes. 

I did not call godad again but did search google on them.  They do have a "community" who are much better help in my opinion than calling.
It takes some time for a change in MX records to take effect... I seem to be back with php mail working.
testmail.php arrives and a phantom registrar received  email...
One note...  Testmail.php returns success no matter if the intended recipient gets the email or not.
 
edit:  I am set to php(default) and 5/5 throttle...  I think godad is limited to 250 per day, although I think I ran across 500 at one point but prolly a different level of subscription.