Advertisement:

Author Topic: Installation nouvelle configuration  (Read 2310 times)

Offline obelix1502

  • Semi-Newbie
  • *
  • Posts: 24
Installation nouvelle configuration
« on: April 16, 2019, 10:24:35 AM »
Bonjour,

Avant de refaire mon site à partir de zéro avec smf 2.0.15, je fais un essai sur un serveur qui m'appartient.

C'est donc un serveur dédié, que j'ai formaté et où j'ai installé Ubuntu Server 18.04.

J'ai installé apache, php 7.2 et mysql.

J'ai paramétré les fichiers de configuration et démarré apache et php.ini

J'ai téléchargé smf 2.0.15 et le pack français uft-8 correspondant.

Je l'ai décompressé dans un dossier nommé smf, et j'ai envoyé par Filezilla le contenu du dossier vers /home/obelix/html/outils/forum/

Ensuite à la fin du tutoriel [nofollow], il est indiqué de l' "exécuter, à l'aide de votre navigateur préféré, l'url correspondant à l'emplacement du forum".

Ce que j'ai fait en mettant dans mon navigateur :
Code: [Select]
http://mon_adresse_ip/home/obelix/html/outils/forum/
Et là bien sûr, l'erreur classique :

Code: [Select]
Not Found
The requested URL /home/obelix/html/outils/forum/ was not found on this server.

Apache/2.4.29 (Ubuntu) Server at mon_adresse_ip_du_serveur Port 80

Qu'ai-je donc mal fait ?  ;) ;)

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #1 on: April 16, 2019, 12:13:49 PM »
Bonjour,

Première chose php 7.2 n'est pas supporté il faut php 7.1.

Deuxièmement ton pointage n'est pas correct tu dois avoir l'url >> Ip/répertoire << comme tu n'as pas de nom de domaine pour autant que ta configuration le permette.

Essaie ton pointage sur un index.html à affichage direct pour être certain de ton pointage.

:)

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline obelix1502

  • Semi-Newbie
  • *
  • Posts: 24
Re: Installation nouvelle configuration
« Reply #2 on: April 16, 2019, 01:55:53 PM »
J'ai le problème que sur mon serveur Ubuntu, lorsque je veux installer php, il m'installe automatiquement le 7.2.

Même si je lui précise le 7.1.

Et je ne peux l'installer via un Cpanel, sur ce serveur, je n'en ai pas.  :-[  :P

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #3 on: April 16, 2019, 02:12:13 PM »
Bonjour,

Tu peux installer un 5.6 ou 7.0 aussi c'est comme tu veux :)

Tu peux tester en local avec WampServer si tu veux il faut 10 minutes pour l'installer :)

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline obelix1502

  • Semi-Newbie
  • *
  • Posts: 24
Re: Installation nouvelle configuration
« Reply #4 on: April 16, 2019, 03:28:32 PM »
J'ai installé php 7.1
Apache2 fonctionne.
Mais à l'adresse
Code: [Select]
http://IP_DU_SERVER/html/outils/forum/ ou http://IP_DU_SERVER/forum/
Pourtant j'ai configuré apache2 comme indiqué dans le wiki Ubuntu ainsi que php.

J'ai toujours l'erreur apache2  :-\ :-\

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #5 on: April 16, 2019, 03:39:52 PM »
question de noob:
est ce que, en travaillant en local (via wampserver) on aura un problème lors de la mise en service sur notre hebergeur avec le nom de domaine?
faudra t'il rechanger manuellement toutes les adresses? ou peut on travailler avec notre nom de domaine?
et si on passe par son serveur dedié, est ce qu'on peut préparer le nouveau fofo sur le même nom de domaine?
si oui, est ce qu'il n'y aura pas conflit avec le forum public?
si non, pareil qu'au dessus, faudra t'il rechanger toute les adresses  du forum et de tout les scripts lorsqu'on l'injectera sur notre serveur?

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #6 on: April 17, 2019, 10:17:34 AM »
Bonjour,

Pour la manipulation d'un hébergement vers un autre qu'il soit local ou non il faut chaque fois utiliser l'outil repair_settings pour remettre tous les paths correctement et c'est tout :)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #7 on: April 17, 2019, 11:23:06 AM »
ha d'accord, merci ;)

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #8 on: April 25, 2019, 06:03:47 PM »
bonsoir,
vu tout les problèmes qu'on a eu, j'ai voulu travailler en local sur mon ordi.
Mais quand j'ai importer ma base de donné j'ai cette erreur là:

"La table 'nom de mon forum.smf_settings' n'existe pas"

et c'est vrai qu'elle n'existe pas, mais non plus sur la version en ligne.
alors pourquoi mysql veut il pointer sur ce script fantome?

ensuite, quand j'aurais enfin mon forum en local, pour le mettre à jour tu nous a dis de les passer les uns aprés les autres.
nous sommes en 2.0.11.
pour pouvoir les passer en local, j'imagine qu'il faut que je telecharge les mise à jour 12,13,14 et 15.
est ce que ce sont les patch qui se trouve là qu'il faut que je prenne?
https://custom.simplemachines.org/upgrades/

merci :)

« Last Edit: April 25, 2019, 06:37:26 PM by grandseb59 »

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #9 on: April 25, 2019, 11:23:31 PM »
Bonjour,

En local tu dois créer une base de donnée avec un nom utilisateur.

Quand c'est fait tu fais l'importation de ta base de donnée.

Puis tu reportes le nom de ta base de données locale est son utilisateur dans le settings.php

Quand cela est en ordre que tes fichiers sont reportés tu fais un repair_settings pour remettre les paths locaux à jour.

En ce qui concerne les patchs Smf ils seront présent dans le gestionnaire de paquet juste au dessus sinon tu peux le faire en manuel comme tu l'as indiqué.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #10 on: April 27, 2019, 10:29:55 AM »
ok j'essaie comme ça, merci :)

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #11 on: June 16, 2019, 09:16:35 AM »
bon , après de nombreux soucis pour importer ma base de donner sur wampserver, mais maintenant c'est bon.
après avoir fait un repair setting.
pour info le forum de base est en php 5.1 et wampserver ne me propose au plus bas que du 5.6
j'ai pu acceder à la page d'accueil primaire sans CSS et j'ai ce message d'erreur, que faut il faire?:

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in C:\wamp64\www\Monsite\Sources\Load.php(206) : runtime-created function on line 3
Call Stack
#   Time   Memory   Function   Location
1   0.0010   348280   {main}( )   ...\index.php:0
2   0.0380   3995720   cleanRequest( )   ...\index.php:79
3   0.0380   4001440   htmlspecialchars__recursive( )   ...\QueryString.php:193
4   0.0380   4002272   htmlspecialchars__recursive( )   ...\QueryString.php:363
5   0.0380   4002352   __lambda_func( )   ...\QueryString.php:359
6   0.0380   4002880   preg_replace ( )   ...\Load.php(206) : runtime-created function:3

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #12 on: June 16, 2019, 01:54:53 PM »
Bonjour,

Ton forum est bien en 2.0.15 ? Si c'est le cas tu peux même monter en 7.1 sans soucis.

Sinon il faut commencer par faire la mise à jour correcte de Smf avec un large upgrade pour ne pas avoir de soucis avec les versions de Php.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #13 on: June 16, 2019, 04:31:21 PM »
non je suis en 2.0.11 et php 5.1 en ligne et 5.6 sur wampserveur
j'ai installer le large upgrade 2.0.15 en collant et remplaçant les fichiers comme demander et voilà la reponse:


Quote
Mise à jour de votre installation SMF!
L'upgrader n'a pas pu trouver certains fichiers cruciaux.

Assurez-vous d'avoir téléchargé tous les fichiers inclus dans le package, y compris les thèmes, les sources et d'autres répertoires.

quel fichier cruciaux n'a t'il pas trouver?

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #14 on: June 16, 2019, 04:44:25 PM »
peut être ça peut aider, voici les messages d'erreurs:
Quote
Remarque: index non défini: upgrade_upgrade_utility dans C: \ wamp64 \ www \ monsite \ upgrade.php à la ligne 3509
Pile d'appels
#   Temps   Mémoire   Une fonction   Emplacement
1   0,0040   1187304   {principale}( )   ... \ upgrade.php : 0
2   0,2090   2599624   upgradeExit ()   ... \ upgrade.php : 701
3   0,2090   2599648   template_upgrade_above ()   ... \ upgrade.php : 742

Quote
Remarque: index non défini: upgrade_progress dans C: \ wamp64 \ www \ monsite \ upgrade.php à la ligne 3521
Pile d'appels
#   Temps   Mémoire   Une fonction   Emplacement
1   0,0040   1187304   {principale}( )   ... \ upgrade.php : 0
2   0,2090   2599624   upgradeExit ()   ... \ upgrade.php : 701
3   0,2090   2599648   template_upgrade_above ()   ... \ upgrade.php : 742

Quote
Remarque: index non défini: étape_upgrade dans C: \ wamp64 \ www \ monsite \ upgrade.php à la ligne 3526
Pile d'appels
#   Temps   Mémoire   Une fonction   Emplacement
1   0,0040   1187304   {principale}( )   ... \ upgrade.php : 0
2   0,2090   2599624   upgradeExit ()   ... \ upgrade.php : 701
3   0,2090   2599648   template_upgrade_above ()   ... \ upgrade.php : 742

Quote
Remarque: index non défini: upgrade_time_elapsed dans C: \ wamp64 \ www \ monsite \ upgrade.php à la ligne 3560
Pile d'appels
#   Temps   Mémoire   Une fonction   Emplacement
1   0,0040   1187304   {principale}( )   ... \ upgrade.php : 0
2   0,2090   2599624   upgradeExit ()   ... \ upgrade.php : 701
3   0,2090   2599648   template_upgrade_above ()   ... \ upgrade.php : 742

Quote
Remarque: index non défini: upgrade_time_mins dans C: \ wamp64 \ www \ monsite \ upgrade.php à la ligne 3561
Pile d'appels
#   Temps   Mémoire   Une fonction   Emplacement
1   0,0040   1187304   {principale}( )   ... \ upgrade.php : 0
2   0,2090   2599624   upgradeExit ()   ... \ upgrade.php : 701
3   0,2090   2599648   template_upgrade_above ()   ... \ upgrade.php : 742

Quote
Remarque: index non défini: upgrade_time_secs dans C: \ wamp64 \ www \ monsite \ upgrade.php à la ligne 3561
Pile d'appels
#   Temps   Mémoire   Une fonction   Emplacement
1   0,0040   1187304   {principale}( )   ... \ upgrade.php : 0
2   0,2090   2599624   upgradeExit ()   ... \ upgrade.php : 701
3   0,2090   2599648   template_upgrade_above ()   ... \ upgrade.php : 742
« Last Edit: June 16, 2019, 04:57:53 PM by grandseb59 »

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #15 on: June 16, 2019, 07:01:30 PM »
pour info encore, sur wampserveur, je suis maintenant en php 7.1 avec la version 2.0.15, mais...
avec ce problème en plus:
Quote
Le répertoire du thème par défaut est erroné, veuillez le corriger en cliquant sur ce texte.

quand je clic dessus ça m'amène à la gestion des themes où 2 thèmes sont présent alors qu'ils n'existent plus dans mon dossier théme, alors que dans celui ci il y en a 8  et seul 2 apparaissent sur le forum.... bizzare, non?





Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #16 on: June 17, 2019, 09:26:46 AM »
Bonjour,

Repair_settings le mettre sur forcer le thème par défaut et sauver.

Puis aller dans la gestion des thèmes et effacer tout ce qui ne sert plus à rien.

:)



Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #17 on: June 17, 2019, 06:31:49 PM »
ça y est j'ai réussi à avoir mon forum en local avec ma BDD en php 7.1 et en v 2.0.15 .....mais....
nouveaux problèmes:
il me manque des onglets dans mon panel admin, qui me permet de gerer les blocs
et plus aucun script maison ne fonctionne (ça on s'y attendait mais aurais tu une solution pour qu'ils puissent remarcher?)
merci;)

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #18 on: June 17, 2019, 07:02:23 PM »
Bonsoir,

Tu dois réinstaller tes modules pour commencer un par un, en mettant la nouvelle version pour chaque module.

Après tu verras ce qui te manque au niveau de tes scripts personnels que tu devras reporter et adapter au Php 7.1 le cas échéant.

Procèdes par ordre et prends des notes pour pouvoir remettre tout cela en production par après.

Au moins tu auras une procédure et une installation propre qui te permettra de passer en 2.1 le moment voulu.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #19 on: June 18, 2019, 02:00:20 PM »
j'ai l'impression qu'il me manque des mods depuis la mise à jour et pouvoir gerer les blocks ce n'est pas  un mod de base?
si non, comment s'appelle t'il?

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #20 on: June 18, 2019, 05:35:37 PM »
Bonsoir,

Tu avais peut-être SimplePortal ou truc du genre d'installé ?

Tu vas sur ton forum de production et tu fais une impression de tous les modules puis tu regardes pour les remettre correctement sur le local ainsi tu auras tout les modules à jour à remettre.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #21 on: June 19, 2019, 06:39:49 PM »
oui c'est celui là qu'il me manque.... simple portal, par contre je ne le retrouve pas dans les paquets installés.

j'ai aussi un problème (mais ça ne s'arrêtera donc jamais?  ;D )
quand j'ai mis à jour le profil moderator management j'ai cette erreur fatale que faut il modifier?

Quote
Erreur fatale: impossible de redéclarer PMM_Who () (précédemment déclaré dans C: \ wamp64 \ www \ monsite \ Sources \ Subs.php: 4700) dans C: \ wamp64 \ www \ monsite \ Sources \ Subs.php à la ligne 4713

voici les lignes en question:

Code: [Select]
/* DUH! WINNING! */
function PMM_Who()
{
$SHPMM = '<a href="http://smfhispano.net">Profile Moderator Management by SMF Hispano &copy;</a>';

return $SHPMM;
}

/* DUH! WINNING! */
function PMM_Who()
{
$SHPMM = '<a href="http://smfhispano.net">Profile Moderator Management by SMF Hispano &copy;</a>';

return $SHPMM;
}

?>

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #22 on: June 19, 2019, 07:28:40 PM »
Bonjour,

Regarde bien ton script et tu verras que tu as deux fois la même fonction.

Il faut simplement en supprimer une c'est tout.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #23 on: June 21, 2019, 12:45:58 PM »
bon....l'erreur fatale est réglé, la page de connexion du forum s'affiche, par contre depuis, quand j'essai de me connecter j'ai cette erreur:
Quote
Erreur de connexion. Veuillez vérifier vos réglages pour l'utilisation du témoin.

j'ai essayer d'aller voir ce que c’était, d'après ce que j'ai compris c'est une histoire de cookies, mais j'ai beau supprimer les cookies de mon navigateur mais ça ne change rien :(

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #24 on: June 21, 2019, 01:35:29 PM »
Bonjour,

Non c'est le réglage des cookies qui est incorrect dans ton admin.

Admin -> Paramètres du Serveur -> Cookies …..

Tu dois avoir le nom du cookies -> puis le temps du cookies -> puis 3 cases décochées ->puis une ligne de séparation -> et les 2 dernières cases cochées.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #25 on: June 21, 2019, 01:40:32 PM »
ça c'est dans le forum.... moi je n'y ai plus accés à cause de cette erreur.

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #26 on: June 21, 2019, 04:59:48 PM »
Bonsoir,

Avant de modifier la base de donnée une question de routine :)

Avec ton MySQL de WampServer tu as bien défini un mot de passe et un utilisateur associé pour ta base de données ? car si tu l'as laissé par défaut sans mot de passe Smf ne fonctionnera pas correctement.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #27 on: June 21, 2019, 05:26:13 PM »
j'ai créer un  mot de passe pour mes bases de données via phpmyadmin, mais ça ne change rien toujours la même erreur.

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #28 on: June 26, 2019, 06:23:16 PM »
Bon ben ça m'a énervé .... j'ai tout désinstaller wampserver et tout recommencer à zero, à partir d'une vielle sauvegarde, et maintenant c'est bon.
donc ça devais venir de wampserver, ce dernier problème de connexion.

sinon les smileys ne s'affichent plus, est ce du  à la nouvelle version?
faut il oublier ceux là et reinjecter des nouveaux paquets de smileys?
ou y a t'il un fichier à modifier?

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #29 on: June 27, 2019, 01:56:48 PM »
Bonsoir,

Non si tes Paths sont bons tu dois avoir tes Smileys.

Donc revérifie tes Pahs et la validité de tes Smileys dans ton administration pour voir si tous les fichiers sont bien là.

:)

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #30 on: July 10, 2019, 05:58:31 PM »
bon ben je n'avance pas, j'ai du repartir de zero plusieurs fois avec une quantité d'erreurs incommensurable les une après les autres.
mais là je bloque...
voici la dernière erreur:

Erreur de la base de données
Valeur de chaîne incorrecte: '' '' pour la fonction inet_aton
Fichier: C: \ wamp64 \ www \ monsite \ Sources \ Subs.php
Ligne: 2663

et voici ce qu'il y a à cette ligne:

      $smcFunc['db_query']('', '
         UPDATE {db_prefix}log_online
         SET log_time = {int:log_time}, ip = IFNULL(INET_ATON({string:ip}), 0), url = {string:url}
         WHERE session = {string:session}',
         array(
            'log_time' => time(),
            'ip' => $user_info['ip'],
            'url' => $serialized,
ligne 2663   -->          'session' => $session_id,
         )
      );

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,326
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Installation nouvelle configuration
« Reply #31 on: July 12, 2019, 04:43:07 AM »
Bonjour,

Erreur reportée juste en mode local pas de grands soucis :)

Je suis absent pour quelques temps :)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline grandseb59

  • Semi-Newbie
  • *
  • Posts: 35
Re: Installation nouvelle configuration
« Reply #32 on: July 14, 2019, 05:46:16 PM »
voici la solution:

si vous avez cette erreur: Incorrect string value: '''' for function inet_aton

La solution pour travailler en local: Modifier la ligne de votre httpd.conf dans "Apache" : où il est indiqué...
Listen 80
changer le en  Listen 127.0.0.1:80
et  redémarrez Apache.
Maintenant, localhost utilisera IPv4 127.0.0.1.