• Welcome to Simple Machines Community Forum. Please login or sign up.
December 05, 2021, 11:55:57 AM

News:

SMF 2.0.18 has been released! Please update. Read more.


Unable to verify referring URL. Please go back and try again.

Started by dsanchez, May 05, 2019, 12:15:42 PM

Previous topic - Next topic

dsanchez

Several of these errors in my log:

Type of error: User
Unable to verify referring URL. Please go back and try again.
http://curefans.com/index.php?action=login2


anyone getting similar messages?
Curefans.com - The meeting point for Curefans worldwide
http://www.curefans.com

dsanchez

Ok, this seems a bigger issue than I thought as some members are reporting they can not login :'(
Curefans.com - The meeting point for Curefans worldwide
http://www.curefans.com

albertlast


Arantor

Quote from: albertlast on May 06, 2019, 12:18:15 AM
Why you use login2?
The right url would be http://curefans.com/index.php?action=login and
this work fine on your side.

Probably because it's failing on the actual "user has entered a password" step (login is the form, login2 is the handler)

I did go to the site and see that the login pop up also doesn't work properly :( just returns "error".
No good deed goes unpunished
All helpful urges should be circumvented

dsanchez

Why is this happening? I don't have the problem but it seems some of the users have this problem :(
Curefans.com - The meeting point for Curefans worldwide
http://www.curefans.com

dsanchez

could you guys advise on disable the login popup and instead just redirecting the login link to http://curefans.com/index.php?action=login ?
Curefans.com - The meeting point for Curefans worldwide
http://www.curefans.com

Arantor

Only way to remove it is to remove the reqOverlayDiv call on it, there's no option for it. But would be better to fix the error...
No good deed goes unpunished
All helpful urges should be circumvented

SychO

Checkout My Themes:
-

Potato  •  Ackerman  •  SunRise  •  NightBreeze

Arantor

Or setting subdomain independent cookies - the issue looks to be caused by session mismatch between www. and non-www. use.
No good deed goes unpunished
All helpful urges should be circumvented

SychO

Quote from: Arantor on May 06, 2019, 05:59:28 AM
Or setting subdomain independent cookies - the issue looks to be caused by session mismatch between www. and non-www. use.

indeed

@dsanchez Maintenance > Cookies and session > Use subdomain independent cookies
Checkout My Themes:
-

Potato  •  Ackerman  •  SunRise  •  NightBreeze

dsanchez

Quote from: SychO on May 06, 2019, 06:03:55 AM
Quote from: Arantor on May 06, 2019, 05:59:28 AM
Or setting subdomain independent cookies - the issue looks to be caused by session mismatch between www. and non-www. use.
indeed
@dsanchez Maintenance > Cookies and session > Use subdomain independent cookies

can't see that option (see attachment)

Curefans.com - The meeting point for Curefans worldwide
http://www.curefans.com

SychO

that's because you have to disable local storage of cookies, but you clearly can't even edit those settings, you need to fix that
Checkout My Themes:
-

Potato  •  Ackerman  •  SunRise  •  NightBreeze

Arantor

And the clue is the big "Settings.php is readonly" message up top...
No good deed goes unpunished
All helpful urges should be circumvented

dsanchez

Curefans.com - The meeting point for Curefans worldwide
http://www.curefans.com

dsanchez

Issue seems solved after implemented the suggested changes :)
Curefans.com - The meeting point for Curefans worldwide
http://www.curefans.com

Advertisement: