Advertisement:

Author Topic: Weirdness after Hosting Move  (Read 275 times)

Offline PaulWS

  • Newbie
  • *
  • Posts: 3
Weirdness after Hosting Move
« on: May 12, 2019, 04:35:32 PM »
So I'm seeing some really strange stuff. 

On the forum page I'm logged in in just fine.  When I go to the top admin it askes me for my password again.

When I go to Moderate or My Messages it has me logged in as one of the other moderators. 

I've been through the repair settings page. 
I've checked the files. 
I've checked the php version (7.2).
I've been through the requirements. 
I'm open to looking through these things again as I'm obviously missing something.   

I'm running SMF 2.0.15
alpb.org/Forum/index.php

In the logs I'm seeing error after error like this.
8192: Function create_function() is deprecated

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,133
Re: Weirdness after Hosting Move
« Reply #1 on: May 12, 2019, 04:43:08 PM »
Sounds like Varnish caching on your server.  Ask your host to disable it.

The deprecated error is because you're running in php 7.2.  SMF 2.0 supports up to php 7.1, you'll have to downgrade.

Offline PaulWS

  • Newbie
  • *
  • Posts: 3
Re: Weirdness after Hosting Move
« Reply #2 on: May 12, 2019, 05:32:57 PM »
I downgraded to 7.1 and now It won't let me log in from the main page.  I can still get into admin by going to search>then clicking admin>Features and options.


Offline PaulWS

  • Newbie
  • *
  • Posts: 3
Re: Weirdness after Hosting Move
« Reply #3 on: May 12, 2019, 05:44:48 PM »
They are running Nginx.  I put in a bypass on the forum and that seems to have cleared up the weirdness.

--Paul