Advertisement:

Author Topic: Broken SMF forum on Linux upgrade  (Read 1122 times)

Offline ozbob

  • Semi-Newbie
  • *
  • Posts: 79
Broken SMF forum on Linux upgrade
« on: May 30, 2019, 03:44:54 PM »
Hello,

My forum at https://railbotforum.org/mbs/  has been upgraded to a new Linux 7 server.

This has broken the forum.

I am getting this error.



Can you advise how to proceed please?

Thanks.

Bob


Online vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 21,559
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: Broken SMF forum on Linux upgrade
« Reply #1 on: May 30, 2019, 03:50:50 PM »
Open /etc/my.cnf
Change sql_mode
To
sql_mode = ""


Then restart mysql
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline ozbob

  • Semi-Newbie
  • *
  • Posts: 79
Re: Broken SMF forum on Linux upgrade
« Reply #2 on: May 30, 2019, 03:56:52 PM »
Thanks.  I am not sure how to do that.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,284
Re: Broken SMF forum on Linux upgrade
« Reply #3 on: May 30, 2019, 04:05:10 PM »
did you upgrade the server? do you manage the server, if the answer is no, contact your host.

Offline ozbob

  • Semi-Newbie
  • *
  • Posts: 79
Re: Broken SMF forum on Linux upgrade
« Reply #4 on: May 30, 2019, 04:08:25 PM »
Thanks.  No I did not do the upgrade.  Will go back to my host.

Offline ozbob

  • Semi-Newbie
  • *
  • Posts: 79
Re: Broken SMF forum on Linux upgrade
« Reply #5 on: May 30, 2019, 05:50:06 PM »
Thanks host effected the change suggested above.

All fine now.

Thank you for the help in resolving the issue.

 :)

Online vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 21,559
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: Broken SMF forum on Linux upgrade
« Reply #6 on: May 30, 2019, 05:50:31 PM »
Glad all is working!
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Online CoreISP

  • Server Admin
  • Server Team
  • SMF Super Hero
  • *
  • Posts: 17,946
  • Gender: Male
  • Liroy van Hoewijk
    • coreisp on GitHub
    • liroyvh on LinkedIn
    • @liroyvh on Twitter
Re: Broken SMF forum on Linux upgrade
« Reply #7 on: May 31, 2019, 08:51:14 PM »
Actually that looks like it may be a bug. If it is: one we should probably address if reasonably possible. Encountered it before but forgot about it.
Disabling such mySQL modes is reasonable for a short-term solution, but I don't think it ought to be long-term. Not a huge problem/major concern, but all the same. Would save some trouble too.
((U + C + I)x(10 − S)) / 20xAx1 / (1 − sin(F / 10))
President/CEO of Simple Machines - Server Manager
Please do not PM for support - anything else is usually OK.

Offline albertlast

  • Development Contributor
  • Full Member
  • *
  • Posts: 589
Re: Broken SMF forum on Linux upgrade
« Reply #8 on: June 01, 2019, 12:42:34 AM »
Well the base issue is here that the query are "broken",
this broken queries got fixed in smf 2.1 to get work.

this took some time...

but the funny thing is,
the most of the quries got already fixed in 2.0.x but only for postgres