Advertisement:

Author Topic: Help! Moved to a new host and attachments/uploaded avatars disappeared  (Read 600 times)

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,243
  • Gender: Male
    • Kindred-999 on GitHub
That's the problem... he ran it when the files were missing -- the system detected that the files were missing and removed all attachments and avatars.

The ONLY way to restore the information is to restore the database with the correct information still in it.

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline GunDude

  • Semi-Newbie
  • *
  • Posts: 40
Is there not file maintenance under Attachments and avatars in the admin panel. Has that been run yet. ??

There is, but it actually made my problem worse.  Not realizing the attachments weren't there, that was run which removed the associations.  Now, we have to re-import the database, and hopefully they will be there.

Offline GigaWatt

  • The Smiley Guy
  • Support Specialist
  • SMF Hero
  • *
  • Posts: 2,030
  • Gender: Male
    • Macedonian electronics forum
Delete everything, import old DB, import all files from backup (all of them), run repair_settings.php?, correct URLs, paths, etc., load forum URL in browser, check if the forum is loading, if the attachments show up in posts and see if you can download them ;).

You can worry about the details later, just make sure the forum is up and running ;).

PS: When uploading the files, if you're doing it via FTP, make sure you have the FTP client set up in binary mode.
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

Offline GunDude

  • Semi-Newbie
  • *
  • Posts: 40
Thanks everyone for your help... It's up and working with attachments and all after re-uploading the backup.