Advertisement:

Author Topic: forum is just blank now  (Read 290 times)

Offline yh555

  • Semi-Newbie
  • *
  • Posts: 20
forum is just blank now
« on: August 18, 2019, 09:09:45 PM »
i dont know what has happened. when go to the url, its just a blank screen. it was working yesterday

Online SpacePhoenix

  • Jr. Member
  • **
  • Posts: 100
Re: forum is just blank now
« Reply #1 on: August 19, 2019, 06:51:49 AM »
Anything in the PHP error logs?

Offline d3vcho();

  • Sempiterno
  • Lead Localizer
  • SMF Hero
  • *
  • Posts: 3,940
  • Gender: Male
    • frandominguez03 on GitHub
Re: forum is just blank now
« Reply #2 on: August 19, 2019, 07:02:47 AM »
What version of SMF are you using? What version of PHP is your install running?

"Greeting Death as an old friend, they departed this life as equals."

Offline yh555

  • Semi-Newbie
  • *
  • Posts: 20
Re: forum is just blank now
« Reply #3 on: August 19, 2019, 10:09:41 AM »
2019/08/19 14:07:57 [error] 4629#4629: *48728947 FastCGI sent in stderr: "PHP message: PHP Notice:  Undefined variable: boarddir in /www/index.php on line 47PHP message: PHP Notice:  Undefined variable: sourcedir in /www/index.php on line 51PHP message: PHP Warning:  require_once(/QueryString.php): failed to open stream: No such file or directory in /www/index.php on line 51PHP message: PHP Fatal error:  require_once(): Failed opening required '/QueryString.php' (include_path='.:/usr/share/php') in /www/index.php on line 51" while reading response header from upstream, client: unix:, server:

Offline yh555

  • Semi-Newbie
  • *
  • Posts: 20
Re: forum is just blank now
« Reply #4 on: August 19, 2019, 10:11:46 AM »
2.0.15 and php 7.3

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,431
Re: forum is just blank now
« Reply #5 on: August 19, 2019, 10:16:13 AM »
your Settings.php file is blanked out, it is a known bug. copy it back from a backup or see if your Settings_bak.php file has content and copy/paste/rename it to Settings.php.

also SMF 2.0.15 does not support php 7.3,  you need to downgrade to 7.1.

Offline yh555

  • Semi-Newbie
  • *
  • Posts: 20
Re: forum is just blank now
« Reply #6 on: August 19, 2019, 10:23:46 AM »
i dont have a backup

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,431
Re: forum is just blank now
« Reply #7 on: August 19, 2019, 10:26:27 AM »
do you have content in your Settings_bak.php file? if not ask your host if they can restore those files only.

Offline yh555

  • Semi-Newbie
  • *
  • Posts: 20
Re: forum is just blank now
« Reply #8 on: August 19, 2019, 10:31:07 AM »
no and i dont think they will be able to restore it

Offline yh555

  • Semi-Newbie
  • *
  • Posts: 20
Re: forum is just blank now
« Reply #9 on: August 19, 2019, 10:37:49 AM »
s ok, i did it manually