Advertisement:

Author Topic: Can't change thread alert settings in 2.1rc2  (Read 2921 times)

Offline m4z

  • Localization Team Apprentice
  • Jr. Member
  • **
  • Posts: 346
Re: Can't change thread alert settings in 2.1rc2
« Reply #40 on: September 22, 2019, 08:40:50 AM »
You should have either received an array w/4 values or false.  You received a '1'...

Ok, I assumed as much but began doubting my (limited) understanding of PHP/SMF sources. I'll add more monkeypatched debug output.

Whatever is causing this, it behaves differently when directly print_r'ing to the page, I'm seeing array data there (but having other problems, like I can't pre- or append context messages before the printed variables, for whatever reason).

Interestingly, once I added (file writing) debug code to the previously working BoardNotify function to look for any differences, that function exhibited the bug, too.

Got other things to do, this is leading me nowhere.
"Faith is what you have in things that don't exist."
--Homer Simpson

Offline m4z

  • Localization Team Apprentice
  • Jr. Member
  • **
  • Posts: 346
Re: Can't change thread alert settings in 2.1rc2
« Reply #41 on: October 27, 2019, 07:21:03 AM »
Sorry for missing this... I updated my forums at the end of September already, and can confirm the fix by albertlast works wonderfully. Marking as solved.

As for the debugging, I've got FirePhp[sic] to work, that works much better and outputs what it's supposed to be outputting (although it's kind of limited, and hindered by the alert checking script spamming stuff every few seconds).
"Faith is what you have in things that don't exist."
--Homer Simpson