• Welcome to Simple Machines Community Forum. Please login or sign up.

Internal Server Error

Started by dominioboys, September 07, 2019, 12:23:26 PM

Previous topic - Next topic

dominioboys

my forum show this:
Internal Server Error


how to fix? error log?

d3vcho

What version of SMF are you using? What version of PHP are you using? Are there any errors in the server's error log?
"Greeting Death as an old friend, they departed this life as equals"

dominioboys

smf 2.0.15
php 7.2

error log not so where it is

Sir Osis of Liver

2.0.15 does not support php 7.2 (7.1 max), but that shouldn't be causing 500 error unless you've installed a mod that breaks in 7.2.  Server log should be in forum root (not always) look for file errorlog or something similar.  What was last thing you did before forum crashed?

"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

dominioboys

nothing, before it worked then I had grub problem and it didn't work anymore

so the version I have cannot work with 7.2?

shawnb61

Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

dominioboys

ok but if i want read post in forum show this:

Call to undefined function mentions_post_scripts()


Arantor

Firstly, that's not an official patch provided by the team; secondly it doesn't fix any mods that have 7.2 compatibility problems. Every single bbcode mod will still cause problems. As will a number of other mods.

Your error message is because you have a partial copy of the Mentions mod installed and not all of its files present.
No good deed goes unpunished
All helpful urges should be circumvented

dominioboys


and what is missing in the mod to be used

Arantor

Who knows? I have no idea what state your installation is in, especially when you've previously told us you have no mods installed but had an error that could only come from a mod.

Best thing to do, go to the page that you download the Mentions mod from, and use the parser on the right hand side of the page to see what changes it makes to your setup, and verify each of those is followed.
No good deed goes unpunished
All helpful urges should be circumvented

dominioboys

is there a way to remove all the mods?


dominioboys


dominioboys

show this in post:
syntax error, unexpected ','

d3vcho

"Greeting Death as an old friend, they departed this life as equals"

dominioboys

when I try to open any post in the forum

Arantor

Does it say anything else? Like a line number maybe?
No good deed goes unpunished
All helpful urges should be circumvented

dominioboys


Arantor

Then your PHP installation is broken.
No good deed goes unpunished
All helpful urges should be circumvented

dominioboys

when i try to login show
Your session timed out while posting. Please go back and try again.

Sir Osis of Liver

"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Kindred

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

dominioboys

The errors logged were as follows.

[Mon Sep 09 06:34:36.821343 2019] [ssl:error] [pid 29893:tid 23352343357184] (70007)The timeout specified has expired: [client 79.44.199.37:61961] AH01985: error reading response from OCSP server
[Mon Sep 09 08:01:09.357050 2019] [ssl:error] [pid 29951:tid 23352244639488] (70007)The timeout specified has expired: [client 18.236.194.108:33648] AH01985: error reading response from OCSP server
[Mon Sep 09 11:06:23.120574 2019] [ssl:error] [pid 29894:tid 23352353863424] (70007)The timeout specified has expired: [client 185.234.218.52:44756] AH01985: error reading response from OCSP server
[Mon Sep 09 12:08:08.683924 2019] [ssl:error] [pid 29951:tid 23352265651968] (70007)The timeout specified has expired: [client 208.100.26.236:45532] AH01985: error reading response from OCSP server

Arantor

OK so that's a server problem. If you configured HTTPS with certificate stapling on your server, it looks like it was misconfigured or otherwise broken. If you didn't configure that, get your host to fix it.
No good deed goes unpunished
All helpful urges should be circumvented

dominioboys

ok but for the problem that I can't get any post?

Arantor

Quote from: dominioboys on September 09, 2019, 01:58:18 PM
ok but for the problem that I can't get any post?

As I said, your PHP is clearly broken if it's only giving you half an error message, or you didn't give me the full message. Without that it's literally impossible to know where to start looking.
No good deed goes unpunished
All helpful urges should be circumvented

dominioboys

Is it better to reinstall SMF from scratch? I have php 7.0

Arantor

Well, you claimed previously to have no mods which would imply you have not in any way modified SMF - in which case a reinstall won't help you.
No good deed goes unpunished
All helpful urges should be circumvented

dominioboys

re-install the forum from scratch ... because I noticed that I have version 2.0.11 files together with those of version 2.0.15

Arantor

Except that would be normal, the file versions only get bumped when they are changed.
No good deed goes unpunished
All helpful urges should be circumvented

Advertisement: