Advertisement:

Author Topic: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)  (Read 174328 times)

Offline panazen

  • Newbie
  • *
  • Posts: 6
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #140 on: February 16, 2006, 06:22:53 AM »
if anyone could help me, it seems when ever i try anything with this theme, it takes the theme off, and the default theme apears again.  :(

bloc

  • Guest
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #141 on: February 16, 2006, 10:46:10 AM »
Sunseeker, the recent topics thinsg are really nothing to be done with in the theme..parent boards are not added becuase then the string can get very long. And again, Amber theme can't do anything about ti, it just receives the info from source files and displays them in its own way. tahts what themes do. ;)

Quick-edit on messageindex then? is that what you mean?

panazen, you are probably using the wrong version fo Amber on your forum, it will cause that kind of error usually.

Offline sunseeker

  • Semi-Newbie
  • *
  • Posts: 63
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #142 on: February 16, 2006, 03:04:13 PM »
bloc, thanks for the replys.

B/C: i gotcha buddy - i understand its not a theme thing to add the parent board in there. i guess i was just asking how to do it. maybe if you know the variable name for the parent then i could go add it myself. im still learning. mayb enot the palce to ask you questions like that.

E - i dont know what you call it. its the little side icon/button you click on to teh right of each message posted. it open the post inline and allows you to do the edit. i believe its called AJAX. also, the quick edit on the message index doesnt work for me either. it tries to but give me an error message. maybe their related somehow in the problem. again the save and spell check doesnt work. the cancel works though. and as i justs mentioned the thread title edit doesnt work either. it give me this error mesage:

An Error Has Occurred!
Session verification failed. Please try logging out and back in again, and then try again.

which i tried many different ways already and cant get it to work. the box comes up for me to edit the text, but when i go to hit enter it gives me that error message.

UPDATE: regarding the error for the title edit when you hit enter, as you would expect to do, it gives that error. but when you click elsewhere after making changes then it doesnt it and the change is made.

but i still cant quick-edit (AJAX) the message.

F - do you know how to change the code so that the increase and descrease in text size is done via the <alt> -mousescroll button?

Offline sunseeker

  • Semi-Newbie
  • *
  • Posts: 63
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #143 on: February 16, 2006, 03:16:10 PM »
bloc,

i found that the tabs dont change colors when clicking on the 'Help' or 'My Messages' in the amber theme. could it be becuase i added a button per your instructions posted here and maybe something needs to be changed elsewhere too?

thanks

Offline panazen

  • Newbie
  • *
  • Posts: 6
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #144 on: February 17, 2006, 03:14:06 PM »
ok, an other question  :D, is there a way to change it, so announcements comes first, so, before search?

Offline sunseeker

  • Semi-Newbie
  • *
  • Posts: 63
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #145 on: February 20, 2006, 11:53:45 AM »
bloc,

along with the questions still above...

if i want to change the font style on the theme is there one main place i do it or do i have to search for a certain 'xxxx' throught the php files to replace many font styles?

im wondering if the changes needed are only in the .css file?

thanks

Offline sunseeker

  • Semi-Newbie
  • *
  • Posts: 63
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #146 on: February 20, 2006, 01:54:27 PM »
bloc,

also i just verified the error ive been talking about.

this is the one regarding the in-line (AJAX) editing feature using the edit icon to the left of the post near the bottom.

i installed smf into a brand new directory.
 
i used the 1.1 rc2 and overwrote the files, etc, and ended up with a 1.1rc2 smf.
tested the in-line editing with the default theme version, works fine.

i then took a freash copy of your amber theme and installed it using the theme manager.

i then tried to do the editing again. it failed. clicking the icon gives me the in-line editing box, but after im done editing i click SAVE and it doesnt work. i cant click SPELL CHECK either. CANCEL works though.

also, i went back and change the them to the deafult supplied with the installation again and it works.

any ideas whats going on?

here is there error tha tmight be associated with it:

---------------
line: 88
char: 2
error: document.forms.quickModForm.subject' is null or not an object
code:0
---------------
« Last Edit: February 20, 2006, 03:14:29 PM by sunseeker »

Offline sunseeker

  • Semi-Newbie
  • *
  • Posts: 63
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #147 on: February 25, 2006, 01:10:02 AM »
hi bloc,

just checking in to see if you had any answers to the problems on this yet?

i posted the question on your site as well.

thanks!

bloc

  • Guest
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #148 on: February 25, 2006, 03:59:45 AM »
I have gone through the Display.template where the inline editing takes place , and it was indeed a few mistakes in the javascript. It was showing in IE more so than Firefox, but should work fine in both now.

You can either download the archive again and replace Display.template - or use the attached one.

About your other questions..I may have been a bit lost..are all still current? :)

Offline sunseeker

  • Semi-Newbie
  • *
  • Posts: 63
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #149 on: February 28, 2006, 12:54:08 AM »
oh yes they are all still very current or of interest. im hot on this theme.

love it.

all those posts are valid if you can read them again.

did you ever understand what i meant by the text on some themes being able to resize, etc? try it on this site. and try it on yours. yours is static. i want to change it but not sure what causes it to happen or not happen. im guessing its the type of font or how the font is defined.

bloc

  • Guest
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #150 on: February 28, 2006, 06:17:06 AM »
Most likely all the font-sizes are in % or in ems on this site. Amber use either "small/x-small" or for example 9pt. So if you set all to % instead, you should be able to resize better. In my newest theme I am using only percent, just for this reason. :)

I am not at home now, so I don't recall exactly what size is used in the Amber stylesheet.

Offline belindaj

  • Newbie
  • *
  • Posts: 7
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #151 on: March 02, 2006, 01:13:50 AM »
Any chance of a matching MKPortal Amber theme to go with this?

I think this is going to be absolutely perfect for our scouting website -  I thought I'd do a little begging.....

AWESOME work.
« Last Edit: March 02, 2006, 01:35:53 AM by belindaj »

bloc

  • Guest
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #152 on: March 02, 2006, 06:13:21 AM »
Well, I am not converting any SMF themes to MKPortal format any longer..since the introduction of the "SMF theme" option in MKP ( where it takes the colors from SMF). But I can see it the advantage having something integrated on the sides..more like the TinyPortal version of Amber. There is one drawback of that..whereas TP just use the SMF template and add its own column(s), MKP have separate columns for itself "outside" SMF..so it will not be so easy to do the same there.

Offline belindaj

  • Newbie
  • *
  • Posts: 7
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #153 on: March 02, 2006, 08:45:58 AM »
Hmm back to MKP - I was not aware of that MKP option to take the colors from an SMF theme - and that would probably work. Thanks for the heads up!

[edit]
OK - I did find the option to use the Forum colors - and that will work satisfactorily. I have one question that I can't figure out though - I've gone through every line of the these CSS for Amber and I can't figure out where the top of the forum color is specified (dark grey/blueish color behind the rounded navigation bar) When you put the forum inside the MKPortal - that dark color doesn't seem right - I'd prefer to make it match the medium/light grey-blue.

« Last Edit: March 02, 2006, 09:24:47 AM by belindaj »

bloc

  • Guest
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #154 on: March 02, 2006, 11:34:27 AM »
Its actually a graphic..try to hold over there and select "view image" or "view background image". Then you get the filename and can change it.

Offline belindaj

  • Newbie
  • *
  • Posts: 7
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #155 on: March 02, 2006, 01:06:45 PM »
I think there's some javascript messing with the location of the file - because if I right-click on it (in IE) I don't get an image name - I just get index.php.

I'll keep messing with it - I like how it's coming together - with a few exceptions that have less to do with your SMF theme than they do with the MKPortal integration with the SMF forum :(

I think I'm going to check out your Tiny Portal and see if it will be more suitable for this particular project than MKP.

Offline belindaj

  • Newbie
  • *
  • Posts: 7
Re: [Theme] Amber (SMF v1.1RC1)
« Reply #156 on: March 02, 2006, 03:46:52 PM »
Quote from: eldacar
There's a sliced psd in the first post. You can make any header images you like! :)

OK - is this an invisible file - or just visible to everyone but me LOL? Because I cannot find it anywhere in this thread - much less the first post :) HELP! Please can you make the psd file available?

bloc

  • Guest
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #157 on: March 02, 2006, 06:38:42 PM »
hm..it seems I have forgotten to add the link... :P :) I will update first post too, but here is the link:

http://www.tinyportal.net/smf/index.php?action=tpmod;dl=item48

Offline mfowler

  • Newbie
  • *
  • Posts: 3
  • Gender: Male
    • Fiendsonline
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #158 on: March 03, 2006, 01:22:05 PM »
Bloc,

This is a great theme..

I'm having a couple minor problems.

First, my tabs for 'help' and 'My Messages' also do not change color when I click on them.

Second, When I click on the 'My Message' tab, I get a runtime error on Line 168; Syntax error. If I click no to debug The page comes up fine. I've tried to find what is causing this error, but have been unable to find it so far. If you need more information, I can send you a test login the the site and URL.

Thanks

Offline sunseeker

  • Semi-Newbie
  • *
  • Posts: 63
Re: [Theme] Amber (SMF v1.1RC1 - v1.1RC2)
« Reply #159 on: March 04, 2006, 06:28:22 PM »
I have gone through the Display.template where the inline editing takes place , and it was indeed a few mistakes in the javascript. It was showing in IE more so than Firefox, but should work fine in both now.

You can either download the archive again and replace Display.template - or use the attached one.

About your other questions..I may have been a bit lost..are all still current? :)


bloc, thanks for doing that. i tested it in a fresh environment. works like its supposed to now. yahoo!

my problem is now that my own display template for that theme was heavily modified for advertising and other things. can you pinpoint the errors and their corrections?

also, as i mentioned before not all of the tabs at the top get highlighted when selected. any idea how to correct this? again, showing the errors and the changes would help me, maybe others, the most if we modified the themes to add features.

thanks bloc!