Advertisement:

Author Topic: Bold text not working  (Read 1534 times)

Offline Zakees_

  • Semi-Newbie
  • *
  • Posts: 11
Bold text not working
« on: October 21, 2019, 06:11:35 AM »
I'm using Horizon 2.0 theme. When I put a text in bold, it doesn't show on PC (on mobile works fine)
It's possible to make it works on both?

Offline d3vcho();

  • Sempiterno
  • Lead Localizer
  • SMF Hero
  • *
  • Posts: 4,319
  • Gender: Male
    • frandominguez03 on GitHub
Re: Bold text not working
« Reply #1 on: October 21, 2019, 06:13:15 AM »
Does that happen with default theme as well? Also have you tried different web browsers?

"Greeting Death as an old friend, they departed this life as equals."

Offline Zakees_

  • Semi-Newbie
  • *
  • Posts: 11
Re: Bold text not working
« Reply #2 on: October 21, 2019, 06:14:42 AM »
I tried but still not working.
Just happen with this theme, but I like it and don't want to change it.

Offline d3vcho();

  • Sempiterno
  • Lead Localizer
  • SMF Hero
  • *
  • Posts: 4,319
  • Gender: Male
    • frandominguez03 on GitHub
Re: Bold text not working
« Reply #3 on: October 21, 2019, 06:17:58 AM »
Maybe you should ask for support to the theme's autor. Where did you get it from?

"Greeting Death as an old friend, they departed this life as equals."

Offline Zakees_

  • Semi-Newbie
  • *
  • Posts: 11
Re: Bold text not working
« Reply #4 on: October 21, 2019, 06:21:16 AM »
Theme's author stop working for smf, and dissapears totally.
I don't know what to do :S

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 52,461
Re: Bold text not working
« Reply #5 on: October 21, 2019, 07:32:34 AM »
can you provide a link to where the issue is happening?

Offline Dzonny

  • Localizer
  • SMF Super Hero
  • *
  • Posts: 12,151
  • Gender: Male
  • No sleep...
    • dzontra.nikola on Facebook
    • Dzonny on GitHub
    • dzontranikola on LinkedIn
    • @opusteniforum on Twitter
    • Samo opusteno
Re: Bold text not working
« Reply #6 on: October 21, 2019, 07:50:05 AM »
Yeah, the link would be useful. It may be that the problem is with css only.

Offline Zakees_

  • Semi-Newbie
  • *
  • Posts: 11
Re: Bold text not working
« Reply #7 on: October 21, 2019, 07:56:15 AM »

Offline d3vcho();

  • Sempiterno
  • Lead Localizer
  • SMF Hero
  • *
  • Posts: 4,319
  • Gender: Male
    • frandominguez03 on GitHub
Re: Bold text not working
« Reply #8 on: October 21, 2019, 07:57:27 AM »
Only registered users have access to the forum.

"Greeting Death as an old friend, they departed this life as equals."

Offline Zakees_

  • Semi-Newbie
  • *
  • Posts: 11
Re: Bold text not working
« Reply #9 on: October 21, 2019, 08:46:27 AM »
Use

username: demo
pass: demo

My bad :P

Offline d3vcho();

  • Sempiterno
  • Lead Localizer
  • SMF Hero
  • *
  • Posts: 4,319
  • Gender: Male
    • frandominguez03 on GitHub
Re: Bold text not working
« Reply #10 on: October 21, 2019, 08:50:19 AM »
There seems to be a CSS error. Navigate to the file index.css of the current theme and look for the following:

Quote
b, strong {
          font-weight: 500;
}

And replace "font-weight: 500;" for " font-weight: bold;".

"Greeting Death as an old friend, they departed this life as equals."

Offline Zakees_

  • Semi-Newbie
  • *
  • Posts: 11
Re: Bold text not working
« Reply #11 on: October 21, 2019, 08:57:30 AM »
It's already like this.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 52,461
Re: Bold text not working
« Reply #12 on: October 21, 2019, 09:00:27 AM »
https://dubaicityroleplay.com/foro/Themes/horizon-smf20/css/index.css
Code: [Select]
/* Define strong as bold, and em as italics.
-------------------------------------------- */
b,
strong {
font-weight: 500;
}

find that and replace with

Code: [Select]
/* Define strong as bold, and em as italics.
-------------------------------------------- */
b.
strong {
font-weight: 500;
}

after the b should be a period not a comma.

Offline Zakees_

  • Semi-Newbie
  • *
  • Posts: 11
Re: Bold text not working
« Reply #13 on: October 21, 2019, 09:23:19 AM »
Okay, thanks a lot. I made a mistake and delete complete theme but I can solve It. Thanks!!

Offline Zakees_

  • Semi-Newbie
  • *
  • Posts: 11
Re: Bold text not working
« Reply #14 on: October 21, 2019, 09:25:52 AM »
It's possible to restore a deleted theme? :s

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 52,461
Re: Bold text not working
« Reply #15 on: October 21, 2019, 09:43:30 AM »
in what way did you delete it?

Offline Antechinus

  • SMF Friend
  • SMF Master
  • *
  • Posts: 25,297
  • Master of BBC Abuse
Re: Bold text not working
« Reply #16 on: October 21, 2019, 06:33:47 PM »
https://dubaicityroleplay.com/foro/Themes/horizon-smf20/css/index.css
Code: [Select]
/* Define strong as bold, and em as italics.
-------------------------------------------- */
b,
strong {
font-weight: 500;
}

find that and replace with

Code: [Select]
/* Define strong as bold, and em as italics.
-------------------------------------------- */
b.
strong {
font-weight: 500;
}

after the b should be a period not a comma.

Why do you say that? A comma is perfectly normal there. It's saying HTML b tags and strong tags get that font-weight. The only reason you would use a period is if you were calling a class, and in that case it would go directly before the class name.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 52,461
Re: Bold text not working
« Reply #17 on: October 21, 2019, 07:43:39 PM »
i changed it in the browser inspect tool and it fixed the issue.

Offline Antechinus

  • SMF Friend
  • SMF Master
  • *
  • Posts: 25,297
  • Master of BBC Abuse
Re: Bold text not working
« Reply #18 on: October 21, 2019, 08:45:10 PM »
In that case I suspect something else is borked too.