Advertisement:

Author Topic: database error  (Read 190 times)

Offline pepf

  • Semi-Newbie
  • *
  • Posts: 49
database error
« on: November 07, 2019, 09:38:17 PM »
Had a new forum installed with a backup dB and attachments installed, and it was running without problem for the last three or so days, or so it seemed/
Today I received three warning emails (This is a notice email to let you know that SMF could not connect to the database, contact your host if this continues.)
Upon checking I found some 240 entries for TODAY alone, all with entries similar to this, below:

http://XXXXXX.com/forum2/index.php?action=dlattach;topic=4940.0;attach=43845;image
Apply Filter: Only show the errors with the same message
8192: Function create_function() is deprecated
Apply Filter: Only show the errors from this file
File: /home/eaxxxx1/public_html/forum2/Sources/Display.php
Line: 1365

(Yesterday, similar error messages were given, as I just found.)
All mention the 8192 and images. They are related to registered users. What is causing this, please?

Offline vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 21,673
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: database error
« Reply #1 on: November 07, 2019, 09:40:11 PM »
Caused by running the forum on PHP 7.2 or higher.
Solution downgrade to PHP 7.1 for now.
We are still working on patch for php 7.2+ support
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline pepf

  • Semi-Newbie
  • *
  • Posts: 49
Re: database error
« Reply #2 on: November 07, 2019, 11:04:14 PM »
Thanks, I changed the server setting to 7.1, but now I got a 500 error. Do I have to do something on SMF to get it working, or is it just taking some time to get effective?

Offline pepf

  • Semi-Newbie
  • *
  • Posts: 49
Re: database error
« Reply #3 on: November 07, 2019, 11:37:44 PM »
Got it sorted out. Thanks again.