• Welcome to Simple Machines Community Forum. Please login or sign up.
September 20, 2021, 04:39:36 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


SMF 2.0.16+ cookie changes

Started by Sesquipedalian, December 28, 2019, 03:31:53 AM

Previous topic - Next topic

Sesquipedalian

Hello all!

With SMF 2.0.16 we have introduced an important security change for our cookies. This change will also be in the next release of SMF 2.1.

We now generate an HMAC for parts of the cookie using an authentication sercet only known by the server. This prevents forgeries of the cookie by any would-be attacker.

This change breaks backwards compatibility with cookies for 2.0.15 and below. Therefore, integrations and modifications that need to tap into SMF's cookie will need to be updated.

To support both the new and the old cookie hashes, you may use this code:


require_once($sourcedir '/Load.php');

// Use strong cookie
if (function_exists('get_auth_secret'))
	
$hashed_password hash_hmac('sha1'sha1($user_info['passwd'] . $user_info['password_salt']), get_auth_secret());
// Fallback for older versions
else
	
$hashed_password sha1($user_info['passwd'] . $user_info['password_salt']);


The get_auth_secret() function, which is part of Load.php, was introduced in 2.0.16 to ease the generation and retrieval of the authentication secret. If that function exists, your code will know that it should use the new password hash in the cookie. If it does not, your code should use the old hash.

Because we know that not all mods can be updated immediately, we've included a setting in the 2.0.16 admin control panel to allow the admin to disable the new cookie security for the sake of backwards compatibility with outdated mods. This setting is only available when a mod that uses the 'integrate_verify_user' hook is installed. This setting will be removed in future versions of SMF; it is only intended as a stop-gap measure until mod authors have time to update their code.

Thanks for reading!
I promise you nothing.


Sesqu... Sesqui... what?
Sesquipedalian, the best word in the English language.

Skhilled


RockLee

Thanks for all the work, I think so far I don't use any mod that uses those lines (I have to see if any will give problems).


Regards!
¡Regresando como cual Fenix! ~ Bomber Code © 2020
Ayudas - Aportes - Tutoriales - Y mucho mas!!!

Rob Lightbody

Thanks for this post.  It explains why my Coppermine Gallery has stopped working.

I want to temporarily use your function to disable the new cookie security, to allow me to get Coppermine updated - I can see the checkbox "Use basic cookie authentication" but its disabled ?

Keep up the good work team, and thanks for the support so far.

Shambles

Quote
... I can see the checkbox "Use basic cookie authentication" but its disabled ? ...

Indeed - the new cookie stuff seems to have disabled TapaTalk access.  How is this new authentication checkbox controlled?

SleePy

The setting is only supposed to be enabled if another integration has triggered 'integrate_verify_user'.
You can directly add it to your Settings.php though to bypass this:

$cookie_no_auth_secret = true;


You will be logged out again after changing this.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

rbradbury

Thanks for the quick reply.

I added the code to Settings.php but the 'Use basic cookie authentication' checkbox remained greyed out

GL700Wing

December 29, 2019, 06:45:54 PM #7 Last Edit: December 29, 2019, 07:11:41 PM by GL700Wing
Quote from: SleePy on December 29, 2019, 04:58:10 PM
The setting is only supposed to be enabled if another integration has triggered 'integrate_verify_user'.
You can directly add it to your Settings.php though to bypass this:

$cookie_no_auth_secret = true;


You will be logged out again after changing this.
I made this change via Administration Center » Server Settings » Cookies and Sessions in the hope of also getting my Coppermine bridge to work again but now whenever I try to login to SMF I get the error message "You were unable to login. Please check your cookie settings."

The only way I could get back into my forum was to manually edit Settings.php and remove/comment out the line $cookie_no_auth_secret = 1;.


Edit: On another forum enabling this setting did not cause any issues as far as logging into SMF was concerned but it didn't resolve the Coppermine bridging issue ...
Life doesn't have to be perfect to be wonderful ...

lurkalot

Quote from: GL700Wing on December 29, 2019, 06:45:54 PM
Quote from: SleePy on December 29, 2019, 04:58:10 PM
The setting is only supposed to be enabled if another integration has triggered 'integrate_verify_user'.
You can directly add it to your Settings.php though to bypass this:

$cookie_no_auth_secret = true;


You will be logged out again after changing this.
I made this change via Administration Center » Server Settings » Cookies and Sessions in the hope of also getting my Coppermine bridge to work again but now whenever I try to login to SMF I get the error message "You were unable to login. Please check your cookie settings."

The only way I could get back into my forum was to manually edit Settings.php and remove/comment out the line $cookie_no_auth_secret = 1;.


Edit: On another forum enabling this setting did not cause any issues as far as logging into SMF was concerned but it didn't resolve the Coppermine bridging issue ...

Regarding the Coppermine bridge.  There's two new bridge files you can download to resolve this, uploaded tonight.  One for Coppermine 1.5.x https://forum.coppermine-gallery.net/index.php/topic,80028.msg387612.html#msg387612

and one for Coppermine 1.6.x https://forum.coppermine-gallery.net/index.php/topic,77951.msg387613.html#msg387613

KittyGalore

Quote from: rbradbury on December 29, 2019, 05:25:02 PM
Thanks for the quick reply.

I added the code to Settings.php but the 'Use basic cookie authentication' checkbox remained greyed out
If you change it from disabled to enabled in the Mangeserver.php it won't be greyed out.
SMF Curve 2.0x

GL700Wing

Quote from: lurkalot on December 29, 2019, 07:18:56 PM
Regarding the Coppermine bridge.  There's two new bridge files you can download to resolve this, uploaded tonight.  One for Coppermine 1.5.x https://forum.coppermine-gallery.net/index.php/topic,80028.msg387612.html#msg387612

and one for Coppermine 1.6.x https://forum.coppermine-gallery.net/index.php/topic,77951.msg387613.html#msg387613
Perfect - worked like a charm!  Thanks!!
Life doesn't have to be perfect to be wonderful ...

RockLee

Quote from: SleePy on December 29, 2019, 04:58:10 PM
The setting is only supposed to be enabled if another integration has triggered 'integrate_verify_user'.
You can directly add it to your Settings.php though to bypass this:

$cookie_no_auth_secret = true;


You will be logged out again after changing this.

No effect, I could not log in (at least with a secondary account) I had to comment on the entire line to allow me to enter ... I would have to do tests with a new user if the same happens but only applies to old users.


Regards!
¡Regresando como cual Fenix! ~ Bomber Code © 2020
Ayudas - Aportes - Tutoriales - Y mucho mas!!!

Sesquipedalian

We'll be simplifying the logic that controls this in 2.0.18.

In the meantime, if manually adding $cookie_no_auth_secret = 1; to your Settings.php isn't enough to make this work as you want, try also adding an entry for 'integrate_verify_user' to the settings table in your database, and give it a dummy value, as shown in the attached image.
I promise you nothing.


Sesqu... Sesqui... what?
Sesquipedalian, the best word in the English language.

RockLee

In a new forum it doesn't give me problems but if I update my site, doing tests if I put in value 0 there is no problem but when I can be on my computer I make the change you suggest me! Thank you @Sesquipedalian
¡Regresando como cual Fenix! ~ Bomber Code © 2020
Ayudas - Aportes - Tutoriales - Y mucho mas!!!

aegersz

I followed your instructions and disabled the checkbox as required but the SA Chat mod still failes to run.

Any thoughts ?

All I could think about were the cookie changes and I have posted in the mod.
The configuration of my Linux VPS (SMF 2.0 with 160+ mods & some assorted manual tweaks) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum). My (House) music DJ dedication page is here

Ulibka

I'm have SMF 2.017, default theme
I;m register user with russian letters : Иван

When I attempt to login (quick login, all login and password correct), password is 1234
Login redirect to index.php?action=login2 and I'm see: incorrect password


I'm input login +password and I'm can see forum

May be you know solution ?


Ulibka

I'm try to ask https://www.simplemachines.ru/ but nobody don't know answer.

Problem is that if you have login with 2 bytes UTF-8 - you need to login twice.

Kindred

We know.

the fix has been published several times.

amd that site -- despite the name - is not an official SMF support site
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Advertisement: