Simple Machines Blogs > Developers' Blog

SMF 2.0.16+ cookie changes

<< < (2/4) > >>

SleePy:
The setting is only supposed to be enabled if another integration has triggered 'integrate_verify_user'.
You can directly add it to your Settings.php though to bypass this:

--- Code: ---$cookie_no_auth_secret = true;

--- End code ---

You will be logged out again after changing this.

rbradbury:
Thanks for the quick reply.

I added the code to Settings.php but the 'Use basic cookie authentication' checkbox remained greyed out

GL700Wing:

--- Quote from: SleePy on December 29, 2019, 04:58:10 PM ---The setting is only supposed to be enabled if another integration has triggered 'integrate_verify_user'.
You can directly add it to your Settings.php though to bypass this:

--- Code: ---$cookie_no_auth_secret = true;

--- End code ---

You will be logged out again after changing this.

--- End quote ---
I made this change via Administration Center » Server Settings » Cookies and Sessions in the hope of also getting my Coppermine bridge to work again but now whenever I try to login to SMF I get the error message "You were unable to login. Please check your cookie settings."

The only way I could get back into my forum was to manually edit Settings.php and remove/comment out the line $cookie_no_auth_secret = 1;.


Edit: On another forum enabling this setting did not cause any issues as far as logging into SMF was concerned but it didn't resolve the Coppermine bridging issue ...

lurkalot:

--- Quote from: GL700Wing on December 29, 2019, 06:45:54 PM ---
--- Quote from: SleePy on December 29, 2019, 04:58:10 PM ---The setting is only supposed to be enabled if another integration has triggered 'integrate_verify_user'.
You can directly add it to your Settings.php though to bypass this:

--- Code: ---$cookie_no_auth_secret = true;

--- End code ---

You will be logged out again after changing this.

--- End quote ---
I made this change via Administration Center » Server Settings » Cookies and Sessions in the hope of also getting my Coppermine bridge to work again but now whenever I try to login to SMF I get the error message "You were unable to login. Please check your cookie settings."

The only way I could get back into my forum was to manually edit Settings.php and remove/comment out the line $cookie_no_auth_secret = 1;.


Edit: On another forum enabling this setting did not cause any issues as far as logging into SMF was concerned but it didn't resolve the Coppermine bridging issue ...

--- End quote ---

Regarding the Coppermine bridge.  There's two new bridge files you can download to resolve this, uploaded tonight.  One for Coppermine 1.5.x https://forum.coppermine-gallery.net/index.php/topic,80028.msg387612.html#msg387612

and one for Coppermine 1.6.x https://forum.coppermine-gallery.net/index.php/topic,77951.msg387613.html#msg387613

KittyGalore:

--- Quote from: rbradbury on December 29, 2019, 05:25:02 PM ---Thanks for the quick reply.

I added the code to Settings.php but the 'Use basic cookie authentication' checkbox remained greyed out

--- End quote ---
If you change it from disabled to enabled in the Mangeserver.php it won't be greyed out.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version