Advertisement:

Author Topic: "8192:preg_replace(): The /e modifier is deprecated  (Read 678 times)

Offline PrincessOnly

  • Newbie
  • *
  • Posts: 4
"8192:preg_replace(): The /e modifier is deprecated
« on: January 03, 2020, 05:44:55 AM »
Now what?

Suddenly this started with nothing done on my end.  Still on PHP 5.6.  Can't access my SMF chatter.princessonly.com/

"8192:preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead
File: /home/princess/public_html/chatter/Sources/Load.php(198) : runtime-created function
Line: 3"

Offline d3vcho();

  • Sempiterno
  • Lead Localizer
  • SMF Hero
  • *
  • Posts: 4,102
  • Gender: Male
    • frandominguez03 on GitHub
Re: "8192:preg_replace(): The /e modifier is deprecated
« Reply #1 on: January 03, 2020, 05:49:44 AM »
What version of SMF are you using? What version of PHP is your server running?

"Greeting Death as an old friend, they departed this life as equals."

Offline PrincessOnly

  • Newbie
  • *
  • Posts: 4
Re: "8192:preg_replace(): The /e modifier is deprecated
« Reply #2 on: January 03, 2020, 08:08:29 AM »
"Still on PHP 5.6"  SMF 1.1.21

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,745
  • Gender: Male
    • Kindred-999 on GitHub
Re: "8192:preg_replace(): The /e modifier is deprecated
« Reply #3 on: January 03, 2020, 08:27:11 AM »
with that error, I'm not sure that you are actually on php 5.6

However -- your solution is simple.
Upgrade to 2.0.17
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline PrincessOnly

  • Newbie
  • *
  • Posts: 4
Re: "8192:preg_replace(): The /e modifier is deprecated
« Reply #4 on: January 03, 2020, 04:33:57 PM »
My host company uses cpanel.  Is there a simple way on cpanel to upgrade?

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,944

Offline PrincessOnly

  • Newbie
  • *
  • Posts: 4
Re: "8192:preg_replace(): The /e modifier is deprecated
« Reply #6 on: January 06, 2020, 07:43:03 AM »
Thanks to all.  Problem solved with a fairly easy upgrade.