Advertisement:

Author Topic: [2.0.16] Authorization from the second time.  (Read 2614 times)

Offline shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 2,099
    • sbulen on GitHub
Re: Authorization from the second time.
« Reply #20 on: February 19, 2020, 10:13:54 PM »
I believe the fix outlined here will resolve this problem:
https://www.simplemachines.org/community/index.php?topic=571082.msg4042818#msg4042818
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline live627

  • Developer
  • SMF Hero
  • *
  • Posts: 5,729
  • Gender: Male
    • live627 on Facebook
    • live627 on GitHub
    • live627 on LinkedIn
    • @live627 on Twitter
    • livemods
Re: Authorization from the second time.
« Reply #21 on: February 21, 2020, 12:25:45 AM »
I fix one bug and create another. Damn. Savage.

Offline Ulibka

  • Semi-Newbie
  • *
  • Posts: 44
  • Gender: Male
Re: Authorization from the second time.
« Reply #22 on: June 05, 2020, 04:26:15 AM »
I believe the fix outlined here will resolve this problem:
https://www.simplemachines.org/community/index.php?topic=571082.msg4042818#msg4042818

I'm have same problem.
User with russain letter need to print password twice.
If user and password have only english letters - all work ok.

I'm have SMF 2.017, all tables in UTF-8, language = Russian
I'm do initial installation using SMF 2.017 install and old database.
After installation I'm convert all database tables to UTF8.
and run upgrade.php

Theme is Japanes Red from this site.

I'm patch script.js as described above.

Test site:
https://woodtools.site/index.php

User: test2020
Password: 1234
login - OK

User name in russian letters:
User: Рамза
Password: 12345

In this case user must fill login and password twice.
You can check it byself.
Login in upper left corner

Separet login button have name : Вход

Offline shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 2,099
    • sbulen on GitHub
Re: Authorization from the second time.
« Reply #23 on: June 05, 2020, 01:02:00 PM »
I believe the fix outlined here will resolve this problem:
https://www.simplemachines.org/community/index.php?topic=571082.msg4042818#msg4042818

Ulibka - the solution to your problem was 2 posts above your post.

EDIT:  You may need to force a refresh for that page on your browser.  Usually shift-F5, or shift-refresh.  Otherwise the new .js doesn't get loaded, you are still using the old one. 
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline Ulibka

  • Semi-Newbie
  • *
  • Posts: 44
  • Gender: Male
Re: [2.0.16] Authorization from the second time.
« Reply #24 on: June 05, 2020, 03:03:44 PM »
I'm edit script.js exactly as you described :)
But nothing changes.
I make picture from chrome dev tools:


If I'm try to login :
User name in russian letters:
User: Рамза
Password: 12345

first login: invalid password,
second login: ok

I'm see login form - it's the same as default theme.

Offline shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 2,099
    • sbulen on GitHub
Re: [2.0.16] Authorization from the second time.
« Reply #25 on: June 05, 2020, 08:38:00 PM »
Did you refresh your browser as specified above?

Old version of script.js is likely cached.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline Ulibka

  • Semi-Newbie
  • *
  • Posts: 44
  • Gender: Male
Re: [2.0.16] Authorization from the second time.
« Reply #26 on: June 05, 2020, 11:27:59 PM »
Did you refresh your browser as specified above?

Old version of script.js is likely cached.

Yes, it is.
I'm publish photo from chrome dev tools - you can see that code was changed.

Offline shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 2,099
    • sbulen on GitHub
Re: [2.0.16] Authorization from the second time.
« Reply #27 on: June 06, 2020, 02:58:52 AM »
I have confirmed that the above fix works fine on a vanilla 2.0.17 install with the user ID and password you have provided.

You have something else going on...

Initial guess is that there is an issue with your UTF8 implementation somewhere. 

I would ensure that:
 - All ***columns*** are utf8_general_ci; not just tables, look at the columns
 - In your settings table, global_character_set is set to: 'UTF-8'
 - In settings.php, you see the row for: $db_character_set = 'utf8';

If all of the above is true, you have some deeper problem somewhere...  You need to try all vanilla code + the fix above in a test environment.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp