Advertisement:

Author Topic: syntax error, unexpected '<'  (Read 315 times)

Offline pepf

  • Semi-Newbie
  • *
  • Posts: 70
syntax error, unexpected '<'
« on: December 22, 2019, 09:08:40 PM »
syntax error, unexpected '<'   

This appears when user registers himself or the admin registers a new user. The registration does not succeed.
This happens on a new install of 2.0.15, old database and attachment folder, and a number of newly installed mods.

What should I do?

Thanks in advance.

Offline drewactual

  • Sr. Member
  • ****
  • Posts: 859
    • College Football Fan Site CFB51
Re: syntax error, unexpected '<'
« Reply #1 on: December 22, 2019, 09:37:51 PM »
what you should do is find the added "<" and remove it.   :)

you say fresh install and some new mods... one of those mods have something to do with registration?  may do well to list your mods to figure out which one of them did it.

Offline pepf

  • Semi-Newbie
  • *
  • Posts: 70
Re: syntax error, unexpected '<'
« Reply #2 on: December 22, 2019, 09:59:00 PM »
Thanks for the quick response. That was it!
After removing the mod blocking registration via VPN the message went away and registration was possible.

Thanks again.

Offline drewactual

  • Sr. Member
  • ****
  • Posts: 859
    • College Football Fan Site CFB51
Re: syntax error, unexpected '<'
« Reply #3 on: December 23, 2019, 03:54:35 PM »
i hesitated to post this, and the biggest reason is this is firmly on the playing field of "modification support" in its forum/board.

... there is no real cause to trash the whole mods function because of a stray character..... however, a stray character (though common) is also indication of sloppy coding and makes ya wonder what else was done sloppy...

if it were me, and it isn't but if it was- finding the extra "<" is easy enough, especially since you narrowed it down to the particular mod.  my guess is the install package is where the issue is, as it's too easy to make that mistake when building that- adding an opening when one is already there, or a closing after its already closed....

Offline pepf

  • Semi-Newbie
  • *
  • Posts: 70
Re: syntax error, unexpected '<'
« Reply #4 on: February 21, 2020, 11:13:05 PM »
Update of what happened in the meantime:

After updating to 2.0.17 I reinstalled the mod Block Proxy VPN On Registration. The problem is now not there anymore.

Thanks again.