News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

Ant's Mutant Curve

Started by Antechinus, February 26, 2020, 11:02:14 PM

Previous topic - Next topic

Ninja ZX-10RR

Quote from: Antechinus on March 10, 2021, 04:40:10 PM
Example test site, running the latest version of the theme with SMF 2.0.18, is here: http://smftest.hawkdawg.com/index.php
You're missing a max-width: 55% (or thereabouts) on div.user at the top, as the search bar overflows at certain resolutions (body ~650px width, so you don't have to play Sherlock Holmes around) during the transition from desktop to mobile view :P However, with that, it gets bad on mobile and both div.user and div.news will need 100% to stretch back again.
The "Page X of Y" buttons in #messageindex got way too big font or they're too small (whichever), but I guess you're still working on that one, it's too evident.
Holy cow I love the go up/down buttons, I may steal that bit of code for some things!
You also re-did all of the image backgrounds with linear-gradients, that's good effort by itself and very well done, I'm not the biggest fan of working with those color-changing backgrounds but you did it properly right there.
Pretty solid thingy you did there :) Inspirational as usual in some areas, thanks for sharing.
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.

♥ Jess ♥

STOP EDITING MY PROFILE

Antechinus

Just spotted this. I've been preoccupied with non-SMF things for a while (****** hitting the fan, and all that). Will take a closer look over the next week. :)
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

dan4ever

Hello

Where in the code for this theme (or SMF), can I find the problem when a mod does not work with each other?

I have a problem with "Multimedia" from NIBOGO and he says it is a css problem.
It takes a whole day to get an answer to a question because I live in Europe and you in America. I sleep when you are awake and vice versa.

This is a submenu that is not visible on the mobile and the drop-down menu is not displayed on the computer.
https://www.guldforum.se/forum/index.php?action=multimedia
Can you see this? the second menu!

I can not find info about others with the same problem.
Have been looking for this error for at least 3 weeks now.

And NIBOGO probably has other things to do ... sigh

/ Dan
/Dan Olsson, Webmaster at https://www.guldforum.se

Ninja ZX-10RR

Quote from: dan4ever on July 09, 2021, 08:49:33 AM
https://www.guldforum.se/forum/index.php?action=multimedia
Can you see this? the second menu!
No, because guests cannot access that link, so we can't even see the menu and it's extremely hard to help without being able to see the issue plus being in Swedish :D
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.

♥ Jess ♥

STOP EDITING MY PROFILE

dan4ever

This 2 pic show the submenu for "Groups" and "Multimedia".

The first one works but not the "Multimedia".
Nibogo told me that its a CSS problem on the theme and he don't fix others theme.

And on a cellphone the submenu not exist at al.
/Dan
/Dan Olsson, Webmaster at https://www.guldforum.se

Diego Andrés

I made an account in your forum to test your issue.
It's both a theme issue and a mod issue.

The theme uses only vertical menu for sections and most mods don't do it exactly like smf so it won't look good when this happens.
You can fix simply by adding the submenu class to the ul child on the multimedia nav.

Additionally would be required to rename the div and ul ids (which shouldn't have the same name as the main menu to begin with). This because it will give you warnings in your site when validating, and most importantly because you'll need to add a custom css rule to prevent this menu from being hidden because it's using the same styles from the main menu (should also not be done imo as custom themes would break it very often).

The first change I assume should be done in the main template of the mod.

Regards.

SMF Tricks - Free & Premium Responsive Themes for SMF.

Antechinus

Quote from: Ninja ZX-10RR on March 21, 2021, 08:07:14 PM
The "Page X of Y" buttons in #messageindex got way too big font or they're too small (whichever), but I guess you're still working on that one, it's too evident.
Not sure what you mean here. I've checked it on my Android phone* and it looks pretty good in either FF or Chrome. Font sizing is slightly out on Chrome, but wouldn't be hard to fix. It's certainly not "way too big". What were you testing it on?


QuoteHoly cow I love the go up/down buttons, I may steal that bit of code for some things!
They really still need a bit of tweaking to deal with landscape vs portrait on mobile. Should be easy enough with the right query. Will take a look at it.

*Yes, grumpy old bugger now haz teh smartphone. :D
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Antechinus

Quote from: dan4ever on July 13, 2021, 05:23:20 PM
This 2 pic show the submenu for "Groups" and "Multimedia".

The first one works but not the "Multimedia".
Nibogo told me that its a CSS problem on the theme and he don't fix others theme.

And on a cellphone the submenu not exist at al.
/Dan
That mod is not on the mod site, so I assume it is one of NIBOGO's paid mods. If it is a paid mod, he should provide support for it. If he's not prepared to do that, I'd need copies of the mod files to know what the problem is. And no, I'm not paying for them.
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Ninja ZX-10RR

You got 5em on .subject .antPages_select which cuts the page navigation in messageindex, I'll post a screenshot of that later if you can't see it on your end.
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.

♥ Jess ♥

STOP EDITING MY PROFILE

Antechinus

Oh I know what you mean. That's deliberate. The page index calls the same basic markup everywhere, and I restricted the visible width of the select in that location to save space and give a cleaner look. It's a bit tricky though, depending on language defined in SMF and on the font defined in the browser. I should probably change the string to just give the page number, without the "of **". The extra text seemed like a good idea at the time, but probably isn't. Opening the select shows you how many pages there are anyway.

By the way: this is not part of the theme itself anyway. It's my page index mod: Dangerous Marsupial Page Index

By default the theme just runs the standard 2.0.x page index.
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Ninja ZX-10RR

I love that mod name lmfao ;D
Interesting one, too. Might use it somewhere, since the default pagination kinda sucks.
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.

♥ Jess ♥

STOP EDITING MY PROFILE

Antechinus

Quote from: Ninja ZX-10RR on March 21, 2021, 08:07:14 PMYou're missing a max-width: 55% (or thereabouts) on div.user at the top, as the search bar overflows at certain resolutions (body ~650px width...

Finally remembered to have a look at this, and I can't see what the issue is. AFAICT it seems fine with the code it already has. Can you be more specific? Possibly post a screenshot? Which device and browser. All the usual crud. :)
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Ninja ZX-10RR

Told ya, about 650px body width it overflows as you don't have a max-width set O:)

Browser you know it's irrelevant, but it's Chrome up-to-date. Device it's some Akai 20something inches screen, would take me a lot of effort to actually check the exact model though, as I'd have to undo several cables.
Quote from: BeastMode topic=525177.msg3720020#msg3720020
It's so powerful that on this post and even in the two PMs you sent me,you still answered my question very quickly and you're apologizing for the delay. You're the #1 support I've probably ever encountered man, so much respect for that. Thank you, and get better soon.

I'll keep this in my siggy for a while just to remind me that someone appreciated what I did while others didn't.

♥ Jess ♥

STOP EDITING MY PROFILE

Antechinus

OK, Chrome bug. Just checked in Chrome and it happens. Doesn't happen at all with Firefox. Will take a look at it.
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Mike66

Have been playing with this as an alternative theme on my forum today  :)

I really like the responsive layout, but I can't get my head round something. I'm running 2.0.18 and I use the Global Headers & Footers mod for a couple of images and text, which are in html.

The theme seems to ignore or overide things like 'centre' written in html in the mod?
And also allows the images in html to overflow small screens, which doesn't happen in my other themes.
Yet all the images in posts etc ( non Global Headers & Footers mod ) are displaying responsively.

I'm sure there is a simple answer to this, but it's not coming to me  ;D 

Antechinus

It probably is simple, but I would have to take a look at the code for that mod. I'll look at it over the weekend. :)
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Mike66

Quote from: Antechinus on September 10, 2021, 02:30:20 PMIt probably is simple, but I would have to take a look at the code for that mod. I'll look at it over the weekend. :)

I think I'm (fingers crossed) finding my way round this now Ant  :)
To fix my images that were going off screen in mobile I added:

img, video, iframe
{
    max-width: 100%;
    margin: 0 auto;
}

img{
    max-width: 100%;
    height: auto; /* Prevent stretching of full-size images with height and width attributes in IE8 */
}

To fix the Global Headers & Footers Mod issue I added:

/* Forum footer */

.forum-footer {
margin-top: 20px;
text-align: center;
}

.forum-footer p {
padding: 0;
margin-bottom: 20px;
}

.forum-footer p:last-child {
margin-bottom: 0;
}

So far so good, but I'm sure I'll find a few other things to tweak  ;D  The theme is awesome thanks  8)

Cheers
Mike

Antechinus

Ok, sounds good. BTW, I just noticed this:
Quote from: Mike66 on September 10, 2021, 12:56:43 PMThe theme seems to ignore or overide things like 'centre' written in html...
You have to use the Yankglish spelling: "center". It's the standard for any W3C stuff (HTML, CSS, etc). But don't use the antiquated "center" tag. If you want something centred use one of these:
.element_class_or_tag {text-align: center;}.element_class_or_tag {margin: 0 auto;}
The first works for inline or inline-block elements. The second works for display: block; elements. :)

I still haven't got around to looking at that mod on a test site. I may be able to add something to the theme's index.css to deal with this issue, without breaking anything else.
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Mike66

Thanks Ant, I always have to check my spelling of center/centre  ;D  but it was OK this time.

Previous niggles are fixed and working fine.
But I've now realised that SMF Gallery Pro isn't playing nice. The Add Picture editor is overflowing the screen, which is strange, as the post/message editor is fine.

Cheers
Mike

Antechinus

TBH I probably should revamp the CSS in this thing. Some places I used floats and absolute positioning, where it would probably be better with grid.

I'm not sure if the way it is done now would mess with that editor. I don't have a copy of that mod (and don't plan on buying it). If the free version of the Gallery mod uses the same editor setup I could take a look at that.

If you really get stuck, you can PM me details for a test acount if you like.
Sources code: making easy front end changes difficult since 1873 :P

Mods & Themes | Revamped theme for this site | Dark theme for this site | GitHub for n00bz

Advertisement: