News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

Ant's Mutant Curve

Started by Antechinus, February 26, 2020, 11:02:14 PM

Previous topic - Next topic

rcane

Good morning,

Using the Mutant Curve (nice theme btw).

Could you provide some guidance on importing an image to replace the gradient at the header?  Just the header area; it's fine from the menu buttons downward.

rcane

Not to double dip on questions so early in the morning, but I have a menu button added (that contains a sub-menu of two items) that only works on desktops.

If you are on a mobile device it simply takes you to your profile page.

The two sub-menu items are just links to open the email page to contact two members for support--just links based on their ID#.  Works fine in desktop sized environments.

I tried the "moderate" menu button and that works fine on the phone.  It's got the proper pop-up. 

I'll try over at 2.0 topics as this might not be theme related.


Kindred

You need to be slightly more specific...
1- the gradient in the header.....    well, there are THREE levels of gradient -- see attached
You cannot view this attachment.

2- How did you create the sub-menus?
 edit subs.php
Below is a demo of how to add properly

'help' => array(
'title' => $txt['help'],
'href' => $scripturl . '?action=help',
'show' => true,
'sub_buttons' => array(
'help2' => array(
'title' => $txt['help2'],
'href' => $scripturl . '?action=help2',
'show' => true,
),
'help3' => array(
'title' => $txt['help3'],
'href' => $scripturl . '?action=help3',
'show' => true,
),
),
),
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

rcane

#183
This is what I have. 
I can't tell if it's an iOS issue or not.  If I tap "get help" on my phone it just refreshes the main board display.  But, if I long-press (which brings up the iOS popup of "open, open in background, etc") and cancel that the sub menu is waiting underneath. 

I had a friend test it on Android.  Same thing.   

That happens for all the sub-menus in fact--one's that I haven't touched (like Profile and Members).  Unless you long-press and clear the OS pop-up options you won't see a menu has sub-items.





'GET HELP' => array(
   'title' => $txt['GET HELP'],
        'show' => true,
         'sub_buttons' => array(
'General Questions' => array (
'title' => $txt['General Questions'],
         'href' => https://mydomain.com/index.php?action=emailuser;sa=email;uid=2367';,
         'show' => true,
         ),
         
'Forum Support' => array(
         'title' => $txt['Forum Support'],
         'href' => 'https://mydomain.com/index.php?action=emailuser;sa=email;uid=1';,
         'show' => true,
         'is_last' => true,
      ),
   ),
),

Kindred

you can not have spaces in variables!!

'Forum Support' => array(
         'title' => $txt['Forum Support'],


don't use caps - don't use spaces
in both cases, use this:   forum_support
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

rcane

I made the corrections, but the behavior hasn't changed.  The sub-menus won't appear until after a long-press is made and cleared.

Kindred

Did you fix all of the cases that were broken?
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

shadav

Quote from: rcane on December 10, 2021, 10:36:56 AMThis is what I have. 
I can't tell if it's an iOS issue or not.  If I tap "get help" on my phone it just refreshes the main board display.  But, if I long-press (which brings up the iOS popup of "open, open in background, etc") and cancel that the sub menu is waiting underneath. 

I had a friend test it on Android.  Same thing. 

That happens for all the sub-menus in fact--one's that I haven't touched (like Profile and Members).  Unless you long-press and clear the OS pop-up options you won't see a menu has sub-items.





'GET HELP' => array(
    'title' => $txt['GET HELP'],
        'show' => true,
        'sub_buttons' => array(
'General Questions' => array (
'title' => $txt['General Questions'],
            'href' => https://mydomain.com/index.php?action=emailuser;sa=email;uid=2367';,
            'show' => true,
            ),
           
'Forum Support' => array(
            'title' => $txt['Forum Support'],
            'href' => 'https://mydomain.com/index.php?action=emailuser;sa=email;uid=1';,
            'show' => true,
            'is_last' => true,
        ),
    ),
),


replace yours with this
'gethelp' => array(
    'title' => $txt['get_help'],
        'show' => true,
        'sub_buttons' => array(
'generalquestions' => array (
'title' => $txt['general_questions'],
            'href' => $scripturl . '?action=emailuser;sa=email;uid=2367',
            'show' => true,
            ),
           
'forumsupport' => array(
            'title' => $txt['forum_support'],
            'href' => '$scripturl . '?action=emailuser;sa=email;uid=1',
            'show' => true,
            'is_last' => true,
        ),
    ),
),

I feel like one of those 3 at the end ), should be moved up from the end to above the forumsupport though

then in your Themes/default/languages/Modifications.english.php and Modifications.english-utf8.php
and any other language files you have
don't forget to add the language strings (or change them now to match)
$txt['get_help'] = 'Get Help';
$txt['general_questions'] = 'General Questions';
$txt['forum_support'] = 'Forum Support';

rcane

Quote from: shadav on December 10, 2021, 04:29:58 PM
Quote from: rcane on December 10, 2021, 10:36:56 AMThis is what I have. 
I can't tell if it's an iOS issue or not.  If I tap "get help" on my phone it just refreshes the main board display.  But, if I long-press (which brings up the iOS popup of "open, open in background, etc") and cancel that the sub menu is waiting underneath. 

I had a friend test it on Android.  Same thing. 

That happens for all the sub-menus in fact--one's that I haven't touched (like Profile and Members).  Unless you long-press and clear the OS pop-up options you won't see a menu has sub-items.





'GET HELP' => array(
    'title' => $txt['GET HELP'],
        'show' => true,
        'sub_buttons' => array(
'General Questions' => array (
'title' => $txt['General Questions'],
            'href' => https://mydomain.com/index.php?action=emailuser;sa=email;uid=2367';,
            'show' => true,
            ),
           
'Forum Support' => array(
            'title' => $txt['Forum Support'],
            'href' => 'https://mydomain.com/index.php?action=emailuser;sa=email;uid=1';,
            'show' => true,
            'is_last' => true,
        ),
    ),
),


replace yours with this
'gethelp' => array(
    'title' => $txt['get_help'],
        'show' => true,
        'sub_buttons' => array(
'generalquestions' => array (
'title' => $txt['general_questions'],
            'href' => $scripturl . '?action=emailuser;sa=email;uid=2367',
            'show' => true,
            ),
           
'forumsupport' => array(
            'title' => $txt['forum_support'],
            'href' => '$scripturl . '?action=emailuser;sa=email;uid=1',
            'show' => true,
            'is_last' => true,
        ),
    ),
),

I feel like one of those 3 at the end ), should be moved up from the end to above the forumsupport though

then in your Themes/default/languages/Modifications.english.php and Modifications.english-utf8.php
and any other language files you have
don't forget to add the language strings (or change them now to match)
$txt['get_help'] = 'Get Help';
$txt['general_questions'] = 'General Questions';
$txt['forum_support'] = 'Forum Support';



I like the actions to email rather than the links.  it's cleaner.  it all failed if I didn't have the three there.  And, if one gets move up, it drops the second button out.


HOWEVER, none of that fixes why you can't tap the parent button on a mobile device and popup the child menu.  You literally have to long-press, close the iOS link options that pop up, and then you will see the buttons we just built.

It's on ALL the menus like this.  Android and iPhone.  I don't know if it's Ants or all SMF. 

Do you have an iphone you could try out a different theme on?

shadav


Kindred

Can't exactly replicate on my trst site with ant's theme....   the only thing I notce is that tge so menu is FAST, and if the main menu has its own link, there us not much time to click the submenu link before the main menu link triggers
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

rcane

Quote from: Kindred on December 10, 2021, 10:08:10 PMCan't exactly replicate on my trst site with ant's theme....   the only thing I notce is that tge so menu is FAST, and if the main menu has its own link, there us not much time to click the submenu link before the main menu link triggers

well, my menu just drops down to two sub menus.  no link.  and it happens on ALL the menu items with sub menus.

rcane

I tried changing the iOS haptic settings to increase and decrease the long-press sensitivity and nothing affects it.

Kindred

Log into my test site and see if it does the same
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

rcane

Quote from: Kindred on December 12, 2021, 04:01:05 PMLog into my test site and see if it does the same

I do not have the URL

Kindred

Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

rcane

Quote from: Kindred on December 12, 2021, 09:15:05 PMTest.turtleshellprod.com

well, i checked that site on my desktop first but there are no sub menus to test that i can see.

the main menu pops out (as does mine), but its the sub menus that don't like my phone.

rcane

The only menu that pops out properly in the mobile display is the main "hamburger".  I don't believe I explained that properly.

Kindred

@Antechinus

--there does appear to be an issue with your second level sub-menus

Go to a site running this theme with a mobile device
tap the hamburger menu
(main menu is displayed)
tap an item with a second-level sub menu    (in the case of my test site, the help menu item has 3 sub-menu items)
---- problem
the second-level submenu OPENS, for a brief instant before the main menu item link is triggered, thus loading the new page and closing the entire hamburger menu.
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

rcane

Quote from: Kindred on December 13, 2021, 02:06:06 PM@Antechinus

--there does appear to be an issue with your second level sub-menus

Go to a site running this theme with a mobile device
tap the hamburger menu
(main menu is displayed)
tap an item with a second-level sub menu    (in the case of my test site, the help menu item has 3 sub-menu items)
---- problem
the second-level submenu OPENS, for a brief instant before the main menu item link is triggered, thus loading the new page and closing the entire hamburger menu.
Thank you for forwarding the concern.  Truly appreciated.

Advertisement: