Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

Ant's Mutant Curve

Started by Antechinus, February 26, 2020, 11:02:14 PM

Previous topic - Next topic


Hello Folks!

We are running Ant's Mutant Curve theme too. We have set our SMF to German. Everything translates fine except for the the link "Unread posts since last visit." and the link "New replies to my posts." on the top (see attached screenshot).

Where can I correct this?



languages/ThemeStrings.english.php holds all the custom language strings. Just make a copy of that and rename it to ThemeStrings.german.php - then you can translate whatever you like.

Regarding those two strings: I thought the default English was too verbose, so trimmed it down a bit.


those "SEF" urls have nothing to do with the theme at all.

Uncheck that box. It is useless.

That is a hold-over from 1.0 that we never got rid of.
Back (10 years ago) Search Engines did not like the php urls with arguments...   so, that option created a "psuedo-html" url which the search engines would not skip.
Search engines now can deal with the arguments....   and that .html junk is junk...

Also, the term "search engine friendly" is a misnomer...   Search engines don't care any more. You get no benefit form having one url versus another.
HUMAN friendly is another thing... and there are a few mods that do make the URLs "pretty" for humans.

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."


Just out of curiosity: is that redundant option being dropped from 2.1 before Final?


Quote from: Antechinus on April 10, 2020, 08:46:12 AM
languages/ThemeStrings.english.php holds all the custom language strings.
Thanks Antechinus,
I commented out the original two entries and replaced them with German expressions.
Unfortunately it did not pick up on changes in a new ThemeStrings.german.php.


If you want to fall back to the default SMF German and English strings, you can just delete those two from ThemeStrings.english. They're really only there because of my personal preferences.

Do note that to pick up any changes in languages files you have to clear the forum cache (under Routine Maintenance).

ETA: Oh yeah, while I think of it. If you're using the UTF-8 version of German then you'd have to name the ThemeStrings file to match that. Basically it should use the same language name as your other languages files.


Yo Ant, I'm digging this theme. Good job bruh!


Handy boilerplate? If it is, good. That was the whole idea. :)
I'm tempted to whip up a few variations on it myself, but so far only have them on a test site.

ETA: I should do another bugfix patch soon. When I was messing around with the positioning of the "New" indicators I found another small bug. And the "New" indicators really should have the positioning set by right instead of left. Makes much more sense (it keeps them in the same position relative to the thread title, regardless of language). 


how can i make width %80 ?


/* Optional max-width on large screens. */
#wrapper, .footer {
max-width: 88em;
margin: 0 auto;

Remove the max-width.


Quote from: Antechinus on April 25, 2020, 08:54:16 PM
/* Optional max-width on large screens. */
#wrapper, .footer {
max-width: 88em;
margin: 0 auto;

i did but not work

Remove the max-width.


Did you also set the width in admin?



Hello everyone.

I am using 2.0.17.

I have installed this theme. It is wonderfull and works fine!
But there is one thing, which is curious to me.
The main menu isn't visible if the browser is wide.
When I narrow the width of my browser, then the burger button appears.
When I click onto the burger button, then the menu pops up, but it lies under the info-center.
I don't know what the reason is, but I found out, that
<div id="header"> has z-index:2,
and <div id="main_menu"> z-index:auto.

I don't know where to fix it, and how, and why it appears.

I have searched and I couldn't find "#main_menu", if that is the right place to correct it.

Could someone give me an advice please?

Thank you.


Which browser and device is this occurring with?
Do you have any mods installed?
Have you made any changes to the CSS?
Can you provide a live link to the problem?



Google 81, Firefox 75,
at my pc and my samsung galaxy s3,
I haven't installed any mods.
I don't remember having changed any css. Perhaps it could be, that i tested changing to put a link into the main menu??


I have sent you the link to my forum via PM.


Ok. The problem is that you are missing a closing tag on the markup for the log in button.

<input type="submit" value="Einloggen" class="button_submit"

It should be:

<input type="submit" value="Einloggen" class="button_submit" />


Could you please tell me in which file I have to add the missing the closing tag?

I don't find it.



elseif (!empty($context['show_login_bar']))
echo '
<script type="text/javascript" src="', $settings['default_theme_url'], '/scripts/sha1.js"></script>
<form id="guest_form" action="', $scripturl, '?action=login2" method="post" accept-charset="', $context['character_set'], '" ', empty($context['disable_login_hashing']) ? ' onsubmit="hashLoginPassword(this, \'' . $context['session_id'] . '\');"' : '', '>
<label for="user">
', $txt['username'], '
<input type="text" id="user" name="user" size="12" class="input_text" />
<label for="passwrd">
', $txt['password'], '
<input type="password" id="passwrd" name="passwrd" size="12" class="input_password" />
<input type="hidden" id="cookielength" name="cookielength" value="-1" />
<input type="submit" value="', $txt['login'], '" class="button_submit" />

The last line.