SMF Support > Server Performance and Configuration

PHP 7._? work with SMF?

(1/2) > >>

ctdkite:
Our forum has worked fine for years and then suddenly disappeared, without any changes to the SMF.  I finally figured out that the only thing that had changed was that I had updated the PHP on my server from 5.6 to 7.4.  I went back and downgraded to 7.3, 7.2, 7.1, and finally back to 5.6 and that fixed it. 

I apologize if this is answered elsewhere, but I can't find it.  Why would it not work for the latest versions of PHP?

Sir Osis of Liver:
2.0.17 (officially) supports up to php 7.2, but it will log a lot of server errors.  Will run fine in 7.1.

Kindred:
Versions before 2.0.15 will not work with 7.0
2.0.17 will work with 7.1, 7.2, 7.3

7.4 is not currently supported

ctdkite:
I worked backward through the 7._ versions and the forum was still missing.  My server provider's next choice was to go back to 5.6 and then it worked.  Strange.

Antechinus:
It sounds like you're still on 2.0.15. Have you actually updated the site to 2.0.17 yet?

Navigation

[0] Message Index

[#] Next page

Go to full version