Advertisement:

Author Topic: 1.1.21 doesn't want to be installed  (Read 529 times)

Offline BabsProductions

  • Newbie
  • *
  • Posts: 4
1.1.21 doesn't want to be installed
« on: March 24, 2020, 02:13:39 PM »
I'm trying to install SMF 1.1.21 on my website. It apparently doesn't want to be installed. I can tell because I got an HTTP 500 ERROR. Is 1.1.x no longer supported?

Offline Looking

  • SMF Hero
  • ******
  • Posts: 2,427
  • SMF Customization
    • jeanborde on Facebook
    • SMF Custom Themes & Custom Coding
Re: 1.1.21 doesn't want to be installed
« Reply #1 on: March 24, 2020, 02:25:43 PM »
No it is not, you need to get SMF 2.

Offline BabsProductions

  • Newbie
  • *
  • Posts: 4
Re: 1.1.21 doesn't want to be installed
« Reply #2 on: March 24, 2020, 07:17:03 PM »
No it is not, you need to get SMF 2.

I guess you got me there. But ah, just a reminder, I'm looking for a person who can actually help. Saying "no it is not" kinda sounds like you're saying "No it isn't no longer supported," making it a double negative in the process. I'm sure you know what double negatives are, right?

Offline shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 1,926
    • sbulen on GitHub
Re: 1.1.21 doesn't want to be installed
« Reply #3 on: March 24, 2020, 10:04:33 PM »
When you see an HTTP500, that usually means something unexpected happened under the covers, and apache kinda felt the carpet pulled out from underneath it... 

The underlying issue is normally in your apache log.  To understand what's going on, look there.

If you are installing a new forum, 1.1 is not the way to go.  I don't know what the max php (or mysql) version supported by 1.1, but since most hosts have been pushing 7.x, and smf1.1 predates 7.x by years, first guess is that your environment is too 'new' to run 1.1.

I have no problems installing 1.1.21 in a php 5.x environment, the install still works fine.

What version of mysql? 
What version of php? 
What OS? 
Do you have errors in your apache log? 

And - most important - why are you trying to install a new 1.1 instance?
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline SpacePhoenix

  • Jr. Member
  • **
  • Posts: 140
Re: 1.1.21 doesn't want to be installed
« Reply #4 on: March 25, 2020, 03:52:50 AM »
Is this a migration from another forum platform or a brand new forum? If it's a brand new forum then you should go for version 2.0.17 (2.1 exists but it's not a "proper" release - it's more of a "testing " release).

What versions of PHP do you have available to use?

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,896
  • Hoarding Budweiser in NY

Offline BabsProductions

  • Newbie
  • *
  • Posts: 4
Re: 1.1.21 doesn't want to be installed
« Reply #6 on: March 26, 2020, 11:46:57 AM »
https://www.simplemachines.org/community/index.php?topic=534915.0
I can see that, but the truth is... I'm an old-fashioned person, so I shouldn't be forced to care what version I use. The people who force me to use more frequent versions of this software clearly don't understand that I like old-school stuff. But I'm just being gullible and thinking it would actually work. Bottom line, they need to fix this, but because 1.1.x is no longer being updated, I don't know what I'm gonna do. Sure, I might install 2.0.x, but only if I have no other option.

Offline shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 1,926
    • sbulen on GitHub
Re: 1.1.21 doesn't want to be installed
« Reply #7 on: March 26, 2020, 12:08:21 PM »
One step at a time...

Did you have a working forum?   That no longer works now?
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline SpacePhoenix

  • Jr. Member
  • **
  • Posts: 140
Re: 1.1.21 doesn't want to be installed
« Reply #8 on: March 26, 2020, 12:49:21 PM »
https://www.simplemachines.org/community/index.php?topic=534915.0
I can see that, but the truth is... I'm an old-fashioned person, so I shouldn't be forced to care what version I use. The people who force me to use more frequent versions of this software clearly don't understand that I like old-school stuff. But I'm just being gullible and thinking it would actually work. Bottom line, they need to fix this, but because 1.1.x is no longer being updated, I don't know what I'm gonna do. Sure, I might install 2.0.x, but only if I have no other option.

If you're on a server that's running PHP 7 then it's simply a case of either upgrade to 2.0.17 (there's info on the best way in another thread - don't have the link to hand) or your forum will be broken.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,896
  • Hoarding Budweiser in NY
Re: 1.1.21 doesn't want to be installed
« Reply #9 on: March 26, 2020, 04:46:29 PM »
I'm an old-fashioned person, so I shouldn't be forced to care what version I use.

Not really a matter of being old fashioned, or just plain old (Sir Osis just turned 70 :P), when dealing with software you need to keep up with current versions.  Old outdated software will not run correctly, if at all, on most platforms, and are unsupported so you're on your own when things go badly.  SMF 1.1 was released fourteen years ago, that's ancient in the software world.  2.0 is the current branch, it's well supported, and has many functional and securlty features (that's important) that 1.1 lacks.  If you already have a 1.1.21 forum, it's not difficult to upgrade to 2.0.17, there's plenty of help available here.  If you're just setting up a new forum, it makes no sense to attempt installing obsolete software.
« Last Edit: March 26, 2020, 04:59:43 PM by Sir Osis of Liver »

Offline DreadPirateRoberts

  • Newbie
  • *
  • Posts: 8
Re: 1.1.21 doesn't want to be installed
« Reply #10 on: March 26, 2020, 06:49:30 PM »
dud i ike to keep my site old looking too but you need new software in the long run if you want to have your forum running fast and facing un expected errors

Offline Shambles

  • SMF Hero
  • ******
  • Posts: 5,421
  • Gender: Male
    • i30 Owners Club
Re: 1.1.21 doesn't want to be installed
« Reply #11 on: March 26, 2020, 07:00:41 PM »
Quote from: DreadPirateRoberts
dud i ike to

What a strange combination of words... ::)

Offline BabsProductions

  • Newbie
  • *
  • Posts: 4
Re: 1.1.21 doesn't want to be installed
« Reply #12 on: March 26, 2020, 07:10:57 PM »
I'm an old-fashioned person, so I shouldn't be forced to care what version I use.

Not really a matter of being old fashioned, or just plain old (Sir Osis just turned 70 :P), when dealing with software you need to keep up with current versions.  Old outdated software will not run correctly, if at all, on most platforms, and are unsupported so you're on your own when things go badly.  SMF 1.1 was released fourteen years ago, that's ancient in the software world.  2.0 is the current branch, it's well supported, and has many functional and securlty features (that's important) that 1.1 lacks.  If you already have a 1.1.21 forum, it's not difficult to upgrade to 2.0.17, there's plenty of help available here.  If you're just setting up a new forum, it makes no sense to attempt installing obsolete software.

I just installed 2.0.17. You can all set down your arguments now.

Offline shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 1,926
    • sbulen on GitHub
Re: 1.1.21 doesn't want to be installed
« Reply #13 on: March 26, 2020, 07:46:23 PM »
So you're back up & running?   If so, good news.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp