Advertisement:

Author Topic: Slow loading forum?  (Read 675 times)

Offline MobileCS

  • Jr. Member
  • **
  • Posts: 190
Slow loading forum?
« on: May 19, 2020, 12:10:59 PM »
Anyone else having issues just browsing this forum? It takes 2-3 seconds just for the page to load.

The issue has been getting progressively worse ever since you guys moved the servers to the new datacenter in April.

Page created in 1.579 seconds with 12 queries.

That looks high too .. I'm pretty sure I used to see 400-500 before the move.




Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 72,371
    • StoryBB/StoryBB on GitHub
Re: Slow loading forum?
« Reply #1 on: May 19, 2020, 12:40:58 PM »
Page created in 0.208 seconds with 22 queries.

Seems fast to me?

Offline Jeff Lewis

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,449
  • Gender: Male
Re: Slow loading forum?
« Reply #2 on: May 19, 2020, 12:48:30 PM »
Anyone else having issues just browsing this forum? It takes 2-3 seconds just for the page to load.

I do occasionally. Viewing the main index a few seconds ago took over 3 seconds to create the page for me. It's really hit or miss though like everything after it to get in here and reply has been speedy.

Online Deaks

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 22,342
  • Gender: Male
    • pouvik on GitHub
Re: Slow loading forum?
« Reply #3 on: May 19, 2020, 01:20:26 PM »
Page created in 0.102 seconds with 13 queries.

I have never had issues with this forum only issue I have is my desktop speed.

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 10,143
  • Hoarding Budweiser in NY
Re: Slow loading forum?
« Reply #4 on: May 19, 2020, 05:22:48 PM »
Forum has been consistently faster since April.  Haven't experienced any of the lag that was common before then.

Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 9,077
  • Gender: Male
  • Black cat rulz!
    • XinYenFon on GitHub
    • merta on LinkedIn
    • @XinYenFon on Twitter
    • wowsnips
Re: Slow loading forum?
« Reply #5 on: May 19, 2020, 05:28:40 PM »
Page created in 0.972 seconds with 17 queries.
Page created in 0.099 seconds with 16 queries.
Page created in 0.203 seconds with 12 queries.
You can support me via Twitch Prime* or Patreon.

[ Bastion ] # [ Lunarfall ] # [ RDD (HTML5) ]

* Twitch prime is an extra perk of your amazon prime subscription -no extra payment required-.

Offline Douglas

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,120
  • Gender: Male
  • Non sibi sed patriae
    • @BearlyDoug on Twitter
    • TheFan.net
Re: Slow loading forum?
« Reply #6 on: May 21, 2020, 10:34:57 AM »
Page created in 0.087 seconds with 17 queries.

I'm assuming SMF is on PHP7, which definitely helps. :)
Doug Hazard
* Full Stack (Web) Developer for The Catholic Diocese of Richmond
(20+ Diocesan sites, 130+ Church sites & 24 School sites)
* Sports Photographer and Media Personality
* CFB Historian
* Tech Admin for one 1M+ post, one 2M+ post and one 10M+ post sites (last two are powered by multiple servers)
* WordPress Developer (Junkie)

Offline JBlaze

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,166
  • Gender: Male
    • jason.p.clemons on Facebook
    • jasonclemons on GitHub
    • jasonclemons1 on LinkedIn
    • @fragicide on Twitter
    • clemons.io
Re: Slow loading forum?
« Reply #7 on: May 21, 2020, 10:41:48 AM »
Page created in 1.271 seconds with 9 queries.

It's been a tad slow for me as well. I wonder if it's more of a latency issue.
Jason Clemons
Former Team Member 2009 - 2012

Online SpacePhoenix

  • Jr. Member
  • **
  • Posts: 165
Re: Slow loading forum?
« Reply #8 on: May 21, 2020, 11:52:37 AM »
Only happens to me with the initial page load after having not visited it for a few hours, which makes me think it's something to do with the creation of sessions.

Offline Jeff Lewis

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,449
  • Gender: Male
Re: Slow loading forum?
« Reply #9 on: May 21, 2020, 12:25:04 PM »
Loading this thread right now: Page created in 2.351 seconds with 22 queries

Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 9,077
  • Gender: Male
  • Black cat rulz!
    • XinYenFon on GitHub
    • merta on LinkedIn
    • @XinYenFon on Twitter
    • wowsnips
Re: Slow loading forum?
« Reply #10 on: May 21, 2020, 02:26:28 PM »
Page created in 1.845 seconds with 23 queries.
Page created in 0.088 seconds with 16 queries.
You can support me via Twitch Prime* or Patreon.

[ Bastion ] # [ Lunarfall ] # [ RDD (HTML5) ]

* Twitch prime is an extra perk of your amazon prime subscription -no extra payment required-.

Offline Adrek

  • Sophist Member
  • *****
  • Posts: 1,080
  • Gender: Male
    • pages/smfpl/171860759503032 on Facebook
    • Adrek.pl
Re: Slow loading forum?
« Reply #11 on: May 26, 2020, 03:34:29 AM »
Right now I had this -> Page created in 22.515 seconds with 19 queries. But after that one long load it is fine again

//another one
Page created in 2.501 seconds with 13 queries.
Page served by: 10.0.100.135 (10.0.100.114)

both are forum homepage
« Last Edit: May 26, 2020, 04:04:36 AM by Adrek »
Polskie wsparcie SMF na simplemachines.org

the simplest solution is most likely the right one

Online SpacePhoenix

  • Jr. Member
  • **
  • Posts: 165
Re: Slow loading forum?
« Reply #12 on: May 26, 2020, 07:22:17 AM »
I just had one Page created in 3.287 seconds with 20 queries.

Offline Massl

  • Jr. Member
  • **
  • Posts: 288
Re: Slow loading forum?
« Reply #13 on: May 27, 2020, 09:27:46 AM »
And the winner is ...


Online SpacePhoenix

  • Jr. Member
  • **
  • Posts: 165
Re: Slow loading forum?
« Reply #14 on: May 27, 2020, 10:07:57 AM »
The slower loading of pages seems to be happening more often now. I'm getting pages loads of over 1 second more frequently. Has something about the server configuration been changed recently?

Offline CoreISP

  • Server Admin
  • Server Team
  • SMF Super Hero
  • *
  • Posts: 18,199
  • Gender: Male
  • Liroy van Hoewijk
    • coreisp on GitHub
    • liroyvh on LinkedIn
    • @liroyvh on Twitter
Re: Slow loading forum?
« Reply #15 on: Yesterday at 07:29:19 PM »
Thank you for all the reports, I've been monitoring it following this topic. Bit elusive as it isn't consistent and 99% of the time it's all happy 'n fast.
Found one aspect that could use some optimisation, so I'll implement that and see if it improves the slower responses.
((U + C + I)x(10 − S)) / 20xAx1 / (1 − sin(F / 10))
President/CEO of Simple Machines - Server Manager
Please do not PM for support - anything else is usually OK.

Offline Jeff Lewis

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,449
  • Gender: Male
Re: Slow loading forum?
« Reply #16 on: Yesterday at 07:41:00 PM »
Bit elusive as it isn't consistent and 99% of the time it's all happy 'n fast.

Easily 99% or more, it's just very odd times it slows down and usually only for one page load while the rest are fine.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 72,371
    • StoryBB/StoryBB on GitHub
Re: Slow loading forum?
« Reply #17 on: Yesterday at 07:43:49 PM »
When you next get a slow one, please also report the 'page served by' details, I'm wondering if it's only one node in the rotation maybe with something astray (e.g. a single node not using cache for some reason)

Online SpacePhoenix

  • Jr. Member
  • **
  • Posts: 165
Re: Slow loading forum?
« Reply #18 on: Yesterday at 07:45:11 PM »
Thank you for all the reports, I've been monitoring it following this topic. Bit elusive as it isn't consistent and 99% of the time it's all happy 'n fast.
Found one aspect that could use some optimisation, so I'll implement that and see if it improves the slower responses.
Does what ads are loaded get recorded for each page load? Maybe a bad ad perhaps?

Offline CoreISP

  • Server Admin
  • Server Team
  • SMF Super Hero
  • *
  • Posts: 18,199
  • Gender: Male
  • Liroy van Hoewijk
    • coreisp on GitHub
    • liroyvh on LinkedIn
    • @liroyvh on Twitter
Re: Slow loading forum?
« Reply #19 on: Yesterday at 08:07:29 PM »
Alright, changes pushed. Please let me know how it behaves for you. (Give the servers a couple of minutes from when I post this though, they'll be rebuilding some caches.)

And yes, reporting the "page served by" section can be helpful when you notice a substantial delay in the page load. :)
No it doesn't appear to have anything to do with the ads. (Plus that wouldn't affect the render times you see at the bottom here. :))
((U + C + I)x(10 − S)) / 20xAx1 / (1 − sin(F / 10))
President/CEO of Simple Machines - Server Manager
Please do not PM for support - anything else is usually OK.