• Welcome to Simple Machines Community Forum. Please login or sign up.
December 03, 2021, 05:42:01 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


PHP version

Started by Acorn, July 15, 2020, 11:10:35 AM

Previous topic - Next topic

Acorn

Hi

I have a forum that is version 2.0.13  (I know it needs updating, but that is not possible for the moment).  I need to know which PHP versions this will be OK    - I am currently on 5.6, and the site is running very slowly.  I have 7.0, 7.1, 7.2, and 7.3 available to me.

Many thanks.

shadav

upgrading from 2.0.13 to 2.0.17 is easy, just install the patches and you are done....
https://wiki.simplemachines.org/smf/Patching

I believe you can use 7.1, not entirely sure....
for 2.0.15 and above can use 7.2

but I doubt that will help with the site being slow....

d3vcho

From https://wiki.simplemachines.org/smf/SMF2.0:Requirements_and_recommendations

QuotePHP 4.1.0 or higher
Versions of SMF below 2.0.7 will not work on PHP 5.5. If you use PHP 5.5 it is necessary to use SMF 2.0.7 or greater.
Versions of SMF from 2.0.16 onwards require a version of PHP between 5.3 and 7.3. If you use PHP 5.3 or lower, it is necessary to use SMF 2.0.13 or lower or SMF 2.0.16 or higher. This is because 2.0.14 and 2.0.15 do not support PHP 5.3. PHP 7.4 is not supported by SMF at this time.
"Greeting Death as an old friend, they departed this life as equals"

Kindred

I don't think that 2.0.13 will work properly on PHP 7.0 (it may run, but I think it generates errors/warnings)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Acorn

Ideally I would update the software (which I understand is very quick - is that right?) but I am a little concerned that some add-ons might not work.

I think the real problem is with the host, but when we tried to migrate earlier this year we had problems with some coding that had been added prior to my involvement with the site. 

We have a lot to do, but my priority at the moment is to do anything possible to speed the site up and stop all the 500 errors.

I guess that if I change the PHP version to 7.0 and it generates errors I can always go back to 5.6 again.

Kindred

if you PATCH update, then there should be no problem with existing mods at 7.0.
(although, on consideration, several mods MIGHT need a mysql to mysqli update -- but that's related to the php version, not the updating of SMF.)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Arantor

Quote from: Kindred on July 15, 2020, 12:59:15 PM
if you PATCH update, then there should be no problem with existing mods at 7.0.
(although, on consideration, several mods MIGHT need a mysql to mysqli update -- but that's related to the php version, not the updating of SMF.)

Well, it sort of is the updating of SMF; the underlying functions for $smcFunc['db_query'] etc. were changed and if the mods aren't strictly using $smcFunc consistently, the update of SMF to cope with PHP changes will break them.
No good deed goes unpunished
All helpful urges should be circumvented

Acorn

Now that's why I'm scared of updating!  I'm fine with html and css, but php... scares me silly.

Sir Osis of Liver

You can unistall the mods, update to 2.0.17 and php 7, then reinstall current versions of the mods.
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Horme Gaming

also depending on the mods newer versions maybe available of the mods so may negate alot of the potential worries.  However ALWAYS backup your fles so if something does go awry then you can restore them easily.  That way  any custom coding you will still have and you can then apply manually if needbe

Advertisement: