• Welcome to Simple Machines Community Forum. Please login or sign up.

RSS error in Wordpress

Started by telstarfans.nl, July 28, 2020, 01:14:14 AM

Previous topic - Next topic

telstarfans.nl

After successfully getting the SMF RSS feed from my SMF message board to my Wordpress website, using several different RSS widgets, recently it has stopped working for all RSS-widgets and the following message now appears on my website (note, no errors reported in the admin-area):

RSS Error: A feed could not be found at  telstarfans dot nl/forum/index.php?type=rss;action=.xml;sa=recent;board=;c=;limit=5. A feed with an invalid mime type may fall victim to this error, or SimplePie was unable to auto-discover it.. Use force_feed() if you are certain this URL is a real feed.

The address reported in the error-message actually works, when I copy paste it to the browser. I have  feeling this error suddenly appeared after I did an update in SMF or Wordpress.


Arantor

No good deed goes unpunished
All helpful urges should be circumvented

telstarfans.nl

I addressed this in the Wordpress forums and they advised me to simply try another RSS feed in the widgets, so I tried the RSS feed to these SMF Forums and they work without any issue.

So it seems the specific feed of my SMF forum is not coming through. I also happened to notice that the link to my forum including www often does not work for longer periods, whereas the URL without www causes no problem. This might be related? I've tried ussing the RSS feed without www, but that did not solve it.

telstarfans.nl

The solution turned out to be: switch off the RSS function and then switch it on again. That simple. Not sure why it ever stopped working though.

Advertisement: