• Welcome to Simple Machines Community Forum. Please login or sign up.

Problème titre de sujet

Started by spleen682, September 04, 2020, 01:47:51 PM

Previous topic - Next topic

spleen682

Salut tout le monde

voila j'ai un problème très gênant, a chaque fois qu' un membre répond a un sujet cela me modifie le titre du sujet en ajoutant automatiquement "RE:"

Exemple:
S'il y a 6 réponses dans le sujet, j'obtient ce titre:

RE: RE: RE: RE: RE: RE: Problème titre de sujet

Je dois editer a la main chaque fois , très très gênant .
Quelqu' un peut m' aider s'il vous plait?

je suis sur SMF 2.0.17

bisane

Hello !
Pour obtenir autant de "re:", c'est qu'il doit y avoir des citations, non ?

spleen682

Justement pas
le forum est jeune , quand j' aurai des sujets a 40 réponses ca va être abominable, j'ai clairment pas envie de passé mon temps a editer els titres de tout les sujets du forum xD

Personne n' as déjà eu ce problème ?

spleen682

Voila exemple, sur ce forum les sujets des reponse il y a un "RE :", mais pas dans le titre initial, et il y a qu' un seul "RE :", peut importe le nombre de reponse au sujet.

moi ca me modifie le titre initial mais en plus ca rajoute un autre "Re :" a chaque réponse et j'arrive vraiment pas a corriger ca

SychO

Cela est dû soit à un mod, soit à des modifications personnalisées apportées à votre forum.

Quels mods avez-vous installés et avez-vous fait des modifications personnalisées sur le code source de votre forum?
Checkout My Themes:
-

Potato  •  Ackerman  •  SunRise  •  NightBreeze

spleen682

oui j' en ai quelques un

@mention members
SimpleColorizer
Recent Forum Topics Boardindex
Group Color in Posts and Profile
Remove "Last edit" mod
SMF Trader System

aucune personalisation a part ces mods et le theme

le truc en plus c'est que ca em change le titre du sujet visible dans la section et pas que sur le sujet

SychO

Quote
le truc en plus c'est que ca em change le titre du sujet visible dans la section et pas que sur le sujet

ça c'est intéressant, mais je ne comprends pas exactement ce que vous voulez dire, pourriez-vous fournir un lien vers un exemple?
Checkout My Themes:
-

Potato  •  Ackerman  •  SunRise  •  NightBreeze

maximus23

Bonsoir,

Comme ce genre de truc m'a expéré assez longtemps j'ai utilisé une solution radicale en supprimant les re :

Pour cela chose toute simple fichier de langue Themes/default/languages/index.french.......

Chercher :

$txt['response_prefix'] = 'Re : ';

remplacer par :

$txt['response_prefix'] = '';

Pour retirer les Re : faire une requête Sql de ce style :


UPDATE smf_messages SET subject = replace(subject, 'Re:', "");
UPDATE smf_messages SET subject = replace(subject, 'Re :', "");



Répéter la requête jusqu'a suppression des Re: ou Re :

Bon amusement :)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

spleen682

@maximus23 merci , énorme ca fonctionne

pour les requetes sql je vais m'en passé , comme dit plus haut le forum est jeune, je vais le faire a la main

problème résolu , merci a tous @bisane @SychO

alexetgus

C'est un très vieux problème ça.
Je suis surpris que SMF n'a pas corrigé ça dans la version 2.0.17, je pensais que ce bug était fixé depuis longtemps.
Ou alors tu n'es pas à jour.

Quelle prise de tête ce truc !
A l'époque, j'ai fait comme Max, directement au coeur du problème en virant ce "Re:" !

spleen682

Si si , a jour en plus
Trop content de la modif de Max, ca me prenais la tête ce truc.

ironside.legende

SMF: 2.0.18
SimplePortal:2.3.7

Paulo.chon

Je me demande si ça ne fonctionnerait pas correctement (i.e. en mettant un seul Re : aux réponses) si on remplaçait dans le fichier de langue Themes/default/languages/index.french.......


$txt['response_prefix'] = 'Re : ';
 par :

$txt['response_prefix'] = 'Re : ';
donc en remplaçant l'espace insécable par une espace ordinaire...

maximus23

Quote from: Paulo.chon on August 28, 2021, 04:55:28 PMdonc en remplaçant l'espace insécable par une espace ordinaire...
Bonjour,

Non il faut le remplacer par un vide ou alors mettre un regex sur le sujet.

On va au plus simple.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

ironside.legende

Quote from: maximus23 on September 04, 2020, 04:30:21 PMBonsoir,

Comme ce genre de truc m'a expéré assez longtemps j'ai utilisé une solution radicale en supprimant les re :

Pour cela chose toute simple fichier de langue Themes/default/languages/index.french.......

Chercher :

$txt['response_prefix'] = 'Re : ';
remplacer par :

$txt['response_prefix'] = '';
Pour retirer les Re : faire une requête Sql de ce style :

UPDATE smf_messages SET subject = replace(subject, 'Re:', "");
UPDATE smf_messages SET subject = replace(subject, 'Re :', "");


Répéter la requête jusqu'a suppression des Re: ou Re :

Bon amusement :)
pourvu que le prefix de table soit bien SMF_
ce qui n'est pas mon cas , si non oui ça marche  ;D
SMF: 2.0.18
SimplePortal:2.3.7

maximus23

Bonsoir,

Oui c'est vrai je devrais noter de mettre le préfixe du settings pour éviter toutes erreurs intempestives.

:) 
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Advertisement: